summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2016-01-26 13:09:22 -0600
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-01 00:11:35 -0500
commit663463da0c29e1f22b0740335d193f637174c104 (patch)
tree031da1c8165d53f9b63357a68a8c9bfa36b2ed00 /recipes-extended
parent5817c4a29b361812b87eddb2bbb623344dccbdc2 (diff)
downloadmeta-virtualization-663463da0c29e1f22b0740335d193f637174c104.tar.gz
xen: merge do_install_append to do_install
The do_install_append is necessary for the git build as well so just merge that into the main include. Signed-off-by: Doug Goldstein <cardoe@cardoe.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/xen/xen.inc8
-rw-r--r--recipes-extended/xen/xen_4.6.0.bb10
2 files changed, 8 insertions, 10 deletions
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc
index a46421b8..beb255c1 100644
--- a/recipes-extended/xen/xen.inc
+++ b/recipes-extended/xen/xen.inc
@@ -828,6 +828,14 @@ do_install() {
828 echo "d $i 0755 root root - -" >> ${D}${sysconfdir}/tmpfiles.d/xen.conf 828 echo "d $i 0755 root root - -" >> ${D}${sysconfdir}/tmpfiles.d/xen.conf
829 done 829 done
830 fi 830 fi
831
832 # fixup default path to qemu-system-i386
833 sed -i 's#\(test -z "$QEMU_XEN" && QEMU_XEN=\).*$#\1"/usr/bin/qemu-system-i386"#' ${D}/etc/init.d/xencommons
834
835 if [ -e ${D}${systemd_unitdir}/system/xen-qemu-dom0-disk-backend.service ]; then
836 sed -i 's#ExecStart=.*qemu-system-i386\(.*\)$#ExecStart=/usr/bin/qemu-system-i386\1#' \
837 ${D}${systemd_unitdir}/system/xen-qemu-dom0-disk-backend.service
838 fi
831} 839}
832 840
833pkg_postinst_${PN}-volatiles() { 841pkg_postinst_${PN}-volatiles() {
diff --git a/recipes-extended/xen/xen_4.6.0.bb b/recipes-extended/xen/xen_4.6.0.bb
index 93c6d2ef..0391dbd8 100644
--- a/recipes-extended/xen/xen_4.6.0.bb
+++ b/recipes-extended/xen/xen_4.6.0.bb
@@ -9,13 +9,3 @@ SRC_URI[md5sum] = "48e232f90927c08326a7b52bb06f49bc"
9SRC_URI[sha256sum] = "6fa1c2431df55aa5950d248e6093b8c8c0f11c357a0adbd348a2186478e80909" 9SRC_URI[sha256sum] = "6fa1c2431df55aa5950d248e6093b8c8c0f11c357a0adbd348a2186478e80909"
10 10
11S = "${WORKDIR}/xen-${PV}" 11S = "${WORKDIR}/xen-${PV}"
12
13do_install_append() {
14 # fixup default path to qemu-system-i386
15 sed -i 's#\(test -z "$QEMU_XEN" && QEMU_XEN=\).*$#\1"/usr/bin/qemu-system-i386"#' ${D}/etc/init.d/xencommons
16
17 if [ -e ${D}${systemd_unitdir}/system/xen-qemu-dom0-disk-backend.service ]; then
18 sed -i 's#ExecStart=.*qemu-system-i386\(.*\)$#ExecStart=/usr/bin/qemu-system-i386\1#' \
19 ${D}${systemd_unitdir}/system/xen-qemu-dom0-disk-backend.service
20 fi
21}