summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChris Patterson <cjp256@gmail.com>2013-11-07 20:47:58 -0500
committerChris Patterson <cjp256@gmail.com>2013-11-07 20:47:58 -0500
commit6296997516f275e3a12ebc42af732faf00557133 (patch)
tree1e630e80cdfdb0a4d9433ac844f129fc9f0993a7 /recipes-extended
parent0610ce0df2353b68a5131d381eb7a3baf34ab00e (diff)
downloadmeta-virtualization-6296997516f275e3a12ebc42af732faf00557133.tar.gz
xen: remove xen-hg recipe and patches
Signed-off-by: Chris Patterson <cjp256@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/xen/xen-hg.bb29
-rw-r--r--recipes-extended/xen/xen-hg/ioemu-cross-gl-check.patch29
-rw-r--r--recipes-extended/xen/xen-hg/tools_qemu_xen_remove_CFLAGS.patch48
3 files changed, 0 insertions, 106 deletions
diff --git a/recipes-extended/xen/xen-hg.bb b/recipes-extended/xen/xen-hg.bb
deleted file mode 100644
index bdb4d323..00000000
--- a/recipes-extended/xen/xen-hg.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1# A build of Xen Unstable from Mercurial
2
3# Build is not yet verified as functional
4# Setting BROKEN for now
5BROKEN = "1"
6
7inherit autotools
8
9require xen.inc
10
11DEPENDS += "yajl"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=e0f0f3ac55608719a82394cc353928df"
14
15SRCREV = "82db8de16530f016809264d3179823999d702849"
16
17SRC_URI = "hg://xenbits.xen.org;module=xen-unstable.hg;rev=d690c7e896a2 \
18 git://xenbits.xensource.com/qemu-xen-unstable.git \
19 file://ioemu-cross-gl-check.patch \
20 file://tools_qemu_xen_remove_CFLAGS.patch"
21
22SRC_URI[md5sum] = "2f3e36c96fe13cebc7475652c2803e14"
23SRC_URI[sha256sum] = "b63bc8d48aaf2688cff1417f99a140943e71de0777b28ed8cbba8aa018b4117c"
24
25S = "${WORKDIR}/xen-unstable.hg"
26
27#EXTRA_OECONF="--disable-pythontools"
28require xen-python.inc
29
diff --git a/recipes-extended/xen/xen-hg/ioemu-cross-gl-check.patch b/recipes-extended/xen/xen-hg/ioemu-cross-gl-check.patch
deleted file mode 100644
index 23497e21..00000000
--- a/recipes-extended/xen/xen-hg/ioemu-cross-gl-check.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1--- git/configure.sav 2012-04-06 12:08:07.891529546 -0600
2+++ xen-unstable.hg/../git/configure 2012-04-06 12:09:39.872923477 -0600
3@@ -289,7 +289,7 @@
4 kqemu="yes"
5 fi
6 fi
7- if test -f /usr/include/sys/soundcard.h ; then
8+ if test -f ${CROSS_SYS_ROOT}/usr/include/sys/soundcard.h ; then
9 audio_drv_list="oss"
10 fi
11 audio_possible_drivers="oss sdl"
12@@ -872,7 +872,7 @@
13 #endif
14 int main( void ) { return (int) glGetString(GL_EXTENSIONS); }
15 EOF
16-if $cc $ARCH_CFLAGS -o $TMPE `$sdl_config --cflags --libs 2> /dev/null` -I/usr/include/GL $TMPC -lXext -lGL 2> /dev/null
17+if $cc $ARCH_CFLAGS -o $TMPE `$sdl_config --cflags --libs 2> /dev/null` -I${CROSS_SYS_ROOT}/usr/include/GL $TMPC -lXext -lGL 2> /dev/null
18 then
19 opengl="yes"
20 else
21@@ -1450,7 +1450,7 @@
22 then
23 echo "#define CONFIG_OPENGL 1" >> $config_h
24 echo "CONFIG_OPENGL=yes" >> $config_mak
25- echo "SDL_CFLAGS+=-I/usr/include/GL" >> $config_mak
26+ echo "SDL_CFLAGS+=-I${CROSS_SYS_ROOT}/usr/include/GL" >> $config_mak
27 echo "SDL_LIBS+=-lXext" >> $config_mak
28 echo "SDL_LIBS+=-lGL" >> $config_mak
29 fi
diff --git a/recipes-extended/xen/xen-hg/tools_qemu_xen_remove_CFLAGS.patch b/recipes-extended/xen/xen-hg/tools_qemu_xen_remove_CFLAGS.patch
deleted file mode 100644
index 5fd01480..00000000
--- a/recipes-extended/xen/xen-hg/tools_qemu_xen_remove_CFLAGS.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1# HG changeset patch
2# User Olaf Hering <olaf@xxxxxxxxx>
3# Date 1330015545 -3600
4# Node ID 5bdbdcb03d60a7b58f41306ef39cb988100efbe4
5# Parent 56214b978466914c1b9f8adb1158a3217a823e42
6tools/qemu-xen: remove CFLAGS for qemu build
7
8Currently qemu-xen gets build with CFLAGS only if CFLAGS was already in
9the environment during make invocation. If CFLAGS is in environment then
10make will append all of the various flags specified in xen Makefiles,
11which is then passed to qemu configure. If CFLAGS is not set, then
12configure will use just "-O2 -g" because make does not export its own
13CFLAGS variable.
14
15To make qemu-xen build consistent this change removes CFLAGS from the
16environment so that only the CFLAGS from qemu configure script will be
17used. This matches what is done in kvm.rpm and qemu.rpm where for
18example RPM_OPT_FLAGS is not passes as CFLAGS. Otherwise those packages
19would not build as well.
20
21Passing makes CFLAGS to configure will lead to build errors:
22- xen Makefiles append -std=gnu99, this breaks qemu build due to a bug
23 in header file:
24fpu/softfloat-specialize.h:107: error: initializer element is not constant
25- in 32bit builds, qemus configure script will append -mcpu=i486 in an
26 odd way, which leads to unknown gcc cmdline options due to a missing
27 space
28- xen Makefiles will append -Wall which will expose all sorts of style
29 issues in the qemu code
30- in one case some of the asm() blocks will not compile with gcc 4.6 in
31 openSuSE 12.1
32
33Until upstream qemu has fixed all these issues use no extra CFLAGS to
34configure qemu-xen.
35
36Signed-off-by: Olaf Hering <olaf@xxxxxxxxx>
37
38diff -r 56214b978466 -r 5bdbdcb03d60 tools/Makefile
39--- a/tools/Makefile
40+++ b/tools/Makefile
41@@ -146,6 +146,7 @@
42 source=.; \
43 fi; \
44 cd qemu-xen-dir; \
45+ env -u CFLAGS
46 $$source/configure --enable-xen --target-list=i386-softmmu \
47 --source-path=$$source \
48 --extra-cflags="-I$(XEN_ROOT)/tools/include \