summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authormingli.yu@windriver.com <mingli.yu@windriver.com>2016-07-14 17:48:27 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-07-15 11:02:53 -0400
commit59c338afc3124d11656366b7e1dbdba279e21422 (patch)
tree0a63ae77cf06ea15d4eb348395837fd2c7b1a7c2 /recipes-extended
parentb657b65354d3146e7a2165a6818c8724ea4f28b9 (diff)
downloadmeta-virtualization-59c338afc3124d11656366b7e1dbdba279e21422.tar.gz
iasl: Upgrade to 20160527 from 20120215
* Upgrade iasl from 20120215 to 20160527 * Fix the dependency as it actually depends on bison-native and flex-native * Remove hardcode PR to let PR server handle the version * Add (x86_64.*|i.86.*)-linux to COMPATIBLE_HOST * Add patch Make-CC-definition-conditional.patch to make CC definition conditional as it makes the package unable to cross-compile when hardcode CC's definition previously. * Add iasl command manual file as iasl.1 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/iasl/iasl/Make-CC-definition-conditional.patch29
-rw-r--r--recipes-extended/iasl/iasl/iasl.1135
-rw-r--r--recipes-extended/iasl/iasl_20120215.bb29
-rw-r--r--recipes-extended/iasl/iasl_20160527.bb36
4 files changed, 200 insertions, 29 deletions
diff --git a/recipes-extended/iasl/iasl/Make-CC-definition-conditional.patch b/recipes-extended/iasl/iasl/Make-CC-definition-conditional.patch
new file mode 100644
index 00000000..f69a36c6
--- /dev/null
+++ b/recipes-extended/iasl/iasl/Make-CC-definition-conditional.patch
@@ -0,0 +1,29 @@
1[PATCH] Make CC definition conditional
2
3Upstream-Status: pending
4
5By hardcoding CC's definition to gcc, make this packages unable to
6cross-compile. the -e options of make can not override the CC since
7it is not defined in Makefile, but in Makefile.config
8
9Signed-off-by: Roy.Li <rongqing.li@windriver.com>
10---
11 generate/unix/Makefile.config | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/generate/unix/Makefile.config b/generate/unix/Makefile.config
15index 8d41399..72d597d 100644
16--- a/generate/unix/Makefile.config
17+++ b/generate/unix/Makefile.config
18@@ -35,7 +35,7 @@
19 .SUFFIXES :
20 PROGS = acpibin acpidump acpiexamples acpiexec acpihelp acpinames acpisrc acpixtract iasl
21 HOST ?= _CYGWIN
22-CC = gcc
23+CC ?= gcc
24
25 #
26 # Common defines
27--
281.9.1
29
diff --git a/recipes-extended/iasl/iasl/iasl.1 b/recipes-extended/iasl/iasl/iasl.1
new file mode 100644
index 00000000..000a3b81
--- /dev/null
+++ b/recipes-extended/iasl/iasl/iasl.1
@@ -0,0 +1,135 @@
1.\" First parameter, NAME, should be all caps
2.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
3.\" other parameters are allowed: see man(7), man(1)
4.TH IASL 1 "October 14, 2005"
5.\" Please adjust this date whenever revising the manpage.
6.\"
7.\" Some roff macros, for reference:
8.\" .nh disable hyphenation
9.\" .hy enable hyphenation
10.\" .ad l left justify
11.\" .ad b justify to both left and right margins
12.\" .nf disable filling
13.\" .fi enable filling
14.\" .br insert line break
15.\" .sp <n> insert n+1 empty lines
16.\" for manpage-specific macros, see man(7)
17.SH NAME
18iasl \- ACPI Source Language compiler/decompiler
19.SH SYNOPSIS
20.B iasl
21.RI [ options ]
22.RI [ "input file" ]
23.SH DESCRIPTION
24This manual page documents briefly the
25.B iasl
26command. The option list is taken from the iasl interactive help.
27.PP
28.\" TeX users may be more comfortable with the \fB<whatever>\fP and
29.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
30.\" respectively.
31.B iasl
32is an ASL compiler and decompiler.
33
34.SH OPTIONS
35
36.PP
37.SS General Output
38.TP
39.B \-p <prefix>
40Specify filename prefix for all output files (including .aml)
41.TP
42.B \-vi
43Less verbose errors and warnings for use with IDEs
44.TP
45.B \-vo
46Enable optimization comments
47.TP
48.B \-vr
49Disable remarks
50.TP
51.B \-vs
52Disable signon
53
54.PP
55.SS AML Output Files
56.TP
57.B \-s<a|c>
58Create AML in assembler or C source file (*.asm or *.c)
59.TP
60.B \-i<a|c>
61Create assembler or C include file (*.inc or *.h)
62.TP
63.B \-t<a|c>
64Create AML in assembler or C hex table (*.hex)
65
66.PP
67.SS AML Code Generation
68.TP
69.B \-oa
70Disable all optimizations (compatibility mode)
71.TP
72.B \-of
73Disable constant folding
74.TP
75.B \-oi
76Disable integer optimization to Zero/One/Ones
77.TP
78.B \-on
79Disable named reference string optimization
80.TP
81.B \-r<Revision>
82Override table header Revision (1-255)
83
84.PP
85.SS Listings
86.TP
87.B \-l
88Create mixed listing file (ASL source and AML) (*.lst)
89.TP
90.B \-ln
91Create namespace file (*.nsp)
92.TP
93.B \-ls
94Create combined source file (expanded includes) (*.src)
95
96.PP
97.SS AML Disassembler
98.TP
99.B \-d [file]
100Disassemble AML to ASL source code file (*.dsl)
101.TP
102.B \-dc [file]
103Disassemble AML and immediately compile it
104.br
105(Obtain DSDT from current system if no input file)
106.TP
107.B \-e
108Generate External() statements for unresolved symbols
109.TP
110.B \-g
111Get ACPI tables and write to files (*.dat)
112
113.PP
114.SS Miscellaneous
115.TP
116.B \-a
117Verify source file is entirely ASCII text (0x00-0x7F)
118
119.PP
120.SS Help
121.TP
122.B \-h
123Additional help and compiler debug options
124.TP
125.B \-hc
126Display operators allowed in constant expressions
127.TP
128.B \-hr
129Display ACPI reserved method names
130
131.SH AUTHOR
132iasl was written by Robert Moore <robert.moore@intel.com>.
133.PP
134This manual page was written by Mattia Dongili <malattia@debian.org>,
135for the Debian project (but may be used by others).
diff --git a/recipes-extended/iasl/iasl_20120215.bb b/recipes-extended/iasl/iasl_20120215.bb
deleted file mode 100644
index 5ce09300..00000000
--- a/recipes-extended/iasl/iasl_20120215.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1DESCRIPTION = "This is a cross development C compiler, assembler and linker environment for the production of 8086 executables (Optionally MSDOS COM)"
2HOMEPAGE = "http://www.acpica.org/"
3LICENSE = "Intel-ACPI"
4LIC_FILES_CHKSUM = "file://asldefine.h;endline=115;md5=d4d7cf809b8b5e03131327b3f718e8f0"
5SECTION = "console/tools"
6PR="r1"
7
8DEPENDS="flex bison"
9
10SRC_URI="https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "324c89e5bb9002e2711e0494290ceacc"
13SRC_URI[sha256sum] = "b2b497415f29ddbefe7be8b9429b62c1f1f6e1ec11456928e4e7da86578e5b8d"
14
15S="${WORKDIR}/acpica-unix-${PV}/source/compiler"
16
17NATIVE_INSTALL_WORKS = "1"
18BBCLASSEXTEND = "native"
19
20do_compile() {
21 CFLAGS="-Wno-error=redundant-decls" $MAKE
22}
23
24do_install() {
25 mkdir -p ${D}${prefix}/bin
26 cp ${S}/iasl ${D}${prefix}/bin
27}
28
29
diff --git a/recipes-extended/iasl/iasl_20160527.bb b/recipes-extended/iasl/iasl_20160527.bb
new file mode 100644
index 00000000..62e83c47
--- /dev/null
+++ b/recipes-extended/iasl/iasl_20160527.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Intel ASL compiler/decompiler"
2DESCRIPTION = "This is a cross development C compiler, assembler and linker environment for the production of 8086 executables (Optionally MSDOS COM)"
3HOMEPAGE = "http://www.acpica.org/"
4LICENSE = "Intel-ACPI"
5LIC_FILES_CHKSUM = "file://source/compiler/aslcompiler.h;beginline=7;endline=114;md5=09f82edcd148ab4c8aa554bc3e9d0676"
6SECTION = "console/tools"
7
8DEPENDS = "bison-native flex-native"
9
10SRC_URI = "https://www.acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz \
11 file://iasl.1 \
12 file://Make-CC-definition-conditional.patch \
13"
14
15SRC_URI[md5sum] = "be677fc358de9dadc036e1ea678a101b"
16SRC_URI[sha256sum] = "6b681732624de1eb58b2bcf1c7ef0744ba14ed35fcaa534d4421574782fbb848"
17
18S = "${WORKDIR}/acpica-unix-${PV}/"
19
20BBCLASSEXTEND = "native"
21CFLAGS += "-D_LINUX -DACPI_ASL_COMPILER -I../include -I../compiler"
22
23COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
24
25# By setting NOOPT we suppress forcing -O2 and setting _FORTIFY_SOURCE=2. Let the
26# optimization and security cflags set them.
27#
28do_compile() {
29 oe_runmake iasl NOOPT=TRUE NOFORTIFY=TRUE
30}
31
32do_install() {
33 install -d ${D}${bindir} ${D}${mandir}/man1
34 install -m 0755 ${S}/generate/unix/bin/iasl ${D}${bindir}
35 install -m 0644 ${WORKDIR}/iasl.1 ${D}${mandir}/man1
36}