summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-06-29 11:51:03 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-06-30 11:19:02 -0400
commit449cfdef60371c2f45bf958303c2e7c7ba932a22 (patch)
treeb3409871b6327872ff08cebc82e67493da37d232 /recipes-extended
parent5c1388998d8c3abdd3e66f02408f6d0569d68c7e (diff)
downloadmeta-virtualization-449cfdef60371c2f45bf958303c2e7c7ba932a22.tar.gz
dev86: work on all hosts, other cleanups
Remove COMPATIBLE_HOST, whilst this is an x86 assembler there's nothing to stop you building it on or for arm64 and assembling x86 code. Override INEXE so that binaries are not stripped and remove INSANE_SKIP. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/dev86/dev86_git.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/recipes-extended/dev86/dev86_git.bb b/recipes-extended/dev86/dev86_git.bb
index 9488d906..ad7a0dfd 100644
--- a/recipes-extended/dev86/dev86_git.bb
+++ b/recipes-extended/dev86/dev86_git.bb
@@ -21,7 +21,7 @@ S = "${WORKDIR}/git"
21DEPENDS = "gperf-native dev86-native" 21DEPENDS = "gperf-native dev86-native"
22 22
23BBCLASSEXTEND = "native" 23BBCLASSEXTEND = "native"
24EXTRA_OEMAKE = "VERSION=${BASE_PV} PREFIX=${prefix} DIST=${D} LDFLAGS='${LDFLAGS}'" 24EXTRA_OEMAKE = "VERSION=${BASE_PV} PREFIX=${prefix} DIST=${D} LDFLAGS='${LDFLAGS}' INEXE=''"
25 25
26do_compile() { 26do_compile() {
27 # always regenerate token1.h, token2.h for deterministic behavior 27 # always regenerate token1.h, token2.h for deterministic behavior
@@ -45,7 +45,4 @@ do_install_append_class-native() {
45 install -v -m 755 ${B}/ifdefg ${D}${bindir} 45 install -v -m 755 ${B}/ifdefg ${D}${bindir}
46} 46}
47 47
48COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
49FILES_${PN} += "${libdir}/bcc" 48FILES_${PN} += "${libdir}/bcc"
50
51INSANE_SKIP_${PN} = "already-stripped"