summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 15:50:46 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 15:53:49 +0000
commit407b82206812c2e6d00f1a73754545351372f2ea (patch)
treeefcf6461e59fda86042a47010e9e1f61fec73aad /recipes-extended
parent7e9c4e6a469ca3ede7265ce91aac52514040758e (diff)
downloadmeta-virtualization-407b82206812c2e6d00f1a73754545351372f2ea.tar.gz
libvirt: make python3 safe
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/libvirt/libvirt-python.inc4
-rw-r--r--recipes-extended/libvirt/libvirt_5.5.0.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc
index 796d6dd8..02fca548 100644
--- a/recipes-extended/libvirt/libvirt-python.inc
+++ b/recipes-extended/libvirt/libvirt-python.inc
@@ -1,11 +1,11 @@
1inherit pythonnative python-dir 1inherit python3native python3-dir
2 2
3export STAGING_INCDIR 3export STAGING_INCDIR
4export STAGING_LIBDIR 4export STAGING_LIBDIR
5export BUILD_SYS 5export BUILD_SYS
6export HOST_SYS 6export HOST_SYS
7 7
8RDEPENDS_${PN}-python += "python" 8RDEPENDS_${PN}-python += "python3"
9PACKAGECONFIG_${PN}-python[xen] = ",,,xen-python" 9PACKAGECONFIG_${PN}-python[xen] = ",,,xen-python"
10 10
11PACKAGES += "${PN}-python-staticdev ${PN}-python-dev ${PN}-python-dbg ${PN}-python" 11PACKAGES += "${PN}-python-staticdev ${PN}-python-dev ${PN}-python-dbg ${PN}-python"
diff --git a/recipes-extended/libvirt/libvirt_5.5.0.bb b/recipes-extended/libvirt/libvirt_5.5.0.bb
index 53f4b3e3..0a3fdeea 100644
--- a/recipes-extended/libvirt/libvirt_5.5.0.bb
+++ b/recipes-extended/libvirt/libvirt_5.5.0.bb
@@ -226,7 +226,7 @@ PACKAGECONFIG[dtrace] = "--with-dtrace,--without-dtrace,,"
226PACKAGECONFIG[udev] = "--with-udev --with-pciaccess,--without-udev,udev libpciaccess," 226PACKAGECONFIG[udev] = "--with-udev --with-pciaccess,--without-udev,udev libpciaccess,"
227PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux," 227PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux,"
228PACKAGECONFIG[ebtables] = "ac_cv_path_EBTABLES_PATH=/sbin/ebtables,ac_cv_path_EBTABLES_PATH=,ebtables,ebtables" 228PACKAGECONFIG[ebtables] = "ac_cv_path_EBTABLES_PATH=/sbin/ebtables,ac_cv_path_EBTABLES_PATH=,ebtables,ebtables"
229PACKAGECONFIG[python] = ",,python," 229PACKAGECONFIG[python] = ",,python3,"
230PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,cyrus-sasl" 230PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,cyrus-sasl"
231PACKAGECONFIG[iproute2] = "ac_cv_path_IP_PATH=/sbin/ip,ac_cv_path_IP_PATH=,iproute2,iproute2" 231PACKAGECONFIG[iproute2] = "ac_cv_path_IP_PATH=/sbin/ip,ac_cv_path_IP_PATH=,iproute2,iproute2"
232PACKAGECONFIG[numactl] = "--with-numactl,--without-numactl,numactl," 232PACKAGECONFIG[numactl] = "--with-numactl,--without-numactl,numactl,"