summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorMichal Orzel <michal.orzel@amd.com>2023-01-06 15:46:29 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-01-10 13:58:07 -0500
commit3581dd56aa97ae17b480692aeb733ca0d1fa0eec (patch)
treeec7aa8081b5b99ecb257a4d5d2a17b3940a91b40 /recipes-extended
parent7da4dbde60eb6d17d39da61bbc20c2682987507f (diff)
downloadmeta-virtualization-3581dd56aa97ae17b480692aeb733ca0d1fa0eec.tar.gz
xen: Add recipes for stable Xen 4.17 release and update master
Add recipes for xen and tools for the newly released 4.17 version and take the opportunity to update master recipes. Reflect 4.17 tools changes in xen-tools.inc: - add test-paging-mempool to test package, - add init-dom0less script to xl package, - add localstatedir to xencommons package (this is needed as from 4.17 onwards, there is no /var/lib/xenstored resulting in /var being installed but not shipped in any package). Reviewed-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Michal Orzel <michal.orzel@amd.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/xen/xen-tools.inc3
-rw-r--r--recipes-extended/xen/xen-tools_4.17.bb19
-rw-r--r--recipes-extended/xen/xen-tools_git.bb8
-rw-r--r--recipes-extended/xen/xen_4.17.bb19
-rw-r--r--recipes-extended/xen/xen_git.bb8
5 files changed, 49 insertions, 8 deletions
diff --git a/recipes-extended/xen/xen-tools.inc b/recipes-extended/xen/xen-tools.inc
index d47309a7..95da2bfb 100644
--- a/recipes-extended/xen/xen-tools.inc
+++ b/recipes-extended/xen/xen-tools.inc
@@ -616,6 +616,7 @@ FILES:${PN}-xl = "\
616 ${libdir}/xen/bin/libxl-save-helper \ 616 ${libdir}/xen/bin/libxl-save-helper \
617 ${sbindir}/xl \ 617 ${sbindir}/xl \
618 ${libdir}/xen/bin/xen-init-dom0 \ 618 ${libdir}/xen/bin/xen-init-dom0 \
619 ${libdir}/xen/bin/init-dom0less \
619 " 620 "
620 621
621FILES:${PN}-xl-examples = "\ 622FILES:${PN}-xl-examples = "\
@@ -658,6 +659,7 @@ FILES:${PN}-xencommons += "\
658 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/xen-init-dom0.service', '', d)} \ 659 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/xen-init-dom0.service', '', d)} \
659 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/xenstored.service', '', d)} \ 660 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/xenstored.service', '', d)} \
660 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/var-lib-xenstored.mount', '', d)} \ 661 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/var-lib-xenstored.mount', '', d)} \
662 ${localstatedir} \
661 " 663 "
662 664
663FILES:${PN}-xend += " \ 665FILES:${PN}-xend += " \
@@ -688,6 +690,7 @@ FILES:${PN}-test += "\
688 ${libdir}/xen/bin/test-resource \ 690 ${libdir}/xen/bin/test-resource \
689 ${libdir}/xen/bin/test-cpu-policy \ 691 ${libdir}/xen/bin/test-cpu-policy \
690 ${libdir}/xen/bin/test-tsx \ 692 ${libdir}/xen/bin/test-tsx \
693 ${libdir}/xen/bin/test-paging-mempool \
691 " 694 "
692 695
693# test-xenstore and test-resource currently only exist in 4.16 696# test-xenstore and test-resource currently only exist in 4.16
diff --git a/recipes-extended/xen/xen-tools_4.17.bb b/recipes-extended/xen/xen-tools_4.17.bb
new file mode 100644
index 00000000..0f323cb3
--- /dev/null
+++ b/recipes-extended/xen/xen-tools_4.17.bb
@@ -0,0 +1,19 @@
1# xen 4.17.0 release sha
2SRCREV ?= "11560248ffda3f00f20bbdf3ae088af474f7f2a3"
3
4XEN_REL ?= "4.17"
5XEN_BRANCH ?= "stable-${XEN_REL}"
6
7SRC_URI = " \
8 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
9 file://0001-python-pygrub-pass-DISTUTILS-xen-4.15.patch \
10 "
11
12LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9"
13
14PV = "${XEN_REL}+stable${SRCPV}"
15
16S = "${WORKDIR}/git"
17
18require xen.inc
19require xen-tools.inc
diff --git a/recipes-extended/xen/xen-tools_git.bb b/recipes-extended/xen/xen-tools_git.bb
index a450a7d6..fd42cf29 100644
--- a/recipes-extended/xen/xen-tools_git.bb
+++ b/recipes-extended/xen/xen-tools_git.bb
@@ -1,7 +1,7 @@
1# master status on 2022-04-05 1# master status on 2022-12-29
2SRCREV ?= "14dd241aad8af447680ac73e8579990e2c09c1e7" 2SRCREV ?= "7eef80e06ed2282bbcec3619d860c6aacb0515d8"
3 3
4XEN_REL ?= "4.17" 4XEN_REL ?= "4.18"
5XEN_BRANCH ?= "master" 5XEN_BRANCH ?= "master"
6 6
7SRC_URI = " \ 7SRC_URI = " \
@@ -9,7 +9,7 @@ SRC_URI = " \
9 file://0001-python-pygrub-pass-DISTUTILS-xen-4.15.patch \ 9 file://0001-python-pygrub-pass-DISTUTILS-xen-4.15.patch \
10 " 10 "
11 11
12LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" 12LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9"
13 13
14PV = "${XEN_REL}+git${SRCPV}" 14PV = "${XEN_REL}+git${SRCPV}"
15 15
diff --git a/recipes-extended/xen/xen_4.17.bb b/recipes-extended/xen/xen_4.17.bb
new file mode 100644
index 00000000..f35689d4
--- /dev/null
+++ b/recipes-extended/xen/xen_4.17.bb
@@ -0,0 +1,19 @@
1# xen 4.17.0 release sha
2SRCREV ?= "11560248ffda3f00f20bbdf3ae088af474f7f2a3"
3
4XEN_REL ?= "4.17"
5XEN_BRANCH ?= "stable-${XEN_REL}"
6
7SRC_URI = " \
8 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \
10 "
11
12LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9"
13
14PV = "${XEN_REL}+stable${SRCPV}"
15
16S = "${WORKDIR}/git"
17
18require xen.inc
19require xen-hypervisor.inc
diff --git a/recipes-extended/xen/xen_git.bb b/recipes-extended/xen/xen_git.bb
index ebd1b76f..21384244 100644
--- a/recipes-extended/xen/xen_git.bb
+++ b/recipes-extended/xen/xen_git.bb
@@ -1,7 +1,7 @@
1# master status on 2022-04-05 1# master status on 2022-12-29
2SRCREV ?= "14dd241aad8af447680ac73e8579990e2c09c1e7" 2SRCREV ?= "7eef80e06ed2282bbcec3619d860c6aacb0515d8"
3 3
4XEN_REL ?= "4.17" 4XEN_REL ?= "4.18"
5XEN_BRANCH ?= "master" 5XEN_BRANCH ?= "master"
6 6
7SRC_URI = " \ 7SRC_URI = " \
@@ -9,7 +9,7 @@ SRC_URI = " \
9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ 9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \
10 " 10 "
11 11
12LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" 12LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9"
13 13
14PV = "${XEN_REL}+git${SRCPV}" 14PV = "${XEN_REL}+git${SRCPV}"
15 15