summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2016-07-31 22:00:11 -0700
committerBruce Ashfield <bruce@zedd.org>2016-08-04 21:45:04 -0400
commit357ca45fb122f71379636f1fa91e95fa2666c93d (patch)
tree2601c6ec6bbe242fd1d64170e0501771e19c6d75 /recipes-extended
parentf7fd44846101f1102ad382390bf60812b615c66a (diff)
downloadmeta-virtualization-357ca45fb122f71379636f1fa91e95fa2666c93d.tar.gz
libvirt: fix python install in multilib case.
Currently libvirt python builds in the multilib case, but fails to install. Switch from PN to BPN, and fix compile to be consistent. Signed-off-by: Bruce Ashfield <bruce@zedd.org>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/libvirt/libvirt-python.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc
index 405d5f74..7a7a4cc5 100644
--- a/recipes-extended/libvirt/libvirt-python.inc
+++ b/recipes-extended/libvirt/libvirt-python.inc
@@ -42,14 +42,14 @@ python __anonymous () {
42 42
43do_compile_append() { 43do_compile_append() {
44 if [ "${LIBVIRT_PYTHON_ENABLE}" = "1" ]; then 44 if [ "${LIBVIRT_PYTHON_ENABLE}" = "1" ]; then
45 cd ${WORKDIR}/libvirt-python-${PV} && \ 45 cd ${WORKDIR}/${BPN}-python-${PV} && \
46 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build 46 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build
47 fi 47 fi
48} 48}
49 49
50do_install_append() { 50do_install_append() {
51 if [ "${LIBVIRT_PYTHON_ENABLE}" = "1" ]; then 51 if [ "${LIBVIRT_PYTHON_ENABLE}" = "1" ]; then
52 cd ${WORKDIR}/${PN}-python-${PV} && \ 52 cd ${WORKDIR}/${BPN}-python-${PV} && \
53 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py install \ 53 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py install \
54 --install-lib=${D}/${PYTHON_SITEPACKAGES_DIR} ${LIBVIRT_INSTALL_ARGS} 54 --install-lib=${D}/${PYTHON_SITEPACKAGES_DIR} ${LIBVIRT_INSTALL_ARGS}
55 fi 55 fi