summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-02-09 14:09:26 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-11 09:41:07 -0500
commit2cec3442c6c34b32f18c0bd37961127d61d4a7af (patch)
tree6deac4d54beddc2e321838fdf4a842e7343c6198 /recipes-extended
parent0d2f0e570b471d91728b1571658d33b044370542 (diff)
downloadmeta-virtualization-2cec3442c6c34b32f18c0bd37961127d61d4a7af.tar.gz
libvirt: fix .la QA errors
oe-core 3739aaf644 [insane: Fix populate_sysroot sanity test path] means that .la files are subject to a QA sanity check that fails if the build paths (workdir) are found. The ptest and main libvirt files have silently had this issue with hosts paths. One fix is to remove the .la files, but this could impact on target test and builds, so our first attempt to fix them is to follow the lead of a similar lttng_tools fix, and modify .la files to have paths and values that are valid on target. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/libvirt/libvirt_1.2.19.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.2.19.bb b/recipes-extended/libvirt/libvirt_1.2.19.bb
index df53d59a..9a58be2c 100644
--- a/recipes-extended/libvirt/libvirt_1.2.19.bb
+++ b/recipes-extended/libvirt/libvirt_1.2.19.bb
@@ -249,6 +249,11 @@ do_install_append() {
249 249
250 # Add hook support for libvirt 250 # Add hook support for libvirt
251 mkdir -p ${D}/etc/libvirt/hooks 251 mkdir -p ${D}/etc/libvirt/hooks
252
253 # remove .la references to our working diretory
254 for i in `find ${D}${libdir} -type f -name *.la`; do
255 sed -i -e 's#-L${B}/src/.libs##g' $i
256 done
252} 257}
253 258
254EXTRA_OECONF += " \ 259EXTRA_OECONF += " \
@@ -263,6 +268,11 @@ do_compile_ptest() {
263 268
264do_install_ptest() { 269do_install_ptest() {
265 oe_runmake -C tests install-ptest 270 oe_runmake -C tests install-ptest
271
272 # Update libdir references in copied .la files
273 for i in `find ${D}${PTEST_PATH} -type f -name *.la`; do
274 sed -i -e 's#${B}#${PTEST_PATH}#g' $i
275 done
266} 276}
267 277
268pkg_postinst_libvirt() { 278pkg_postinst_libvirt() {