summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-04 11:25:58 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-06 20:36:34 -0400
commit27f8c49f8ca3c3365fe72d82ec0ed13fae9642e0 (patch)
treeca22ffa5db56fb8e27f607ff66bf37b95852d94e /recipes-extended
parentf108906d2bdcdc34813e7103c36ee618aba33e6d (diff)
downloadmeta-virtualization-27f8c49f8ca3c3365fe72d82ec0ed13fae9642e0.tar.gz
dev86: fix ldflags QA issue by passing LDFLAGS
ERROR: dev86-0.16.21-r0 do_package_qa: QA Issue: File /usr/lib/bcc/unproto in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/lib/bcc/bcc-cpp in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/lib/bcc/copt in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/lib/bcc/bcc-cc1 in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/bin/ld86 in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/bin/ar86 in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/bin/size86 in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/bin/nm86 in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/bin/as86 in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/bin/objdump86 in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) File /usr/bin/bcc in package dev86 doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags] ERROR: dev86-0.16.21-r0 do_package_qa: QA run found fatal errors. Please consider fixing them. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/dev86/dev86_0.16.21.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-extended/dev86/dev86_0.16.21.bb b/recipes-extended/dev86/dev86_0.16.21.bb
index d38f7bda..cf64a9d1 100644
--- a/recipes-extended/dev86/dev86_0.16.21.bb
+++ b/recipes-extended/dev86/dev86_0.16.21.bb
@@ -10,10 +10,11 @@ SRC_URI = "git://github.com/lkundrak/${BPN}.git;protocol=https"
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12BBCLASSEXTEND = "native" 12BBCLASSEXTEND = "native"
13EXTRA_OEMAKE = "VERSION=${PV} PREFIX=${prefix} DIST=${D}" 13EXTRA_OEMAKE = "VERSION=${PV} PREFIX=${prefix} DIST=${D} LDFLAGS='${LDFLAGS}'"
14 14
15do_compile() { 15do_compile() {
16 16 # ${S}/Makefile does respect LDFLAGS, but ${S}/cpp/Makefile doesn't when building bcc-cpp
17 sed -i 's#$(CC) $(CFLAGS) -o bcc-cpp#$(CC) $(CFLAGS) $(LDFLAGS) -o bcc-cpp#g' ${S}/cpp/Makefile
17 oe_runmake make.fil 18 oe_runmake make.fil
18 oe_runmake -f make.fil bcc86 as86 ld86 19 oe_runmake -f make.fil bcc86 as86 ld86
19 20