summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorStefan Agner <stefan@agner.ch>2016-09-06 11:51:40 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-09-07 16:06:56 -0400
commit222f8d486dceba3744dde79fd004292ea824124b (patch)
tree7f83cfe4b96d17b88ddf9e62271c8cd2808fba69 /recipes-extended
parenta3766e464d3ce0e7a57b61b2cca369d4429baa34 (diff)
downloadmeta-virtualization-222f8d486dceba3744dde79fd004292ea824124b.tar.gz
kvmtool: add lightweight hypervisor native Linux KVM tool
Add Native Linux KVM tool, a lightweight tool for hosting KVM guests maintained by the Linux kernel community. Signed-off-by: Stefan Agner <stefan@agner.ch> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/kvmtool/files/external-crosscompiler.patch31
-rw-r--r--recipes-extended/kvmtool/kvmtool.bb23
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-extended/kvmtool/files/external-crosscompiler.patch b/recipes-extended/kvmtool/files/external-crosscompiler.patch
new file mode 100644
index 00000000..75cef3b1
--- /dev/null
+++ b/recipes-extended/kvmtool/files/external-crosscompiler.patch
@@ -0,0 +1,31 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3This allows OpenEmbedded to pass in cross compiler configuration using
4the default envirnment variables. It is required so that kvmtool can
5be linked against the cross-compiled libfdt library.
6
7diff --git a/Makefile b/Makefile
8index 1f0196f..8bfb068 100644
9--- a/Makefile
10+++ b/Makefile
11@@ -14,11 +14,6 @@ export E Q
12 include config/utilities.mak
13 include config/feature-tests.mak
14
15-CC := $(CROSS_COMPILE)gcc
16-CFLAGS :=
17-LD := $(CROSS_COMPILE)ld
18-LDFLAGS :=
19-
20 FIND := find
21 CSCOPE := cscope
22 TAGS := ctags
23@@ -297,7 +292,7 @@ $(warning No static libc found. Skipping guest init)
24 endif
25
26 ifeq (y,$(ARCH_WANT_LIBFDT))
27- ifneq ($(call try-build,$(SOURCE_LIBFDT),$(CFLAGS),-lfdt),y)
28+ ifneq ($(call try-build,$(SOURCE_LIBFDT),$(CPPFLAGS) $(CFLAGS),-lfdt),y)
29 $(error No libfdt found. Please install libfdt-dev package)
30 else
31 CFLAGS_DYNOPT += -DCONFIG_HAS_LIBFDT
diff --git a/recipes-extended/kvmtool/kvmtool.bb b/recipes-extended/kvmtool/kvmtool.bb
new file mode 100644
index 00000000..3f299dd5
--- /dev/null
+++ b/recipes-extended/kvmtool/kvmtool.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Native Linux KVM tool"
2DESCRIPTION = "kvmtool is a lightweight tool for hosting KVM guests."
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
6
7DEPENDS = "dtc libaio zlib"
8
9SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git \
10 file://external-crosscompiler.patch \
11 "
12
13SRCREV = "0093df80d754e1a05b016e5a4ccd4b51a00c562c"
14PV = "3.18.0+git${SRCREV}"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE='ARCH="${TARGET_ARCH}" V=1'
19
20do_install() {
21 install -d ${D}${bindir}
22 install -m 0755 ${S}/lkvm ${D}${bindir}/
23}