summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2024-02-12 20:06:15 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-02-21 13:58:56 +0000
commit0c7965ed569c6701b07b6fc204d0a45ebc5196cd (patch)
tree8f85f2cc3ae62660ab990fbd758014d2aaf682e4 /recipes-extended
parentbd67612b66412754b092f336345470dfeda83c29 (diff)
downloadmeta-virtualization-0c7965ed569c6701b07b6fc204d0a45ebc5196cd.tar.gz
upx: bump to 4.2.2 release
Update upx recipe from 3.96 to 4.2.2 release: * Use the gitsm fetcher to get the source code. * Add a note to keep using the git repository. * Update the homepage. * Drop the build dependencies as they're useless. UPX builds using the vendor subdirectory, statically linking the libraries. Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/upx/upx_git.bb43
1 files changed, 7 insertions, 36 deletions
diff --git a/recipes-extended/upx/upx_git.bb b/recipes-extended/upx/upx_git.bb
index 2a5f08be..02e70ffe 100644
--- a/recipes-extended/upx/upx_git.bb
+++ b/recipes-extended/upx/upx_git.bb
@@ -1,45 +1,16 @@
1HOMEPAGE = "http://upx.sourceforge.net"
2SUMMARY = "Ultimate executable compressor." 1SUMMARY = "Ultimate executable compressor."
3 2HOMEPAGE = "https://upx.github.io/"
4SRCREV_upx = "8d1a98e03bf281b2cee459b6c27347e56d13c6a8"
5SRCREV_vendor_doctest = "666e648b68fda2deb141a1fe93e3fd1e2795dd0f"
6SRCREV_vendor_lzma_sdk = "9ebf8f468c689d83504e6c08c6bc26c4a1cf180f"
7SRCREV_vendor_ucl = "4b58d592199dc1e5db691e1a54fb0e5e9af0ecaf"
8SRCREV_vendor_zlib = "2a5b338eb173a701ed179e951d4c390e75e8d4c7"
9SRCREV_FORMAT = "upx"
10SRC_URI = "git://github.com/upx/upx;name=upx;branch=devel;protocol=https \
11 git://github.com/upx/upx-vendor-doctest;name=vendor_doctest;subdir=git/vendor/doctest;branch=upx-vendor;protocol=https \
12 git://github.com/upx/upx-vendor-lzma-sdk;name=vendor_lzma_sdk;subdir=git/vendor/lzma-sdk;branch=upx-vendor;protocol=https \
13 git://github.com/upx/upx-vendor-ucl;name=vendor_ucl;subdir=git/vendor/ucl;branch=upx-vendor;protocol=https \
14 git://github.com/upx/upx-vendor-zlib;name=vendor_zlib;subdir=git/vendor/zlib;branch=upx-vendor;protocol=https \
15"
16
17LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
18LIC_FILES_CHKSUM = "file://LICENSE;md5=353753597aa110e0ded3508408c6374a" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=353753597aa110e0ded3508408c6374a"
5SRCREV_upx = "099c3d829e80488af7395a4242b318877e980da4"
6PV = "4.2.2+git${SRCPV}"
19 7
20DEPENDS = "zlib libucl xz cmake-native" 8# Note: DO NOT use released tarball in favor of the git repository with submodules.
21 9# it makes maintenance easier for CVEs or other issues.
22# inherit cmake 10SRC_URI = "gitsm://github.com/upx/upx;protocol=https;;name=upx;branch=devel"
23 11
24S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
25 13
26PV = "3.96+" 14inherit pkgconfig cmake
27
28EXTRA_OEMAKE += " \
29 UPX_UCLDIR=${STAGING_DIR_TARGET} \
30 UPX_LZMADIR=${STAGING_DIR_TARGET} \
31"
32
33# FIXME: The build fails if security flags are enabled
34SECURITY_CFLAGS = ""
35
36do_compile() {
37 oe_runmake -C src all
38}
39
40do_install:append() {
41 install -d ${D}${bindir}
42 install -m 755 ${B}/build/release/upx ${D}${bindir}/upx
43}
44 15
45BBCLASSEXTEND = "native" 16BBCLASSEXTEND = "native"