summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-09-11 10:42:16 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-09-11 15:51:08 -0400
commit055744cdbc1526d966091158c8fae2d22c905db4 (patch)
treef272293d13d4c7f1d3599f9be44357d8a791cb3f /recipes-extended
parentc917cafe47655708a094a227444a3d5aa5cb182c (diff)
downloadmeta-virtualization-055744cdbc1526d966091158c8fae2d22c905db4.tar.gz
libvirt: pass correct args when start libvirtd
When systemd starts libvirtd we want to make sure we pass the correct arguments to run the daemon. If we fail to do so the libvirtd service will restart about once a minute and not allow for VMs to properly be instantiated. libvirtd now runs with the same args as when we use sysvinit. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/libvirt/libvirt_1.2.17.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.2.17.bb b/recipes-extended/libvirt/libvirt_1.2.17.bb
index 6f269f99..06cb51b3 100644
--- a/recipes-extended/libvirt/libvirt_1.2.17.bb
+++ b/recipes-extended/libvirt/libvirt_1.2.17.bb
@@ -222,6 +222,11 @@ do_install_append() {
222 mv ${D}/${libexecdir}/libvirt-guests.sh ${D}/${sysconfdir}/init.d 222 mv ${D}/${libexecdir}/libvirt-guests.sh ${D}/${sysconfdir}/init.d
223 fi 223 fi
224 224
225 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
226 # This variable is used by libvirtd.service to start libvirtd in the right mode
227 sed -i '/#LIBVIRTD_ARGS="--listen"/a LIBVIRTD_ARGS="--listen --daemon"' ${D}/${sysconfdir}/sysconfig/libvirtd
228 fi
229
225 # The /var/run/libvirt directories created by the Makefile 230 # The /var/run/libvirt directories created by the Makefile
226 # are wiped out in volatile, we need to create these at boot. 231 # are wiped out in volatile, we need to create these at boot.
227 rm -rf ${D}${localstatedir}/run 232 rm -rf ${D}${localstatedir}/run