summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen
diff options
context:
space:
mode:
authorChris Patterson <pattersonc@ainfosec.com>2016-07-27 16:30:42 -0400
committerBruce Ashfield <bruce@zedd.org>2016-07-31 22:55:51 -0400
commitf7fd44846101f1102ad382390bf60812b615c66a (patch)
treeb2624f069f975e3641c27a76dda875db1ff3faf4 /recipes-extended/xen
parent917953761ca32ec871d1b411a03a95ef2e50bda0 (diff)
downloadmeta-virtualization-f7fd44846101f1102ad382390bf60812b615c66a.tar.gz
xen: uprev to 4.7.0
- update packages and add additional ones for new binaries (cpuid and livepatch) - update xen_git to point to 4.7, make branch= fully variable, and remove assumed .0 from release version - add patch to fix compilation of xen with gcc 6 on arm/aarch64 Build tested x86_64 and aarch64 targets. Signed-off-by: Chris Patterson <pattersonc@ainfosec.com> Signed-off-by: Bruce Ashfield <bruce@zedd.org>
Diffstat (limited to 'recipes-extended/xen')
-rw-r--r--recipes-extended/xen/files/libxl-compilation-warning-fix-for-arm-aarch64.patch58
-rw-r--r--recipes-extended/xen/xen.inc19
-rw-r--r--recipes-extended/xen/xen_4.6.1.bb10
-rw-r--r--recipes-extended/xen/xen_4.7.0.bb11
-rw-r--r--recipes-extended/xen/xen_git.bb9
5 files changed, 92 insertions, 15 deletions
diff --git a/recipes-extended/xen/files/libxl-compilation-warning-fix-for-arm-aarch64.patch b/recipes-extended/xen/files/libxl-compilation-warning-fix-for-arm-aarch64.patch
new file mode 100644
index 00000000..baab9281
--- /dev/null
+++ b/recipes-extended/xen/files/libxl-compilation-warning-fix-for-arm-aarch64.patch
@@ -0,0 +1,58 @@
1Upstream-Status: Submitted
2
3From 3716a7faf98e1e126d47fe1596593917c27ee1bd Mon Sep 17 00:00:00 2001
4From: Chris Patterson <pattersonc@ainfosec.com>
5Date: Tue, 26 Jul 2016 16:01:47 -0400
6Subject: [PATCH] libxl: compilation warning fix for arm & aarch64
7
8GCC 6 will warn on unused static const variables in c modules:
9https://gcc.gnu.org/ml/gcc-patches/2015-09/msg00847.html
10
11When compiling with LIBXL_HAVE_NO_SUSPEND_RESUME set (arm & aarch64),
12the compiler emits the following errors:
13 xl_cmdimpl.c:101:19: error: 'migrate_report'
14 defined but not used [-Werror=unused-const-variable=]
15 xl_cmdimpl.c:99:19: error: 'migrate_permission_to_go'
16 defined but not used [-Werror=unused-const-variable=]
17 xl_cmdimpl.c:97:19: error: 'migrate_receiver_ready'
18 defined but not used [-Werror=unused-const-variable=]
19 xl_cmdimpl.c:95:19: error: 'migrate_receiver_banner'
20 defined but not used [-Werror=unused-const-variable=]
21
22These unused const variables are only used in functions which exist between
23the ifndef block:
24 #ifndef LIBXL_HAVE_NO_SUSPEND_RESUME
25 ...
26 #endif
27
28Wrap the same ifndef around these variables.
29
30Signed-off-by: Chris Patterson <pattersonc@ainfosec.com>
31---
32 tools/libxl/xl_cmdimpl.c | 3 +++
33 1 file changed, 3 insertions(+)
34
35diff --git a/tools/libxl/xl_cmdimpl.c b/tools/libxl/xl_cmdimpl.c
36index d1fcfa4..ada8178 100644
37--- a/tools/libxl/xl_cmdimpl.c
38+++ b/tools/libxl/xl_cmdimpl.c
39@@ -92,6 +92,7 @@ static int fd_lock = -1;
40 static const char savefileheader_magic[32]=
41 "Xen saved domain, xl format\n \0 \r";
42
43+#ifndef LIBXL_HAVE_NO_SUSPEND_RESUME
44 static const char migrate_receiver_banner[]=
45 "xl migration receiver ready, send binary domain data.\n";
46 static const char migrate_receiver_ready[]=
47@@ -100,6 +101,8 @@ static const char migrate_permission_to_go[]=
48 "domain is yours, you are cleared to unpause";
49 static const char migrate_report[]=
50 "my copy unpause results are as follows";
51+#endif
52+
53 /* followed by one byte:
54 * 0: everything went well, domain is running
55 * next thing is we all exit
56--
572.7.4
58
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc
index de8c1686..e911415c 100644
--- a/recipes-extended/xen/xen.inc
+++ b/recipes-extended/xen/xen.inc
@@ -151,6 +151,7 @@ PACKAGES = "\
151 ${PN}-base \ 151 ${PN}-base \
152 ${PN}-blktap \ 152 ${PN}-blktap \
153 ${PN}-console \ 153 ${PN}-console \
154 ${PN}-cpuid \
154 ${PN}-dbg \ 155 ${PN}-dbg \
155 ${PN}-dev \ 156 ${PN}-dev \
156 ${PN}-devd \ 157 ${PN}-devd \
@@ -196,6 +197,7 @@ PACKAGES = "\
196 ${PN}-libxenvchan-dev \ 197 ${PN}-libxenvchan-dev \
197 ${PN}-libxlutil \ 198 ${PN}-libxlutil \
198 ${PN}-libxlutil-dev \ 199 ${PN}-libxlutil-dev \
200 ${PN}-livepatch \
199 ${PN}-misc \ 201 ${PN}-misc \
200 ${PN}-pygrub \ 202 ${PN}-pygrub \
201 ${PN}-python \ 203 ${PN}-python \
@@ -369,6 +371,10 @@ FILES_${PN}-console = "\
369 ${sbindir}/xenconsoled \ 371 ${sbindir}/xenconsoled \
370 " 372 "
371 373
374FILES_${PN}-cpuid = "\
375 ${bindir}/xen-cpuid \
376 "
377
372FILES_${PN}-devd = "\ 378FILES_${PN}-devd = "\
373 ${sysconfdir}/init.d/xendriverdomain \ 379 ${sysconfdir}/init.d/xendriverdomain \
374 " 380 "
@@ -399,6 +405,10 @@ FILES_${PN}-kdd = "\
399 ${sbindir}/kdd \ 405 ${sbindir}/kdd \
400 " 406 "
401 407
408FILES_${PN}-livepatch += " \
409 ${sbindir}/xen-livepatch \
410 "
411
402FILES_${PN}-misc = "\ 412FILES_${PN}-misc = "\
403 ${bindir}/xencons \ 413 ${bindir}/xencons \
404 ${bindir}/xencov_split \ 414 ${bindir}/xencov_split \
@@ -527,6 +537,7 @@ FILES_${PN}-remus = "\
527 " 537 "
528 538
529FILES_${PN}-scripts-network = " \ 539FILES_${PN}-scripts-network = " \
540 ${sysconfdir}/xen/scripts/colo-proxy-setup \
530 ${sysconfdir}/xen/scripts/network-bridge \ 541 ${sysconfdir}/xen/scripts/network-bridge \
531 ${sysconfdir}/xen/scripts/network-nat \ 542 ${sysconfdir}/xen/scripts/network-nat \
532 ${sysconfdir}/xen/scripts/network-route \ 543 ${sysconfdir}/xen/scripts/network-route \
@@ -544,6 +555,7 @@ FILES_${PN}-scripts-block = " \
544 ${sysconfdir}/xen/scripts/blktap \ 555 ${sysconfdir}/xen/scripts/blktap \
545 ${sysconfdir}/xen/scripts/block \ 556 ${sysconfdir}/xen/scripts/block \
546 ${sysconfdir}/xen/scripts/block-common.sh \ 557 ${sysconfdir}/xen/scripts/block-common.sh \
558 ${sysconfdir}/xen/scripts/block-dummy \
547 ${sysconfdir}/xen/scripts/block-enbd \ 559 ${sysconfdir}/xen/scripts/block-enbd \
548 ${sysconfdir}/xen/scripts/block-iscsi \ 560 ${sysconfdir}/xen/scripts/block-iscsi \
549 ${sysconfdir}/xen/scripts/block-nbd \ 561 ${sysconfdir}/xen/scripts/block-nbd \
@@ -744,9 +756,11 @@ export XEN_OS = "Linux"
744 756
745# this is used for the header (#!${bindir}/python) of the install python scripts 757# this is used for the header (#!${bindir}/python) of the install python scripts
746export PYTHONPATH="${bindir}/python" 758export PYTHONPATH="${bindir}/python"
759export ac_cv_path_PYTHONPATH="${bindir}/python"
747 760
748# seabios forcefully sets HOSTCC to CC - fixup to allow it to build native conf executable 761# xen and seabios require HOSTCC and HOSTCXX set to cross-compile
749export HOSTCC="${BUILD_CC}" 762export HOSTCC="${BUILD_CC}"
763export HOSTCXX="${BUILD_CXX}"
750 764
751# make xen requires CROSS_COMPILE set by hand as it does not abide by ./configure 765# make xen requires CROSS_COMPILE set by hand as it does not abide by ./configure
752export CROSS_COMPILE="${TARGET_PREFIX}" 766export CROSS_COMPILE="${TARGET_PREFIX}"
@@ -837,6 +851,9 @@ do_configure() {
837} 851}
838 852
839do_compile() { 853do_compile() {
854 # workaround for build bug when CFLAGS is exported
855 # https://www.mail-archive.com/xen-devel@lists.xen.org/msg67822.html
856 unset CFLAGS
840 oe_runmake 857 oe_runmake
841} 858}
842 859
diff --git a/recipes-extended/xen/xen_4.6.1.bb b/recipes-extended/xen/xen_4.6.1.bb
deleted file mode 100644
index 0adf8adb..00000000
--- a/recipes-extended/xen/xen_4.6.1.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require xen.inc
2
3SRC_URI = " \
4 http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \
5 "
6
7SRC_URI[md5sum] = "df2d854c3c90ffeefaf71e7f868fb326"
8SRC_URI[sha256sum] = "44cc2fccba1e147ef4c8da0584ce0f24189c8743de0e3e9a9226da88ddb5f589"
9
10S = "${WORKDIR}/xen-${PV}"
diff --git a/recipes-extended/xen/xen_4.7.0.bb b/recipes-extended/xen/xen_4.7.0.bb
new file mode 100644
index 00000000..adb5c363
--- /dev/null
+++ b/recipes-extended/xen/xen_4.7.0.bb
@@ -0,0 +1,11 @@
1require xen.inc
2
3SRC_URI = " \
4 http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \
5 file://libxl-compilation-warning-fix-for-arm-aarch64.patch \
6 "
7
8SRC_URI[md5sum] = "3aa4e01bf37a3a5bc8572907cb88e649"
9SRC_URI[sha256sum] = "be5876144d49729572ae06142e0bb93f1c1f2695578141eff2931995add24623"
10
11S = "${WORKDIR}/xen-${PV}"
diff --git a/recipes-extended/xen/xen_git.bb b/recipes-extended/xen/xen_git.bb
index a86a5017..e10d669f 100644
--- a/recipes-extended/xen/xen_git.bb
+++ b/recipes-extended/xen/xen_git.bb
@@ -1,15 +1,16 @@
1require xen.inc 1require xen.inc
2 2
3SRCREV = "1fd615aa0108490ffc558d27627f509183cbfdaf" 3SRCREV ?= "9a6cc4f5c14b3d7542b7523f88a1b65464733d3a"
4 4
5XEN_REL="4.6" 5XEN_REL ?= "4.7"
6XEN_BRANCH ?= "staging-${XEN_REL}"
6 7
7PV = "${XEN_REL}.0+git${SRCPV}" 8PV = "${XEN_REL}+git${SRCPV}"
8 9
9S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
10 11
11SRC_URI = " \ 12SRC_URI = " \
12 git://xenbits.xen.org/xen.git;branch=staging-${XEN_REL} \ 13 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
13 " 14 "
14 15
15DEFAULT_PREFERENCE = "-1" 16DEFAULT_PREFERENCE = "-1"