summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-07-31 17:34:06 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-08-01 14:41:46 -0400
commit900c85076e8a438659132846db1734b094ec56a4 (patch)
treea38a593baa650129c2572a4a214a9e43b5f37cd4 /recipes-extended/xen
parent489fa21681908755f66ea8be2169d7684cb32470 (diff)
downloadmeta-virtualization-900c85076e8a438659132846db1734b094ec56a4.tar.gz
xen: Fix build with gas/2.41
Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/xen')
-rw-r--r--recipes-extended/xen/files/0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch62
-rw-r--r--recipes-extended/xen/xen_4.17.bb4
2 files changed, 66 insertions, 0 deletions
diff --git a/recipes-extended/xen/files/0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch b/recipes-extended/xen/files/0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch
new file mode 100644
index 00000000..c73bb270
--- /dev/null
+++ b/recipes-extended/xen/files/0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch
@@ -0,0 +1,62 @@
1From 9add6f9aced42a76f6a2c124754bef6fde56fa05 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3To: xen-devel@lists.xenproject.org
4Cc: Stefano Stabellini <sstabellini@kernel.org>
5Cc: Julien Grall <julien@xen.org>
6Cc: Bertrand Marquis <bertrand.marquis@arm.com>
7Cc: Volodymyr Babchuk <Volodymyr_Babchuk@epam.com>
8Date: Mon, 31 Jul 2023 17:01:32 -0700
9Subject: [PATCH] arm32: Avoid using solaris syntax for .section directive
10
11Assembler from binutils 2.41 rejects this syntax
12
13.section "name"[, flags...]
14
15where flags could be #alloc, #write, #execstr
16Switch to using ELF syntax
17
18.section name[, "flags"[, @type]]
19
20[1] https://ftp.gnu.org/old-gnu/Manuals/gas-2.9.1/html_chapter/as_7.html#SEC119
21
22Upstream-Status: Submitted [by email to xen-devel@lists.xenproject.org and maintainers]
23
24Signed-off-by: Khem Raj <raj.khem@gmail.com>
25---
26 xen/arch/arm/arm32/proc-v7.S | 6 +++---
27 1 file changed, 3 insertions(+), 3 deletions(-)
28
29diff --git a/xen/arch/arm/arm32/proc-v7.S b/xen/arch/arm/arm32/proc-v7.S
30index c90a31d80f..6d3d19b873 100644
31--- a/xen/arch/arm/arm32/proc-v7.S
32+++ b/xen/arch/arm/arm32/proc-v7.S
33@@ -29,7 +29,7 @@ brahma15mp_init:
34 mcr CP32(r0, ACTLR)
35 mov pc, lr
36
37- .section ".proc.info", #alloc
38+ .section .proc.info, "a"
39 .type __v7_ca15mp_proc_info, #object
40 __v7_ca15mp_proc_info:
41 .long 0x410FC0F0 /* Cortex-A15 */
42@@ -38,7 +38,7 @@ __v7_ca15mp_proc_info:
43 .long caxx_processor
44 .size __v7_ca15mp_proc_info, . - __v7_ca15mp_proc_info
45
46- .section ".proc.info", #alloc
47+ .section .proc.info, "a"
48 .type __v7_ca7mp_proc_info, #object
49 __v7_ca7mp_proc_info:
50 .long 0x410FC070 /* Cortex-A7 */
51@@ -47,7 +47,7 @@ __v7_ca7mp_proc_info:
52 .long caxx_processor
53 .size __v7_ca7mp_proc_info, . - __v7_ca7mp_proc_info
54
55- .section ".proc.info", #alloc
56+ .section .proc.info, "a"
57 .type __v7_brahma15mp_proc_info, #object
58 __v7_brahma15mp_proc_info:
59 .long 0x420F00F0 /* Broadcom Brahma-B15 */
60--
612.41.0
62
diff --git a/recipes-extended/xen/xen_4.17.bb b/recipes-extended/xen/xen_4.17.bb
index 9da1b194..bd8f55b3 100644
--- a/recipes-extended/xen/xen_4.17.bb
+++ b/recipes-extended/xen/xen_4.17.bb
@@ -7,6 +7,7 @@ XEN_BRANCH ?= "stable-${XEN_REL}"
7SRC_URI = " \ 7SRC_URI = " \
8 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ 8 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ 9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \
10 file://0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch \
10 " 11 "
11 12
12LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9" 13LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9"
@@ -17,3 +18,6 @@ S = "${WORKDIR}/git"
17 18
18require xen.inc 19require xen.inc
19require xen-hypervisor.inc 20require xen-hypervisor.inc
21
22TOOLCHAIN = "gcc"
23LDFLAGS:remove = "-fuse-ld=lld"