summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/xen_git.bb
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-02-25 16:15:54 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-02-27 16:59:23 -0500
commit545461ba2f97f065791e3d4ed22342eba2836d48 (patch)
tree68917fa8fed4b544b84e32d70470e5c47600f1a2 /recipes-extended/xen/xen_git.bb
parente12b76773a874ea4454411aea564a3e9008c931b (diff)
downloadmeta-virtualization-545461ba2f97f065791e3d4ed22342eba2836d48.tar.gz
xen: separate recipes for hypervisor and tools; switch to git as source
This change changes the names of many packages produced: the xen-tools recipe now builds packages previous built by the xen recipe, so the package prefix changes from "xen-" to "xen-tools-". A temporary bbappend is provided for qemu to ease the transition. Multiple motivations for recipe separation: - improves efficiency of incremental build and development - supports building the hypervisor and tools with different toolchains and for different architectures Switch to using a git recipe on the Xen stable branch: - enables easier tracking of critical XSA security updates applied upstream by just advancing SRCREV along the branch Revision has been set to the tip of the stable-4.12 branch, which has the one XSA-312 patch applied on top of RELEASE-4.12.2. The recipe refactor externalizes the block tap components, to enable optional building of blktap in a separate recipe outside xen-tools, needed by OpenXT. xenstored is made a virtual package to support switching between alternative implementations (several exist). Update xen-image-minimal to install the xen-tools package, which replaces what was previously xen-base. Determine the flask policy filename, which is Xen-version specific, using the same method as the Xen build system. qemu: update PACKAGECONFIG[xen] for xen package renaming: allows builds to continue correctly in the meantime while openembedded core and poky are updated. OpenXT ticket reference: OXT-1694 Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/xen/xen_git.bb')
-rw-r--r--recipes-extended/xen/xen_git.bb19
1 files changed, 8 insertions, 11 deletions
diff --git a/recipes-extended/xen/xen_git.bb b/recipes-extended/xen/xen_git.bb
index 5f950e6f..a7475ac3 100644
--- a/recipes-extended/xen/xen_git.bb
+++ b/recipes-extended/xen/xen_git.bb
@@ -1,18 +1,15 @@
1require xen.inc 1SRCREV ?= "a5fcafbfbee55261853fba07149c1c795f2baf58"
2
3XEN_REL ?= "4.12"
4XEN_BRANCH ?= "stable-${XEN_REL}"
2 5
3SRCREV ?= "cb70a26f78848fe45f593f7ebc9cfaac760a791b" 6SRC_URI = "git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH}"
4 7
5XEN_REL = "4.13" 8LIC_FILES_CHKSUM ?= "file://COPYING;md5=bbb4b1bdc2c3b6743da3c39d03249095"
6XEN_BRANCH = "staging"
7FLASK_POLICY_FILE = "xenpolicy-${XEN_REL}-unstable"
8 9
9PV = "${XEN_REL}+git${SRCPV}" 10PV = "${XEN_REL}+git${SRCPV}"
10 11
11S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
12 13
13SRC_URI = " \ 14require xen.inc
14 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ 15require xen-hypervisor.inc
15 file://0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch \
16 "
17
18DEFAULT_PREFERENCE = "-1"