summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/xen_4.14.bb
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-07-17 14:03:47 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-20 14:47:15 -0400
commit5f0ded3423e010a23ac617f7811469e6c4b783b8 (patch)
tree343215b0b244393039c2c9182a75a45847a88ab6 /recipes-extended/xen/xen_4.14.bb
parent5524c6d0fbc371040b519013d81b6e945dfecbcb (diff)
downloadmeta-virtualization-5f0ded3423e010a23ac617f7811469e6c4b783b8.tar.gz
xen, xen-tools: add recipes for Xen 4.14
Add a versioned-suffix pair of recipes for Xen 4.14, allowing selection of which Xen version to build via setting PREFERRED_VERSION. 4.14 is currently still pre-release, so the new recipes for it set DEFAULT_PREFERENCE to -1, and the default for now remains the existing stable version. Forward ports of patches needed for 4.14 are included. Implementation note: since both this version and the git recipe are built from git branches -- important for Xen since significant updates are made available there inbetween point releases -- the recipe includes 'stable' as a string in PV so as to distinguish it from 'git' in the git recipe, and thereby allow PREFERRED_VERSION to select the correct recipe in the situation where both happen to be configured with the same XEN_REL. Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/xen/xen_4.14.bb')
-rw-r--r--recipes-extended/xen/xen_4.14.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-extended/xen/xen_4.14.bb b/recipes-extended/xen/xen_4.14.bb
new file mode 100644
index 00000000..02af2a7f
--- /dev/null
+++ b/recipes-extended/xen/xen_4.14.bb
@@ -0,0 +1,20 @@
1SRCREV ?= "02d69864b51a4302a148c28d6d391238a6778b4b"
2
3XEN_REL ?= "4.14"
4XEN_BRANCH ?= "stable-${XEN_REL}"
5
6SRC_URI = " \
7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
8 file://xen-arm64-implement-atomic-fetch-add.patch \
9 "
10
11LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5"
12
13PV = "${XEN_REL}+stable${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17DEFAULT_PREFERENCE ??= "-1"
18
19require xen.inc
20require xen-hypervisor.inc