summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/xen.inc
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-07-17 14:03:49 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-20 14:47:15 -0400
commitee94ad466cc3ffbf214a00a6a9aaad6d8ff68794 (patch)
tree72ad051878364119bbb359de9f39e559993a3957 /recipes-extended/xen/xen.inc
parenteba860b0d9815216db5e7440bef168d44cea2d37 (diff)
downloadmeta-virtualization-ee94ad466cc3ffbf214a00a6a9aaad6d8ff68794.tar.gz
xen, arm32: filter out unwanted tune flags from CPP as per CC
Avoids passing the wrong floating point ABI flags to the linker. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/xen/xen.inc')
-rw-r--r--recipes-extended/xen/xen.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc
index 58b57e58..3c1e3b95 100644
--- a/recipes-extended/xen/xen.inc
+++ b/recipes-extended/xen/xen.inc
@@ -193,6 +193,7 @@ do_post_patch() {
193do_post_patch_append_arm() { 193do_post_patch_append_arm() {
194 # The hypervisor binary must not be built with the hard floating point ABI. 194 # The hypervisor binary must not be built with the hard floating point ABI.
195 echo "CC := \$(filter-out ${TUNE_CCARGS},\$(CC))" >> ${S}/xen/arch/arm/Rules.mk 195 echo "CC := \$(filter-out ${TUNE_CCARGS},\$(CC))" >> ${S}/xen/arch/arm/Rules.mk
196 echo "CPP := \$(filter-out ${TUNE_CCARGS},\$(CPP))" >> ${S}/xen/arch/arm/Rules.mk
196} 197}
197 198
198addtask post_patch after do_patch before do_configure 199addtask post_patch after do_patch before do_configure