summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/xen-hypervisor.inc
diff options
context:
space:
mode:
authorMichal Orzel <michal.orzel@arm.com>2022-03-09 11:09:06 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-03-10 14:42:22 -0500
commitca4601a54a9cabe2c2bb8eb758bcad2d3ab98ddf (patch)
tree0b4e58cc34b238d76415c01024b91e9b2e77ee28 /recipes-extended/xen/xen-hypervisor.inc
parent2dc502a2690ed07b8e692b95d769803ec9f8eb21 (diff)
downloadmeta-virtualization-ca4601a54a9cabe2c2bb8eb758bcad2d3ab98ddf.tar.gz
xen: Override CC and CPP in make command line
After 4.16 release, Xen build system has been changed significantly. When building latest status of Xen it was observed that commit 317c98cb91 broke the hypervisor build on arm32 due to the change in handling Rules.mk that xen.inc modifies to override CC and CPP. In order to fix the issue this patch moves overriding CC and CPP from Rules.mk to make command line by adding them to EXTRA_OEMAKE:arm. Take the opportunity to bump SRCREV of xen_git.bb and xen-tools_git.bb to the current status of master. Signed-off-by: Michal Orzel <michal.orzel@arm.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/xen/xen-hypervisor.inc')
-rw-r--r--recipes-extended/xen/xen-hypervisor.inc8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-extended/xen/xen-hypervisor.inc b/recipes-extended/xen/xen-hypervisor.inc
index 81e361f1..6f3d24d0 100644
--- a/recipes-extended/xen/xen-hypervisor.inc
+++ b/recipes-extended/xen/xen-hypervisor.inc
@@ -48,6 +48,14 @@ do_configure() {
48 fi 48 fi
49} 49}
50 50
51# The hypervisor binary for arm must not be built with the hard floating point
52# ABI. Override CC and CPP when invoking make so that they do not contain
53# TUNE_CCARGS.
54EXTRA_OEMAKE:arm += "CC='${CCACHE}${HOST_PREFIX}gcc ${TOOLCHAIN_OPTIONS} \
55 ${CC_REPRODUCIBLE_OPTIONS}' \
56 CPP='${CCACHE}${HOST_PREFIX}gcc -E ${TOOLCHAIN_OPTIONS} \
57 ${CC_REPRODUCIBLE_OPTIONS}'"
58
51do_compile() { 59do_compile() {
52 oe_runmake xen PYTHON="${PYTHON}" \ 60 oe_runmake xen PYTHON="${PYTHON}" \
53 EXTRA_CFLAGS_XEN_CORE="${EXTRA_CFLAGS_XEN_CORE}" 61 EXTRA_CFLAGS_XEN_CORE="${EXTRA_CFLAGS_XEN_CORE}"