summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/polarssl_1.1.4.bb
diff options
context:
space:
mode:
authorKurt Bodiker <kurt.bodiker@braintrust-us.com>2018-05-01 10:05:31 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-05-01 23:17:29 -0400
commite1279d6de619e50871178d0c061073922fdb3c53 (patch)
tree7f93bda23641183495a8d04e41c4785f22a3a68f /recipes-extended/xen/polarssl_1.1.4.bb
parentb9f265377c8a673c6a5bd4f4bab0ac41a075bfde (diff)
downloadmeta-virtualization-e1279d6de619e50871178d0c061073922fdb3c53.tar.gz
xen: PolarSSL recipe and patches for Xen stubdoms
PolarSSL (now mbedTLS) is a lightweight SSL library optimized for embedded systems. In the case of Xen stubdomains, we are using MiniOS. This PolarSSL recipe creates a static library that is cross-compiled against MiniOS, Xen, LWIP, and Newlib headers and subsequently used during the cross-compilation and linking of the stubdom specific GMP, TPM Emulator, and the Xen vTPM and vTPM Manager stubdomains. The current Xen source code is hardcoded to fetch a specific version of this package. The patch files originate from the Xen/stubdom source tree. This recipe provides the flexibility to change version or modify the patches. Signed-off-by: Kurt Bodiker <kurt.bodiker@braintrust-us.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/xen/polarssl_1.1.4.bb')
-rw-r--r--recipes-extended/xen/polarssl_1.1.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-extended/xen/polarssl_1.1.4.bb b/recipes-extended/xen/polarssl_1.1.4.bb
new file mode 100644
index 00000000..80ea45a7
--- /dev/null
+++ b/recipes-extended/xen/polarssl_1.1.4.bb
@@ -0,0 +1,19 @@
1# Copyright (C) 2017 Kurt Bodiker <kurt.bodiker@braintrust-us.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "PolarSSL (now 'mbed TLS') is an open source, portable, easy to use, readable and flexible SSL library."
5HOMEPAGE = "https://tls.mbed.org"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
8
9# git hash for release tag polarssl-1.1.4
10SRCREV_polarssl = "d36da11125a9c85c572a4fdf63e0a25e76d7bb18"
11SRC_URI = "\
12 git://github.com/ARMmbed/mbedtls.git;protocol=https;nobranch=1;destsuffix=polarssl;name=polarssl \
13 file://polarssl.patch; \
14"
15
16S="${WORKDIR}/${PN}"
17B="${S}/library"
18
19require polarssl.inc