summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/files
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2016-01-26 13:09:24 -0600
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-01 00:11:36 -0500
commitf5649753869888606de09701ea9f9a56424cd3d8 (patch)
tree2a462bafcf8ea3d8575ecbe8296d1f65ff0ac416 /recipes-extended/xen/files
parent3915d59fdf7af575b7e26a82efb0f998864d8692 (diff)
downloadmeta-virtualization-f5649753869888606de09701ea9f9a56424cd3d8.tar.gz
xen: don't inject -mfpmath=sse which causes build issues
Don't inject -mfpmath=sse into the build which causes issues with the hypervisor build. Signed-off-by: Doug Goldstein <cardoe@cardoe.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/xen/files')
-rw-r--r--recipes-extended/xen/files/xen-x86-Fix-up-rules-when-forcing-mno-sse.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/recipes-extended/xen/files/xen-x86-Fix-up-rules-when-forcing-mno-sse.patch b/recipes-extended/xen/files/xen-x86-Fix-up-rules-when-forcing-mno-sse.patch
deleted file mode 100644
index 4c3e297f..00000000
--- a/recipes-extended/xen/files/xen-x86-Fix-up-rules-when-forcing-mno-sse.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From: Nathan Rossi <nathan.rossi@xilinx.com>
2Subject: [PATCH] xen/x86: Fix up rules when forcing -mno-sse
3
4* When forcing -mno-sse specify -mfpmath=387 to avoid the fallback
5 warning
6
7Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
8Upstream-Status: Not-Submitted
9---
10 xen/arch/x86/Rules.mk | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/xen/arch/x86/Rules.mk b/xen/arch/x86/Rules.mk
14index 6775cb5..03848f7 100644
15--- a/xen/arch/x86/Rules.mk
16+++ b/xen/arch/x86/Rules.mk
17@@ -42,7 +42,7 @@ x86 := y
18 x86_32 := n
19 x86_64 := y
20
21-CFLAGS += -mno-red-zone -mno-sse -fpic
22+CFLAGS += -mno-red-zone -mno-sse -fpic -mfpmath=387
23 CFLAGS += -fno-asynchronous-unwind-tables
24 # -fvisibility=hidden reduces -fpic cost, if it's available
25 ifneq ($(call cc-option,$(CC),-fvisibility=hidden,n),n)
26--
272.1.1
28