summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/files
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2023-05-27 13:47:53 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-05-29 09:48:09 -0400
commitd9dc99282fa4a7dfce861f64e792b1a8307a4a8c (patch)
treeaf0d225dcf27a8da5bc7b6e436efae67eb8e270d /recipes-extended/xen/files
parentb6214f244577ca97b01cc2a1054d16a298c5ce48 (diff)
downloadmeta-virtualization-d9dc99282fa4a7dfce861f64e792b1a8307a4a8c.tar.gz
xen, xen-tools: Update git recipe revision for gcc 13 compatibility
Adds an update for the python/pygrub environment patch for the current Xen 4.18 development tree. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/xen/files')
-rw-r--r--recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch
new file mode 100644
index 00000000..3c7a97db
--- /dev/null
+++ b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch
@@ -0,0 +1,41 @@
1diff --git a/tools/pygrub/Makefile b/tools/pygrub/Makefile
2index 4963bc89c6..c1c05eb421 100644
3--- a/tools/pygrub/Makefile
4+++ b/tools/pygrub/Makefile
5@@ -13,14 +13,14 @@ setup.py = CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDSHARED="$(CC)" LDFLAGS="$(PY_LDFLA
6 all: build
7 .PHONY: build
8 build:
9- $(setup.py) build
10+ $(setup.py) build $(DISTUTILS_BUILD_ARGS)
11
12 .PHONY: install
13 install: all
14 $(INSTALL_DIR) $(DESTDIR)/$(bindir)
15 $(INSTALL_DIR) $(DESTDIR)/$(LIBEXEC_BIN)
16 $(setup.py) install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \
17- --root="$(DESTDIR)" --force
18+ --root="$(DESTDIR)" --force $(DISTUTILS_INSTALL_ARGS)
19 $(INSTALL_PYTHON_PROG) src/pygrub $(DESTDIR)/$(LIBEXEC_BIN)/pygrub
20 set -e; if [ $(bindir) != $(LIBEXEC_BIN) -a \
21 "`readlink -f $(DESTDIR)/$(bindir)`" != \
22diff --git a/tools/python/Makefile b/tools/python/Makefile
23index 437431c48e..0a99c2067e 100644
24--- a/tools/python/Makefile
25+++ b/tools/python/Makefile
26@@ -16,13 +16,13 @@ setup.py = CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDSHARED="$(CC)" LDFLAGS="$(PY_LDFLA
27
28 .PHONY: build
29 build:
30- $(setup.py) build
31+ $(setup.py) build $(DISTUTILS_BUILD_ARGS)
32
33 .PHONY: install
34 install:
35 $(INSTALL_DIR) $(DESTDIR)$(LIBEXEC_BIN)
36 $(setup.py) install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \
37- --root="$(DESTDIR)" --force
38+ --root="$(DESTDIR)" --force $(DISTUTILS_INSTALL_ARGS)
39 $(INSTALL_PYTHON_PROG) scripts/convert-legacy-stream $(DESTDIR)$(LIBEXEC_BIN)
40 $(INSTALL_PYTHON_PROG) scripts/verify-stream-v2 $(DESTDIR)$(LIBEXEC_BIN)
41