summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/files
diff options
context:
space:
mode:
authorChris Patterson <cjp256@gmail.com>2013-11-07 20:49:43 -0500
committerChris Patterson <cjp256@gmail.com>2013-11-07 20:49:43 -0500
commit6c2779ae59ea174e8467caf590c3197482335a08 (patch)
treea7e2d398a31eba6efd4e4aebbf00822a40e24aa8 /recipes-extended/xen/files
parent949174e9643e4879be11460683eb6fff24c43454 (diff)
downloadmeta-virtualization-6c2779ae59ea174e8467caf590c3197482335a08.tar.gz
xen: remove old patches
Signed-off-by: Chris Patterson <cjp256@gmail.com>
Diffstat (limited to 'recipes-extended/xen/files')
-rw-r--r--recipes-extended/xen/files/allow_disable_xend.patch75
-rw-r--r--recipes-extended/xen/files/ioemu-cross-gl-check.patch29
-rw-r--r--recipes-extended/xen/files/xend-config.sxp304
-rwxr-xr-xrecipes-extended/xen/files/xenminiinit.sh59
4 files changed, 0 insertions, 467 deletions
diff --git a/recipes-extended/xen/files/allow_disable_xend.patch b/recipes-extended/xen/files/allow_disable_xend.patch
deleted file mode 100644
index 33187045..00000000
--- a/recipes-extended/xen/files/allow_disable_xend.patch
+++ /dev/null
@@ -1,75 +0,0 @@
1--- xen-4.1.2/config/StdGNU.mk.sav 2012-03-08 12:30:26.047303578 -0700
2+++ xen-4.1.2/config/StdGNU.mk 2012-03-08 12:31:48.826696508 -0700
3@@ -56,6 +56,9 @@
4 XEN_CONFIG_DIR = $(CONFIG_DIR)/xen
5 XEN_SCRIPT_DIR = $(XEN_CONFIG_DIR)/scripts
6
7+# Allow xend to be disabled in lieu of only libxl
8+CONFIG_ENABLE_XEND ?= y
9+
10 SOCKET_LIBS =
11 CURSES_LIBS = -lncurses
12 PTHREAD_LIBS = -lpthread
13--- xen-4.1.2/tools/Makefile.sav 2012-03-08 11:25:10.177301492 -0700
14+++ xen-4.1.2/tools/Makefile 2012-03-08 12:33:48.807302767 -0700
15@@ -15,7 +15,7 @@
16 SUBDIRS-$(CONFIG_X86) += firmware
17 SUBDIRS-$(ACM_SECURITY) += security
18 SUBDIRS-y += console
19-SUBDIRS-y += xenmon
20+SUBDIRS-$(CONFIG_ENABLE_XEND) += xenmon
21 SUBDIRS-$(VTPM_TOOLS) += vtpm_manager
22 SUBDIRS-$(VTPM_TOOLS) += vtpm
23 SUBDIRS-y += xenstat
24@@ -36,17 +36,19 @@
25
26 SUBDIRS-y += xenpmd
27 SUBDIRS-y += libxl
28-SUBDIRS-y += remus
29+SUBDIRS-$(CONFIG_ENABLE_XEND) += remus
30 SUBDIRS-$(CONFIG_X86) += xenpaging
31 SUBDIRS-$(CONFIG_X86) += debugger/gdbsx
32 SUBDIRS-$(CONFIG_X86) += debugger/kdd
33
34 # These don't cross-compile
35 ifeq ($(XEN_COMPILE_ARCH),$(XEN_TARGET_ARCH))
36+ifneq ($(XEN_ENABLE_XEND),y)
37 SUBDIRS-$(PYTHON_TOOLS) += python
38 SUBDIRS-$(PYTHON_TOOLS) += pygrub
39 SUBDIRS-$(OCAML_TOOLS) += ocaml
40 endif
41+endif
42
43 # For the sake of linking, set the sys-root
44 ifneq ($(CROSS_COMPILE),)
45--- xen-4.1.2/tools/misc/Makefile.sav 2012-03-08 12:23:10.107321955 -0700
46+++ xen-4.1.2/tools/misc/Makefile 2012-03-08 12:34:54.466721729 -0700
47@@ -19,11 +19,13 @@
48 SUBDIRS-$(CONFIG_MINITERM) += miniterm
49 SUBDIRS := $(SUBDIRS-y)
50
51-INSTALL_BIN-y := xencons
52+INSTALL_BIN-y :=
53+INSTALL_BIN-$(CONFIG_ENABLE_XEND) += xencons
54 INSTALL_BIN-$(CONFIG_X86) += xen-detect
55 INSTALL_BIN := $(INSTALL_BIN-y)
56
57-INSTALL_SBIN-y := xm xen-bugtool xen-python-path xend xenperf xsview xenpm xen-tmem-list-parse gtraceview gtracestat xenlockprof xenwatchdogd
58+INSTALL_SBIN-y := xenperf xsview xenpm xen-tmem-list-parse gtraceview gtracestat xenlockprof xenwatchdogd
59+INSTALL_SBIN-$(CONFIG_ENABLE_XEND) += xm xend xsview xen-python-path xen-bugtool
60 INSTALL_SBIN-$(CONFIG_X86) += xen-hvmctx xen-hvmcrash
61 INSTALL_SBIN-$(CONFIG_MIGRATE) += xen-hptool
62 INSTALL_SBIN := $(INSTALL_SBIN-y)
63--- xen-4.1.2/tools/hotplug/NetBSD/Makefile.sav 2012-03-08 12:54:56.247306596 -0700
64+++ xen-4.1.2/tools/hotplug/NetBSD/Makefile 2012-03-08 12:57:50.337339410 -0700
65@@ -8,7 +8,9 @@
66 XEN_SCRIPTS += vif-ip
67
68 XEN_SCRIPT_DATA =
69-XEN_RCD_PROG = rc.d/xencommons rc.d/xend rc.d/xendomains rc.d/xen-watchdog
70+XEN_RCD_PROG-y := rc.d/xencommons rc.d/xendomains rc.d/xen-watchdog
71+XEN_RCD_PROG-$(CONFIG_ENABLE_XEND) += rc.d/xend
72+XEN_RCD_PROG := $(XEN_RCD_PROG-y)
73
74 .PHONY: all
75 all:
diff --git a/recipes-extended/xen/files/ioemu-cross-gl-check.patch b/recipes-extended/xen/files/ioemu-cross-gl-check.patch
deleted file mode 100644
index a1363ea0..00000000
--- a/recipes-extended/xen/files/ioemu-cross-gl-check.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1--- qemu-xen-4.1-testing/configure 2012-02-20 09:01:08.219798969 -0700
2+++ xen-4.1-testing.hg/../git/configure 2012-02-20 09:03:27.876749305 -0700
3@@ -289,7 +289,7 @@
4 kqemu="yes"
5 fi
6 fi
7- if test -f /usr/include/sys/soundcard.h ; then
8+ if test -f ${CROSS_SYS_ROOT}/usr/include/sys/soundcard.h ; then
9 audio_drv_list="oss"
10 fi
11 audio_possible_drivers="oss sdl"
12@@ -872,7 +872,7 @@
13 #endif
14 int main( void ) { return (int) glGetString(GL_EXTENSIONS); }
15 EOF
16-if $cc $ARCH_CFLAGS -o $TMPE `$sdl_config --cflags --libs 2> /dev/null` -I/usr/include/GL $TMPC -lXext -lGL 2> /dev/null
17+if $cc $ARCH_CFLAGS -o $TMPE `$sdl_config --cflags --libs 2> /dev/null` -I${CROSS_SYS_ROOT}/usr/include/GL $TMPC -lXext -lGL 2> /dev/null
18 then
19 opengl="yes"
20 else
21@@ -1450,7 +1450,7 @@
22 then
23 echo "#define CONFIG_OPENGL 1" >> $config_h
24 echo "CONFIG_OPENGL=yes" >> $config_mak
25- echo "SDL_CFLAGS+=-I/usr/include/GL" >> $config_mak
26+ echo "SDL_CFLAGS+=-I${CROSS_SYS_ROOT}/usr/include/GL" >> $config_mak
27 echo "SDL_LIBS+=-lXext" >> $config_mak
28 echo "SDL_LIBS+=-lGL" >> $config_mak
29 fi
diff --git a/recipes-extended/xen/files/xend-config.sxp b/recipes-extended/xen/files/xend-config.sxp
deleted file mode 100644
index 096bb555..00000000
--- a/recipes-extended/xen/files/xend-config.sxp
+++ /dev/null
@@ -1,304 +0,0 @@
1# -*- sh -*-
2
3#
4# Xend configuration file.
5#
6
7# This example configuration is appropriate for an installation that
8# utilizes a bridged network configuration. Access to xend via http
9# is disabled.
10
11# Commented out entries show the default for that entry, unless otherwise
12# specified.
13
14#(logfile /var/log/xen/xend.log)
15#(loglevel DEBUG)
16
17# Uncomment the line below. Set the value to flask, acm, or dummy to
18# select a security module.
19
20#(xsm_module_name dummy)
21
22# The Xen-API server configuration.
23#
24# This value configures the ports, interfaces, and access controls for the
25# Xen-API server. Each entry in the list starts with either unix, a port
26# number, or an address:port pair. If this is "unix", then a UDP socket is
27# opened, and this entry applies to that. If it is a port, then Xend will
28# listen on all interfaces on that TCP port, and if it is an address:port
29# pair, then Xend will listen on the specified port, using the interface with
30# the specified address.
31#
32# The subsequent string configures the user-based access control for the
33# listener in question. This can be one of "none" or "pam", indicating either
34# that users should be allowed access unconditionally, or that the local
35# Pluggable Authentication Modules configuration should be used. If this
36# string is missing or empty, then "pam" is used.
37#
38# The final string gives the host-based access control for that listener. If
39# this is missing or empty, then all connections are accepted. Otherwise,
40# this should be a space-separated sequence of regular expressions; any host
41# with a fully-qualified domain name or an IP address that matches one of
42# these regular expressions will be accepted.
43#
44# Example: listen on TCP port 9363 on all interfaces, accepting connections
45# only from machines in example.com or localhost, and allow access through
46# the unix domain socket unconditionally:
47#
48# (xen-api-server ((9363 pam '^localhost$ example\\.com$')
49# (unix none)))
50#
51# Optionally, the TCP Xen-API server can use SSL by specifying the private
52# key and certificate location:
53#
54# (9367 pam '' xen-api.key xen-api.crt)
55#
56# Default:
57# (xen-api-server ((unix)))
58
59
60(xend-http-server yes)
61(xend-unix-server yes)
62(xend-tcp-xmlrpc-server yes)
63(xend-unix-xmlrpc-server yes)
64#(xend-relocation-server no)
65(xend-relocation-server yes)
66#(xend-relocation-ssl-server no)
67(xend-udev-event-server yes)
68
69#(xend-unix-path /var/lib/xend/xend-socket)
70
71
72# Address and port xend should use for the legacy TCP XMLRPC interface,
73# if xend-tcp-xmlrpc-server is set.
74#(xend-tcp-xmlrpc-server-address 'localhost')
75#(xend-tcp-xmlrpc-server-port 8006)
76
77# SSL key and certificate to use for the legacy TCP XMLRPC interface.
78# Setting these will mean that this port serves only SSL connections as
79# opposed to plaintext ones.
80#(xend-tcp-xmlrpc-server-ssl-key-file xmlrpc.key)
81#(xend-tcp-xmlrpc-server-ssl-cert-file xmlrpc.crt)
82
83
84# Port xend should use for the HTTP interface, if xend-http-server is set.
85#(xend-port 8000)
86
87# Port xend should use for the relocation interface, if xend-relocation-server
88# is set.
89#(xend-relocation-port 8002)
90
91# Port xend should use for the ssl relocation interface, if
92# xend-relocation-ssl-server is set.
93#(xend-relocation-ssl-port 8003)
94
95# SSL key and certificate to use for the ssl relocation interface, if
96# xend-relocation-ssl-server is set.
97#(xend-relocation-server-ssl-key-file xmlrpc.key)
98#(xend-relocation-server-ssl-cert-file xmlrpc.crt)
99
100# Whether to use ssl as default when relocating.
101#(xend-relocation-ssl no)
102
103# Address xend should listen on for HTTP connections, if xend-http-server is
104# set.
105# Specifying 'localhost' prevents remote connections.
106# Specifying the empty string '' (the default) allows all connections.
107#(xend-address '')
108#(xend-address localhost)
109
110# Address xend should listen on for relocation-socket connections, if
111# xend-relocation-server is set.
112# Meaning and default as for xend-address above.
113# Also, interface name is allowed (e.g. eth0) there to get the
114# relocation address to be bound on.
115#(xend-relocation-address '')
116
117# The hosts allowed to talk to the relocation port. If this is empty (the
118# default), then all connections are allowed (assuming that the connection
119# arrives on a port and interface on which we are listening; see
120# xend-relocation-port and xend-relocation-address above). Otherwise, this
121# should be a space-separated sequence of regular expressions. Any host with
122# a fully-qualified domain name or an IP address that matches one of these
123# regular expressions will be accepted.
124#
125# For example:
126# (xend-relocation-hosts-allow '^localhost$ ^.*\\.example\\.org$')
127#
128#(xend-relocation-hosts-allow '')
129(xend-relocation-hosts-allow '^localhost$ ^localhost\\.localdomain$')
130
131# The limit (in kilobytes) on the size of the console buffer
132#(console-limit 1024)
133
134##
135# To bridge network traffic, like this:
136#
137# dom0: ----------------- bridge -> real eth0 -> the network
138# |
139# domU: fake eth0 -> vifN.0 -+
140#
141# use
142#
143# (network-script network-bridge)
144#
145# Your default ethernet device is used as the outgoing interface, by default.
146# To use a different one (e.g. eth1) use
147#
148# (network-script 'network-bridge netdev=eth1')
149#
150# The bridge is named eth0, by default (yes, really!)
151#
152
153# It is normally much better to create the bridge yourself in
154# /etc/network/interfaces. network-bridge start does nothing if you
155# already have a bridge, and network-bridge stop does nothing if the
156# default bridge name (normally eth0) is not a bridge. See
157# bridge-utils-interfaces(5) for full information on the syntax in
158# /etc/network/interfaces, but you probably want something like this:
159# iface xenbr0 inet static
160# address [etc]
161# netmask [etc]
162# [etc]
163# bridge_ports eth0
164#
165# To have network-bridge create a differently-named bridge, use:
166# (network-script 'network-bridge bridge=<name>')
167#
168# It is possible to use the network-bridge script in more complicated
169# scenarios, such as having two outgoing interfaces, with two bridges, and
170# two fake interfaces per guest domain. To do things like this, write
171# yourself a wrapper script, and call network-bridge from it, as appropriate.
172#
173(network-script network-bridge)
174
175# The script used to control virtual interfaces. This can be overridden on a
176# per-vif basis when creating a domain or a configuring a new vif. The
177# vif-bridge script is designed for use with the network-bridge script, or
178# similar configurations.
179#
180# If you have overridden the bridge name using
181# (network-script 'network-bridge bridge=<name>') then you may wish to do the
182# same here. The bridge name can also be set when creating a domain or
183# configuring a new vif, but a value specified here would act as a default.
184#
185# If you are using only one bridge, the vif-bridge script will discover that,
186# so there is no need to specify it explicitly. The default is to use
187# the bridge which is listed first in the output from brctl.
188#
189(vif-script vif-bridge)
190
191
192## Use the following if network traffic is routed, as an alternative to the
193# settings for bridged networking given above.
194#(network-script network-route)
195#(vif-script vif-route)
196
197
198## Use the following if network traffic is routed with NAT, as an alternative
199# to the settings for bridged networking given above.
200#(network-script network-nat)
201#(vif-script vif-nat)
202
203# dom0-min-mem is the lowest permissible memory level (in MB) for dom0.
204# This is a minimum both for auto-ballooning (as enabled by
205# enable-dom0-ballooning below) and for xm mem-set when applied to dom0.
206(dom0-min-mem 196)
207
208# Whether to enable auto-ballooning of dom0 to allow domUs to be created.
209# If enable-dom0-ballooning = no, dom0 will never balloon out.
210(enable-dom0-ballooning yes)
211
212# 32-bit paravirtual domains can only consume physical
213# memory below 168GB. On systems with memory beyond that address,
214# they'll be confined to memory below 128GB.
215# Using total_available_memory (in GB) to specify the amount of memory reserved
216# in the memory pool exclusively for 32-bit paravirtual domains.
217# Additionally you should use dom0_mem = <-Value> as a parameter in
218# xen kernel to reserve the memory for 32-bit paravirtual domains, default
219# is "0" (0GB).
220(total_available_memory 0)
221
222# In SMP system, dom0 will use dom0-cpus # of CPUS
223# If dom0-cpus = 0, dom0 will take all cpus available
224(dom0-cpus 0)
225
226# Whether to enable core-dumps when domains crash.
227#(enable-dump no)
228
229# The tool used for initiating virtual TPM migration
230#(external-migration-tool '')
231
232# The interface for VNC servers to listen on. Defaults
233# to 127.0.0.1 To restore old 'listen everywhere' behaviour
234# set this to 0.0.0.0
235#(vnc-listen '127.0.0.1')
236
237# The default password for VNC console on HVM domain.
238# Empty string is no authentication.
239(vncpasswd '')
240
241# The VNC server can be told to negotiate a TLS session
242# to encryption all traffic, and provide x509 cert to
243# clients enabling them to verify server identity. The
244# GTK-VNC widget, virt-viewer, virt-manager and VeNCrypt
245# all support the VNC extension for TLS used in QEMU. The
246# TightVNC/RealVNC/UltraVNC clients do not.
247#
248# To enable this create x509 certificates / keys in the
249# directory ${XEN_CONFIG_DIR} + vnc
250#
251# ca-cert.pem - The CA certificate
252# server-cert.pem - The Server certificate signed by the CA
253# server-key.pem - The server private key
254#
255# and then uncomment this next line
256# (vnc-tls 1)
257
258# The certificate dir can be pointed elsewhere..
259#
260# (vnc-x509-cert-dir vnc)
261
262# The server can be told to request & validate an x509
263# certificate from the client. Only clients with a cert
264# signed by the trusted CA will be able to connect. This
265# is more secure the password auth alone. Passwd auth can
266# used at the same time if desired. To enable client cert
267# checking uncomment this:
268#
269# (vnc-x509-verify 1)
270
271# The default keymap to use for the VM's virtual keyboard
272# when not specififed in VM's configuration
273#(keymap 'en-us')
274
275# Script to run when the label of a resource has changed.
276#(resource-label-change-script '')
277
278# Rotation count of qemu-dm log file.
279#(qemu-dm-logrotate-count 10)
280
281# Path where persistent domain configuration is stored.
282# Default is /var/lib/xend/domains/
283#(xend-domains-path /var/lib/xend/domains)
284
285# Number of seconds xend will wait for device creation and
286# destruction
287#(device-create-timeout 100)
288#(device-destroy-timeout 100)
289
290# When assigning device to HVM guest, we use the strict check for HVM guest by
291# default. (For PV guest, we use loose check automatically if necessary.)
292# When we assign device to HVM guest, if we meet with the co-assignment
293# issues or the ACS issue, we could try changing the option to 'no' -- however,
294# we have to realize this may incur security issue and we can't make sure the
295# device assignment could really work properly even after we do this.
296#(pci-passthrough-strict-check yes)
297
298# If we have a very big scsi device configuration, start of xend is slow,
299# because xend scans all the device paths to build its internal PSCSI device
300# list. If we need only a few devices for assigning to a guest, we can reduce
301# the scan to this device. Set list list of device paths in same syntax like in
302# command lsscsi, e.g. ('16:0:0:0' '15:0')
303# (pscsi-device-mask ('*'))
304
diff --git a/recipes-extended/xen/files/xenminiinit.sh b/recipes-extended/xen/files/xenminiinit.sh
deleted file mode 100755
index 22d5008f..00000000
--- a/recipes-extended/xen/files/xenminiinit.sh
+++ /dev/null
@@ -1,59 +0,0 @@
1#!/bin/sh
2
3# This is currently a very raw init script for xen-minimal
4# Feel free to expand and make more useful
5
6STARTDOMAINS="rtos freedos"
7
8# Shutdown Xen domains
9for foo in $STARTDOMAINS ; do
10 xl destroy $foo
11done
12
13# Stop and Startup Xen common
14if test -f /etc/init.d/xencommons ; then
15 echo Using Xen standard init scripts
16# /etc/init.d/libvirtd stop
17# /etc/init.d/xendomains stop
18# /etc/init.d/xencommons stop
19#
20# /etc/init.d/xencommons start
21# /etc/init.d/libvirtd start
22# /etc/init.d/xendomains start
23else
24 echo Skipping Xen standard init scripts
25
26 killall xenstored
27 killall xenconsoled
28 umount /proc/xen
29
30 # Fix up device nodes
31 if pidof udevd ; then
32 echo Udev running. Skipping mdev fixups
33 else
34 rm -rf /dev/xen
35 mkdir /dev/xen
36 for foo in /dev/xen!* ; do ln -s $foo /dev/xen/`echo $foo | cut -f 2 -d '!'` ; done
37 fi
38
39 mount -t xenfs xenfs /proc/xen
40 xenstored --pid-file=/var/run/xenstored.pid
41 xenstore-write "/local/domain/0/name" "Domain-0"
42 xenconsoled --pid-file=/var/run/xenconsoled.pid
43fi
44
45# Remove the images we have
46cd /tmp
47rm -rf xen
48
49# Grab and start the VM images
50mkdir xen
51cd xen
52for foo in $STARTDOMAINS ; do
53 wget http://candidates/xen/images/$foo.zip
54 unzip $foo.zip
55 xl create $foo.cfg
56done
57
58# Fix up the Webmin server with a new admin password
59test -f /usr/libexec/webmin/changepass.pl && /usr/libexec/webmin/changepass.pl /etc/webmin admin password