summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/files
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-07-06 19:18:49 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-08 22:44:48 -0400
commit16ec6ab62c5f41541092318170e0221e7ce0da89 (patch)
tree9f283731557b197729b66bd9fe3c125954230e39 /recipes-extended/xen/files
parent596d98b559f1c2b40ea4b0f3dbf23ed131e4a817 (diff)
downloadmeta-virtualization-16ec6ab62c5f41541092318170e0221e7ce0da89.tar.gz
xen-tools: apply kdd tool patch
Apply an upstream Xen Release-acked patch to fix kdd debugger and remove the temporary inhibit of Werror on building that tool. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/xen/files')
-rw-r--r--recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch12
-rw-r--r--recipes-extended/xen/files/xen-tools-kdd-fix-build-again.patch39
2 files changed, 39 insertions, 12 deletions
diff --git a/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch b/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch
index 6e43a4ff..ba97c4bc 100644
--- a/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch
+++ b/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch
@@ -40,15 +40,3 @@ index a151b3f625..a05ceec1e5 100644
40-- 40--
412.19.1 412.19.1
42 42
43diff --git a/tools/debugger/kdd/Makefile b/tools/debugger/kdd/Makefile
44index 26116949d4..a72ad3b1e0 100644
45--- a/tools/debugger/kdd/Makefile
46+++ b/tools/debugger/kdd/Makefile
47@@ -1,7 +1,6 @@
48 XEN_ROOT = $(CURDIR)/../../..
49 include $(XEN_ROOT)/tools/Rules.mk
50
51-CFLAGS += -Werror
52 CFLAGS += $(CFLAGS_libxenctrl)
53 CFLAGS += -DXC_WANT_COMPAT_MAP_FOREIGN_API
54 LDLIBS += $(LDLIBS_libxenctrl)
diff --git a/recipes-extended/xen/files/xen-tools-kdd-fix-build-again.patch b/recipes-extended/xen/files/xen-tools-kdd-fix-build-again.patch
new file mode 100644
index 00000000..61229997
--- /dev/null
+++ b/recipes-extended/xen/files/xen-tools-kdd-fix-build-again.patch
@@ -0,0 +1,39 @@
1From d44cbbe0f3243afcc56e47dcfa97bbfe23e46fbb Mon Sep 17 00:00:00 2001
2From: Wei Liu <wl@xen.org>
3Date: Fri, 3 Jul 2020 20:10:01 +0000
4Subject: [PATCH] kdd: fix build again
5
6Restore Tim's patch. The one that was committed was recreated by me
7because git didn't accept my saved copy. I made some mistakes while
8recreating that patch and here we are.
9
10Fixes: 3471cafbdda3 ("kdd: stop using [0] arrays to access packet contents")
11Reported-by: Michael Young <m.a.young@durham.ac.uk>
12Signed-off-by: Wei Liu <wl@xen.org>
13Reviewed-by: Tim Deegan <tim@xen.org>
14Release-acked-by: Paul Durrant <paul@xen.org>
15---
16 tools/debugger/kdd/kdd.c | 4 ++--
17 1 file changed, 2 insertions(+), 2 deletions(-)
18
19diff --git a/tools/debugger/kdd/kdd.c b/tools/debugger/kdd/kdd.c
20index 866532f0c7..a7d0976ea4 100644
21--- a/tools/debugger/kdd/kdd.c
22+++ b/tools/debugger/kdd/kdd.c
23@@ -79,11 +79,11 @@ typedef struct {
24 /* State of the debugger stub */
25 typedef struct {
26 union {
27- uint8_t txb[sizeof (kdd_hdr)]; /* Marshalling area for tx */
28+ uint8_t txb[sizeof (kdd_pkt)]; /* Marshalling area for tx */
29 kdd_pkt txp; /* Also readable as a packet structure */
30 };
31 union {
32- uint8_t rxb[sizeof (kdd_hdr)]; /* Marshalling area for rx */
33+ uint8_t rxb[sizeof (kdd_pkt)]; /* Marshalling area for rx */
34 kdd_pkt rxp; /* Also readable as a packet structure */
35 };
36 unsigned int cur; /* Offset into rx where we'll put the next byte */
37--
382.17.1
39