summaryrefslogtreecommitdiffstats
path: root/recipes-extended/vgabios/biossums_0.7a.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-04-29 13:11:35 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-05-02 14:07:30 -0400
commit8386caefb7449f9b53e646c2e2cb1ba8bef6faa6 (patch)
tree89df9ea08bdc8aaf5edc92d62acc65f83d7fa4cb /recipes-extended/vgabios/biossums_0.7a.bb
parent36433bfef3b690ee1211f04a38022b1f3dc2b383 (diff)
downloadmeta-virtualization-8386caefb7449f9b53e646c2e2cb1ba8bef6faa6.tar.gz
vgabios: upgrade to 0.8a and cleanup recipe
Upgrade to 0.8a. License checksum updated as the FSF street address changed. Apply a patch to use the correct host compiler when building biossums, removing the need for a separate biossums-native recipe. Don't hardcode /usr/share, use ${datadir}. Install all found firmware (including the new Banshee BIOS in 0.8a) and the debug files which were not installed but intended to be packaged. Remove redundant PR and S assignments, as these are the default values. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/vgabios/biossums_0.7a.bb')
-rw-r--r--recipes-extended/vgabios/biossums_0.7a.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/recipes-extended/vgabios/biossums_0.7a.bb b/recipes-extended/vgabios/biossums_0.7a.bb
deleted file mode 100644
index 95483fff..00000000
--- a/recipes-extended/vgabios/biossums_0.7a.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1DESCRIPTION = "biossums tool for building Plex86/Bochs LGPL VGABios"
2HOMEPAGE = "http://www.nongnu.org/vgabios/"
3LICENSE = "LGPL-2.1-only"
4SECTION = "firmware"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589"
7
8SRC_URI = "http://savannah.gnu.org/download/vgabios/vgabios-${PV}.tgz"
9
10SRC_URI[md5sum] = "2c0fe5c0ca08082a9293e3a7b23dc900"
11SRC_URI[sha256sum] = "9d24c33d4bfb7831e2069cf3644936a53ef3de21d467872b54ce2ea30881b865"
12
13BBCLASSEXTEND = "native"
14
15FILES:${PN} = "${bindir}/biossums"
16
17S = "${WORKDIR}/vgabios-${PV}"
18
19do_configure() {
20 # Don't override the compiler or its flags:
21 sed 's,^CC,DISABLED_CC,' -i Makefile
22 sed 's,^CFLAGS,DISABLED_CFLAGS,' -i Makefile
23 sed 's,^LDFLAGS,DISABLED_LDFLAGS,' -i Makefile
24 # Supply the C flags to the compiler:
25 sed 's,-o biossums,$(CFLAGS) -o biossums,' -i Makefile
26}
27
28do_compile() {
29 # clean removes binaries distributed with source
30 oe_runmake clean
31 oe_runmake biossums
32}
33
34do_install() {
35 mkdir -p "${D}${bindir}"
36 install -m 0755 biossums "${D}${bindir}"
37}