summaryrefslogtreecommitdiffstats
path: root/recipes-extended/vgabios/biossums_0.7a.bb
diff options
context:
space:
mode:
authorChristopher Clark <christopher.clark6@baesystems.com>2017-08-23 14:43:32 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-08-24 09:55:40 -0400
commit140c6836ed5ba04383d18236840b4f86d6008278 (patch)
tree4aeb59ceaf8b3f11a3775a3508046d08018a2b3b /recipes-extended/vgabios/biossums_0.7a.bb
parentaecdc17e0d9202954e8a8bf9cd80c0cb3505db41 (diff)
downloadmeta-virtualization-140c6836ed5ba04383d18236840b4f86d6008278.tar.gz
vgabios : extract biossums tool and build it separately, native
The biossums tool is used to generate the vgabios build product. This patch: * adds a separate recipe "biossums" for the tool * makes the vgabios recipe depend upon biossums-native * makes the vgabios recipe use the native binary rather than a locally built one The upstream source tarball contains binaries so these are removed before compiling proceeds. Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/vgabios/biossums_0.7a.bb')
-rw-r--r--recipes-extended/vgabios/biossums_0.7a.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-extended/vgabios/biossums_0.7a.bb b/recipes-extended/vgabios/biossums_0.7a.bb
new file mode 100644
index 00000000..10bd0142
--- /dev/null
+++ b/recipes-extended/vgabios/biossums_0.7a.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "biossums tool for building Plex86/Bochs LGPL VGABios"
2HOMEPAGE = "http://www.nongnu.org/vgabios/"
3LICENSE = "LGPLv2.1"
4SECTION = "firmware"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589"
7
8SRC_URI = "http://savannah.gnu.org/download/vgabios/vgabios-${PV}.tgz"
9
10SRC_URI[md5sum] = "2c0fe5c0ca08082a9293e3a7b23dc900"
11SRC_URI[sha256sum] = "9d24c33d4bfb7831e2069cf3644936a53ef3de21d467872b54ce2ea30881b865"
12
13BBCLASSEXTEND = "native"
14
15FILES_${PN} = "${bindir}/biossums"
16
17S = "${WORKDIR}/vgabios-${PV}"
18
19do_configure() {
20 # Don't override the compiler or its flags:
21 sed 's,^CC,DISABLED_CC,' -i Makefile
22 sed 's,^CFLAGS,DISABLED_CFLAGS,' -i Makefile
23 # Supply the C flags to the compiler:
24 sed 's,-o biossums,$(CFLAGS) -o biossums,' -i Makefile
25}
26
27do_compile() {
28 # clean removes binaries distributed with source
29 oe_runmake clean
30 oe_runmake biossums
31}
32
33do_install() {
34 mkdir -p "${D}${bindir}"
35 install -m 0755 biossums "${D}${bindir}"
36}