summaryrefslogtreecommitdiffstats
path: root/recipes-extended/seabios/seabios_1.9.1.bb
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2018-09-19 13:57:55 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-22 23:11:28 -0400
commit6f2de77556960d6953aa56fb8e8d876f58fdd583 (patch)
treed9456754171b7c5f57f33b88cf36f518ba907898 /recipes-extended/seabios/seabios_1.9.1.bb
parentcea8ca7c9c92f5cccc2dc4725d0e7de934f9c100 (diff)
downloadmeta-virtualization-6f2de77556960d6953aa56fb8e8d876f58fdd583.tar.gz
seabios: update to 1.11.2 and use github for SRC_URI
Update to version 1.11.2 fixes compile errors encountered with 1.9.1. Use the official QEMU github mirror of git.qemu.org/seabios as a stable, maintained, available SRC_URI for seabios releases. While downloads.seabios.org is documented as the official source, it has not published tarballs for the most recent releases. Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/seabios/seabios_1.9.1.bb')
-rw-r--r--recipes-extended/seabios/seabios_1.9.1.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/recipes-extended/seabios/seabios_1.9.1.bb b/recipes-extended/seabios/seabios_1.9.1.bb
deleted file mode 100644
index 77e8f34a..00000000
--- a/recipes-extended/seabios/seabios_1.9.1.bb
+++ /dev/null
@@ -1,43 +0,0 @@
1DESCRIPTION = "SeaBIOS"
2HOMEPAGE = "http://www.coreboot.org/SeaBIOS"
3LICENSE = "LGPLv3"
4SECTION = "firmware"
5
6SRC_URI = " \
7 https://www.seabios.org/downloads/${PN}-${PV}.tar.gz \
8 file://hostcc.patch \
9 "
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
12 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \
13 "
14
15SRC_URI[md5sum] = "e21b6f3e54d492be837ef20d66617f81"
16SRC_URI[sha256sum] = "8a2a562fe5cfd37fe8327cdc4a60accdfe441e235b29e6999fdeb442ba98d608"
17
18FILES_${PN} = "/usr/share/firmware"
19
20DEPENDS = "util-linux-native file-native bison-native flex-native gettext-native iasl-native python-native"
21
22TUNE_CCARGS = ""
23EXTRA_OEMAKE += "HOSTCC='${BUILD_CC}'"
24EXTRA_OEMAKE += "CROSS_PREFIX=${TARGET_PREFIX}"
25
26COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
27
28do_configure() {
29 oe_runmake defconfig
30}
31
32do_compile() {
33 unset CPP
34 unset CPPFLAGS
35 oe_runmake
36}
37
38do_install() {
39 oe_runmake
40 install -d ${D}/usr/share/firmware
41 install -m 0644 out/bios.bin ${D}/usr/share/firmware/
42}
43