summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libvirt
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-08-04 17:38:02 +0800
committerBruce Ashfield <bruce@zedd.org>2016-08-04 21:45:53 -0400
commitaf2948e0483c56abf191d65e0e2d412974c21357 (patch)
treeba1ed0db029d0ed3810488eeaca777cdef274d73 /recipes-extended/libvirt
parent357ca45fb122f71379636f1fa91e95fa2666c93d (diff)
downloadmeta-virtualization-af2948e0483c56abf191d65e0e2d412974c21357.tar.gz
libvirt: upgrade 1.3.2 -> 1.3.5
Upgrade libvirt from 1.3.2 to 1.3.5. * update checksums and remove PR * remove trailing whitespace * remove backport patch 0001-fix-crash-in-getAllDomainStats.patch * update context of patches * remove libvirtd.socket from SYSTEMD_SERVICE which doesn't exist anymore * install test data which ptest requires Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Bruce Ashfield <bruce@zedd.org>
Diffstat (limited to 'recipes-extended/libvirt')
-rw-r--r--recipes-extended/libvirt/libvirt-1.3.5/0001-to-fix-build-error.patch (renamed from recipes-extended/libvirt/libvirt-1.3.2/0001-to-fix-build-error.patch)0
-rw-r--r--recipes-extended/libvirt/libvirt-python.inc5
-rw-r--r--recipes-extended/libvirt/libvirt/0001-fix-crash-in-getAllDomainStats.patch57
-rw-r--r--recipes-extended/libvirt/libvirt/Revert-build-add-prefix-to-SYSTEMD_UNIT_DIR.patch16
-rw-r--r--recipes-extended/libvirt/libvirt/install-missing-file.patch12
-rw-r--r--recipes-extended/libvirt/libvirt/runptest.patch34
-rw-r--r--recipes-extended/libvirt/libvirt_1.3.5.bb (renamed from recipes-extended/libvirt/libvirt_1.3.2.bb)10
7 files changed, 47 insertions, 87 deletions
diff --git a/recipes-extended/libvirt/libvirt-1.3.2/0001-to-fix-build-error.patch b/recipes-extended/libvirt/libvirt-1.3.5/0001-to-fix-build-error.patch
index 089ee330..089ee330 100644
--- a/recipes-extended/libvirt/libvirt-1.3.2/0001-to-fix-build-error.patch
+++ b/recipes-extended/libvirt/libvirt-1.3.5/0001-to-fix-build-error.patch
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc
index 7a7a4cc5..bc2f1de2 100644
--- a/recipes-extended/libvirt/libvirt-python.inc
+++ b/recipes-extended/libvirt/libvirt-python.inc
@@ -17,10 +17,9 @@ FILES_${PN}-python = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*"
17 17
18SRC_URI += "http://libvirt.org/sources/python/libvirt-python-${PV}.tar.gz;name=libvirt_python" 18SRC_URI += "http://libvirt.org/sources/python/libvirt-python-${PV}.tar.gz;name=libvirt_python"
19SRC_URI += "file://libvirt_api_xml_path.patch;patchdir=../libvirt-python-${PV}" 19SRC_URI += "file://libvirt_api_xml_path.patch;patchdir=../libvirt-python-${PV}"
20SRC_URI += "file://0001-fix-crash-in-getAllDomainStats.patch;patchdir=../libvirt-python-${PV}"
21 20
22SRC_URI[libvirt_python.md5sum] = "ed018c714d7ddbe93221c796dff283ed" 21SRC_URI[libvirt_python.md5sum] = "4dbd7ef9ee9c4dea5887b5b31eb04529"
23SRC_URI[libvirt_python.sha256sum] = "6d35ae9e7801573393b9c92471f39e6700d479f10b641df81d041b469f160bf8" 22SRC_URI[libvirt_python.sha256sum] = "a0508a57637fd18a3584fb9d2322fb172f65708c9db16e0438a70eb0f36fa5c2"
24 23
25export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml" 24export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml"
26export LIBVIRT_CFLAGS = "-I${S}/include" 25export LIBVIRT_CFLAGS = "-I${S}/include"
diff --git a/recipes-extended/libvirt/libvirt/0001-fix-crash-in-getAllDomainStats.patch b/recipes-extended/libvirt/libvirt/0001-fix-crash-in-getAllDomainStats.patch
deleted file mode 100644
index 0583a940..00000000
--- a/recipes-extended/libvirt/libvirt/0001-fix-crash-in-getAllDomainStats.patch
+++ /dev/null
@@ -1,57 +0,0 @@
1From e9c4e2abffef007a28112ebb40a9586b0128f10b Mon Sep 17 00:00:00 2001
2From: Pavel Hrdina <phrdina@redhat.com>
3Date: Mon, 18 Apr 2016 16:53:50 +0200
4Subject: [PATCH] fix crash in getAllDomainStats
5
6Upstream-Status: Backport
7
8Commits 1d39dbaf and 827ed9b4 broke the libvirt-python API by removing
9virDomainRef() and virDomainFree(). virDomainStatsRecordListFree() will
10free that domain pointer and later when virDomain (python object) call
11its destructor and tries to free that same pointer again.
12
13Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1326839
14
15Signed-off-by: Pavel Hrdina <phrdina@redhat.com>
16---
17 libvirt-override.c | 8 +++++++-
18 1 file changed, 7 insertions(+), 1 deletion(-)
19
20diff --git a/libvirt-override.c b/libvirt-override.c
21index 4640ed5..2de95ce 100644
22--- a/libvirt-override.c
23+++ b/libvirt-override.c
24@@ -8381,6 +8381,7 @@ convertDomainStatsRecord(virDomainStatsRecordPtr *records,
25 PyObject *py_retval;
26 PyObject *py_record;
27 PyObject *py_record_stats = NULL;
28+ virDomainPtr dom = NULL;
29 size_t i;
30
31 if (!(py_retval = PyList_New(nrecords)))
32@@ -8392,9 +8393,12 @@ convertDomainStatsRecord(virDomainStatsRecordPtr *records,
33
34 VIR_PY_LIST_SET_GOTO(py_retval, i, py_record, error);
35
36+ dom = records[i]->dom;
37+ virDomainRef(dom);
38 VIR_PY_TUPLE_SET_GOTO(py_record, 0,
39- libvirt_virDomainPtrWrap(records[i]->dom),
40+ libvirt_virDomainPtrWrap(dom),
41 error);
42+ dom = NULL;
43
44 if (!(py_record_stats = getPyVirTypedParameter(records[i]->params,
45 records[i]->nparams)))
46@@ -8406,6 +8410,8 @@ convertDomainStatsRecord(virDomainStatsRecordPtr *records,
47 return py_retval;
48
49 error:
50+ if (dom)
51+ virDomainFree(dom);
52 Py_XDECREF(py_retval);
53 return NULL;
54 }
55--
562.8.1
57
diff --git a/recipes-extended/libvirt/libvirt/Revert-build-add-prefix-to-SYSTEMD_UNIT_DIR.patch b/recipes-extended/libvirt/libvirt/Revert-build-add-prefix-to-SYSTEMD_UNIT_DIR.patch
index 16c3a16b..02ddf68e 100644
--- a/recipes-extended/libvirt/libvirt/Revert-build-add-prefix-to-SYSTEMD_UNIT_DIR.patch
+++ b/recipes-extended/libvirt/libvirt/Revert-build-add-prefix-to-SYSTEMD_UNIT_DIR.patch
@@ -1,3 +1,9 @@
1Upstream-Status: Inappropriate [configuration]
2
3Update context for version 1.3.5.
4
5Signed-off-by: Kai Kang <kai.kang@windriver.com>
6---
1From dd915e7f70e676aea93f750c75d16ce646e71e4b Mon Sep 17 00:00:00 2001 7From dd915e7f70e676aea93f750c75d16ce646e71e4b Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com> 8From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Wed, 9 Sep 2015 11:52:44 -0400 9Date: Wed, 9 Sep 2015 11:52:44 -0400
@@ -24,20 +30,20 @@ diff --git a/daemon/Makefile.am b/daemon/Makefile.am
24index 2dbe81b..41ea2db 100644 30index 2dbe81b..41ea2db 100644
25--- a/daemon/Makefile.am 31--- a/daemon/Makefile.am
26+++ b/daemon/Makefile.am 32+++ b/daemon/Makefile.am
27@@ -445,7 +445,7 @@ endif ! LIBVIRT_INIT_SCRIPT_UPSTART 33@@ -449,7 +449,7 @@ endif ! LIBVIRT_INIT_SCRIPT_UPSTART
28 34
29 if LIBVIRT_INIT_SCRIPT_SYSTEMD 35 if LIBVIRT_INIT_SCRIPT_SYSTEMD
30 36
31-SYSTEMD_UNIT_DIR = $(prefix)/lib/systemd/system 37-SYSTEMD_UNIT_DIR = $(prefix)/lib/systemd/system
32+SYSTEMD_UNIT_DIR = /lib/systemd/system 38+SYSTEMD_UNIT_DIR = /lib/systemd/system
33 BUILT_SOURCES += libvirtd.service libvirtd.socket 39 BUILT_SOURCES += libvirtd.service
34 40
35 install-init-systemd: install-sysconfig libvirtd.service libvirtd.socket 41 install-init-systemd: install-sysconfig libvirtd.service
36diff --git a/src/Makefile.am b/src/Makefile.am 42diff --git a/src/Makefile.am b/src/Makefile.am
37index a316b4d..d271291 100644 43index a316b4d..d271291 100644
38--- a/src/Makefile.am 44--- a/src/Makefile.am
39+++ b/src/Makefile.am 45+++ b/src/Makefile.am
40@@ -2594,7 +2594,7 @@ EXTRA_DIST += \ 46@@ -2633,7 +2633,7 @@ EXTRA_DIST += \
41 if WITH_LIBVIRTD 47 if WITH_LIBVIRTD
42 if LIBVIRT_INIT_SCRIPT_SYSTEMD 48 if LIBVIRT_INIT_SCRIPT_SYSTEMD
43 49
@@ -50,7 +56,7 @@ diff --git a/tools/Makefile.am b/tools/Makefile.am
50index b3227a7..0e58f73 100644 56index b3227a7..0e58f73 100644
51--- a/tools/Makefile.am 57--- a/tools/Makefile.am
52+++ b/tools/Makefile.am 58+++ b/tools/Makefile.am
53@@ -356,7 +356,7 @@ libvirt-guests.init: libvirt-guests.init.in libvirt-guests.sh 59@@ -380,7 +380,7 @@ libvirt-guests.init: libvirt-guests.init.in libvirt-guests.sh
54 60
55 61
56 EXTRA_DIST += libvirt-guests.service.in 62 EXTRA_DIST += libvirt-guests.service.in
diff --git a/recipes-extended/libvirt/libvirt/install-missing-file.patch b/recipes-extended/libvirt/libvirt/install-missing-file.patch
index f6f6e256..ecd4a87b 100644
--- a/recipes-extended/libvirt/libvirt/install-missing-file.patch
+++ b/recipes-extended/libvirt/libvirt/install-missing-file.patch
@@ -1,3 +1,11 @@
1Upstream-Status: Inapproriate
2
3This patch is for ptest, so it is inapproriate to send to upstream.
4
5Update context for 1.3.5.
6
7Signed-off-by: Kai Kang <kai.kang@windriver.com>
8---
1From 0780181a3285511f166487a54ebc231fc657edfe Mon Sep 17 00:00:00 2001 9From 0780181a3285511f166487a54ebc231fc657edfe Mon Sep 17 00:00:00 2001
2From: Catalin Enache <catalin.enache@windriver.com> 10From: Catalin Enache <catalin.enache@windriver.com>
3Date: Mon, 25 Jul 2016 16:38:51 +0300 11Date: Mon, 25 Jul 2016 16:38:51 +0300
@@ -14,10 +22,10 @@ diff --git a/tests/Makefile.am b/tests/Makefile.am
14index 02e0dd8..187fbca 100644 22index 02e0dd8..187fbca 100644
15--- a/tests/Makefile.am 23--- a/tests/Makefile.am
16+++ b/tests/Makefile.am 24+++ b/tests/Makefile.am
17@@ -155,6 +155,7 @@ EXTRA_DIST = \ 25@@ -170,6 +170,7 @@ EXTRA_DIST = \
18 xml2vmxdata 26 xml2vmxdata
19 27
20 test_helpers = commandhelper ssh test_conf 28 test_helpers = commandhelper ssh virconftest
21+test_misc = 29+test_misc =
22 test_programs = virshtest sockettest \ 30 test_programs = virshtest sockettest \
23 nodeinfotest virbuftest \ 31 nodeinfotest virbuftest \
diff --git a/recipes-extended/libvirt/libvirt/runptest.patch b/recipes-extended/libvirt/libvirt/runptest.patch
index a33f5695..b7609a81 100644
--- a/recipes-extended/libvirt/libvirt/runptest.patch
+++ b/recipes-extended/libvirt/libvirt/runptest.patch
@@ -1,14 +1,18 @@
1Update context for 1.3.5.
2
3Signed-off-by: Kai Kang <kai.kang@windriver.com>
4---
1Add 'install-ptest' rule. 5Add 'install-ptest' rule.
2Change TESTS_ENVIRONMENT to allow running outside build dir. 6Change TESTS_ENVIRONMENT to allow running outside build dir.
3 7
4Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com> 8Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com>
5Upstream-status: Pending 9Upstream-status: Pending
6 10---
7Index: libvirt-1.2.4/tests/Makefile.am 11diff --git a/tests/Makefile.am b/tests/Makefile.am
8=================================================================== 12index 0c4ad3c..bb4e31a 100644
9--- libvirt-1.2.4.orig/tests/Makefile.am 13--- a/tests/Makefile.am
10+++ libvirt-1.2.4/tests/Makefile.am 14+++ b/tests/Makefile.am
11@@ -31,9 +31,11 @@ 15@@ -33,11 +33,13 @@ INCLUDES = \
12 -I$(top_srcdir)/src/conf \ 16 -I$(top_srcdir)/src/conf \
13 $(GETTEXT_CPPFLAGS) 17 $(GETTEXT_CPPFLAGS)
14 18
@@ -16,13 +20,17 @@ Index: libvirt-1.2.4/tests/Makefile.am
16+ 20+
17 AM_CFLAGS = \ 21 AM_CFLAGS = \
18- -Dabs_builddir="\"$(abs_builddir)\"" \ 22- -Dabs_builddir="\"$(abs_builddir)\"" \
23- -Dabs_topbuilddir="\"$(abs_topbuilddir)\"" \
19- -Dabs_srcdir="\"$(abs_srcdir)\"" \ 24- -Dabs_srcdir="\"$(abs_srcdir)\"" \
25- -Dabs_topsrcdir="\"$(abs_topsrcdir)\"" \
20+ -Dabs_builddir="\"$(PTEST_DIR)/tests\"" \ 26+ -Dabs_builddir="\"$(PTEST_DIR)/tests\"" \
27+ -Dabs_topbuilddir="\"$(PTEST_DIR)\"" \
21+ -Dabs_srcdir="\"$(PTEST_DIR)/tests\"" \ 28+ -Dabs_srcdir="\"$(PTEST_DIR)/tests\"" \
29+ -Dabs_topsrcdir="\"$(PTEST_DIR)\"" \
22 $(LIBXML_CFLAGS) \ 30 $(LIBXML_CFLAGS) \
23 $(LIBNL_CFLAGS) \ 31 $(LIBNL_CFLAGS) \
24 $(GNUTLS_CFLAGS) \ 32 $(GNUTLS_CFLAGS) \
25@@ -48,7 +50,7 @@ 33@@ -62,7 +64,7 @@ QEMULIB_LDFLAGS = \
26 34
27 if WITH_DRIVER_MODULES 35 if WITH_DRIVER_MODULES
28 INCLUDES += \ 36 INCLUDES += \
@@ -31,15 +39,12 @@ Index: libvirt-1.2.4/tests/Makefile.am
31 endif WITH_DRIVER_MODULES 39 endif WITH_DRIVER_MODULES
32 40
33 PROBES_O = 41 PROBES_O =
34@@ -409,20 +411,19 @@ 42@@ -483,17 +485,15 @@ TESTS = $(test_programs) \
35 # Also, BSD sh doesn't like 'a=b b=$$a', so we can't use an 43 # Also, BSD sh doesn't like 'a=b b=$$a', so we can't use an
36 # intermediate shell variable, but must do all the expansion in make 44 # intermediate shell variable, but must do all the expansion in make
37 45
38-lv_abs_top_builddir=$(shell cd '$(top_builddir)' && pwd) 46-lv_abs_top_builddir=$(shell cd '$(top_builddir)' && pwd)
39 path_add = $(subst :,$(PATH_SEPARATOR),\ 47-
40- $(subst !,$(lv_abs_top_builddir)/,!daemon:!tools:!tests))
41+ $(subst !,$(PTEST_DIR)/,!daemon:!tools:!tests))
42
43 VIR_TEST_EXPENSIVE ?= $(VIR_TEST_EXPENSIVE_DEFAULT) 48 VIR_TEST_EXPENSIVE ?= $(VIR_TEST_EXPENSIVE_DEFAULT)
44 TESTS_ENVIRONMENT = \ 49 TESTS_ENVIRONMENT = \
45- abs_top_builddir=$(lv_abs_top_builddir) \ 50- abs_top_builddir=$(lv_abs_top_builddir) \
@@ -52,14 +57,13 @@ Index: libvirt-1.2.4/tests/Makefile.am
52+ abs_builddir="$(PTEST_DIR)/tests" \ 57+ abs_builddir="$(PTEST_DIR)/tests" \
53+ abs_srcdir="$(PTEST_DIR)/tests" \ 58+ abs_srcdir="$(PTEST_DIR)/tests" \
54+ CONFIG_HEADER="$(PTEST_DIR)/config.h" \ 59+ CONFIG_HEADER="$(PTEST_DIR)/config.h" \
55 PATH="$(path_add)$(PATH_SEPARATOR)$$PATH" \
56 SHELL="$(SHELL)" \ 60 SHELL="$(SHELL)" \
57- LIBVIRT_DRIVER_DIR="$(lv_abs_top_builddir)/src/.libs" \ 61- LIBVIRT_DRIVER_DIR="$(lv_abs_top_builddir)/src/.libs" \
58+ LIBVIRT_DRIVER_DIR="$(PTEST_DIR)/src/.libs" \ 62+ LIBVIRT_DRIVER_DIR="$(PTEST_DIR)/src/.libs" \
59 LIBVIRT_AUTOSTART=0 \ 63 LIBVIRT_AUTOSTART=0 \
60 LC_ALL=C \ 64 LC_ALL=C \
61 VIR_TEST_EXPENSIVE=$(VIR_TEST_EXPENSIVE) \ 65 VIR_TEST_EXPENSIVE=$(VIR_TEST_EXPENSIVE) \
62@@ -1137,5 +1138,51 @@ 66@@ -1388,5 +1388,51 @@ else ! WITH_CIL
63 EXTRA_DIST += objectlocking.ml 67 EXTRA_DIST += objectlocking.ml
64 endif ! WITH_CIL 68 endif ! WITH_CIL
65 69
diff --git a/recipes-extended/libvirt/libvirt_1.3.2.bb b/recipes-extended/libvirt/libvirt_1.3.5.bb
index b11f514a..f4a8f387 100644
--- a/recipes-extended/libvirt/libvirt_1.3.2.bb
+++ b/recipes-extended/libvirt/libvirt_1.3.5.bb
@@ -5,7 +5,6 @@ LICENSE_${PN}-ptest = "GPLv2+ & LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://COPYING.LESSER;md5=4b54a1fd55a448865a0b32d41598759d" 6 file://COPYING.LESSER;md5=4b54a1fd55a448865a0b32d41598759d"
7SECTION = "console/tools" 7SECTION = "console/tools"
8PR = "r1"
9 8
10DEPENDS = "bridge-utils gnutls libxml2 lvm2 avahi parted curl libpcap util-linux e2fsprogs pm-utils \ 9DEPENDS = "bridge-utils gnutls libxml2 lvm2 avahi parted curl libpcap util-linux e2fsprogs pm-utils \
11 iptables dnsmasq readline libtasn1 libxslt-native" 10 iptables dnsmasq readline libtasn1 libxslt-native"
@@ -36,8 +35,8 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.gz;name=libvirt \
36 file://install-missing-file.patch \ 35 file://install-missing-file.patch \
37 " 36 "
38 37
39SRC_URI[libvirt.md5sum] = "b48b06bbc7efbe9973ed0f3f223d6da2" 38SRC_URI[libvirt.md5sum] = "f9dc1e63d559eca50ae0ee798a4c6c6d"
40SRC_URI[libvirt.sha256sum] = "e3c6fc2683178660b371efb3ac7a1103a3f4b78efac7ffe560bc5917974ccf05" 39SRC_URI[libvirt.sha256sum] = "93a23c44eb431da46c9458f95a66e29c9b98e37515d44b6be09e75b35ec94ac8"
41 40
42inherit autotools gettext update-rc.d pkgconfig ptest systemd 41inherit autotools gettext update-rc.d pkgconfig ptest systemd
43 42
@@ -137,7 +136,6 @@ INITSCRIPT_PARAMS_${PN}-libvirtd = "defaults 72"
137 136
138SYSTEMD_PACKAGES = "${PN}-libvirtd" 137SYSTEMD_PACKAGES = "${PN}-libvirtd"
139SYSTEMD_SERVICE_${PN}-libvirtd = " \ 138SYSTEMD_SERVICE_${PN}-libvirtd = " \
140 libvirtd.socket \
141 libvirtd.service \ 139 libvirtd.service \
142 virtlockd.service \ 140 virtlockd.service \
143 libvirt-guests.service \ 141 libvirt-guests.service \
@@ -249,7 +247,7 @@ do_install_append() {
249 >> ${D}${sysconfdir}/default/volatiles/99_libvirt 247 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
250 248
251 # Add hook support for libvirt 249 # Add hook support for libvirt
252 mkdir -p ${D}/etc/libvirt/hooks 250 mkdir -p ${D}/etc/libvirt/hooks
253 251
254 # remove .la references to our working diretory 252 # remove .la references to our working diretory
255 for i in `find ${D}${libdir} -type f -name *.la`; do 253 for i in `find ${D}${libdir} -type f -name *.la`; do
@@ -270,6 +268,8 @@ do_compile_ptest() {
270do_install_ptest() { 268do_install_ptest() {
271 oe_runmake -C tests install-ptest 269 oe_runmake -C tests install-ptest
272 270
271 find ${S}/tests -maxdepth 1 -type d -exec cp -r {} ${D}${PTEST_PATH}/tests/ \;
272
273 # remove .la files for ptest, they aren't required and can trigger QA errors 273 # remove .la files for ptest, they aren't required and can trigger QA errors
274 for i in `find ${D}${PTEST_PATH} -type f -name *.la`; do 274 for i in `find ${D}${PTEST_PATH} -type f -name *.la`; do
275 rm -f $i 275 rm -f $i