diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-01-29 10:32:43 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-01-29 10:32:43 -0500 |
commit | 0d4fca1dddc3d23c583c55e77761f963e737731c (patch) | |
tree | 81127e7737f4a210d0640c9ef3b0e6728aa34e77 /recipes-extended/libvirt | |
parent | c93bc0c0185da21482164d9f76047715349cbb17 (diff) | |
download | meta-virtualization-0d4fca1dddc3d23c583c55e77761f963e737731c.tar.gz |
libvirt: refresh patches for 1.2.1
The 1.2.1 libvirt update was pushed before the patches were refreshed,
which results in a patching failure.
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/libvirt')
-rw-r--r-- | recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch | 47 |
1 files changed, 16 insertions, 31 deletions
diff --git a/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch b/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch index 821af909..91410449 100644 --- a/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch +++ b/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 70700ad6bf2db2ba8e169168f225458743b90f86 Mon Sep 17 00:00:00 2001 | 1 | From dade75d1ce25df6ab61867250d7adb65b4912090 Mon Sep 17 00:00:00 2001 |
2 | From: Bruce Ashfield <bruce.ashfield@windriver.com> | 2 | From: Bruce Ashfield <bruce.ashfield@windriver.com> |
3 | Date: Fri, 2 Aug 2013 11:38:43 -0400 | 3 | Date: Fri, 2 Aug 2013 11:38:43 -0400 |
4 | Subject: [PATCH] tools: add libvirt-net-rpc to virt-host-validate when TLS is | 4 | Subject: [PATCH] tools: add libvirt-net-rpc to virt-host-validate when TLS is |
@@ -10,30 +10,15 @@ link against libvirt-net-rpc which provides the implementation. | |||
10 | 10 | ||
11 | Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> | 11 | Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> |
12 | --- | 12 | --- |
13 | examples/domain-events/events-c/Makefile.am | 6 ++++++ | 13 | examples/dominfo/Makefile.am | 7 +++++++ |
14 | examples/dominfo/Makefile.am | 7 +++++++ | 14 | examples/domsuspend/Makefile.am | 7 +++++++ |
15 | examples/domsuspend/Makefile.am | 7 +++++++ | 15 | examples/hellolibvirt/Makefile.am | 7 +++++++ |
16 | examples/hellolibvirt/Makefile.am | 7 +++++++ | 16 | examples/openauth/Makefile.am | 6 ++++++ |
17 | examples/openauth/Makefile.am | 6 ++++++ | 17 | tools/Makefile.am | 13 +++++++++++++ |
18 | tools/Makefile.am | 13 +++++++++++++ | 18 | 5 files changed, 40 insertions(+) |
19 | 6 files changed, 46 insertions(+) | ||
20 | 19 | ||
21 | diff --git a/examples/domain-events/events-c/Makefile.am b/examples/domain-events/events-c/Makefile.am | ||
22 | index 0646aee..6b2f5bd 100644 | ||
23 | --- a/examples/domain-events/events-c/Makefile.am | ||
24 | +++ b/examples/domain-events/events-c/Makefile.am | ||
25 | @@ -21,3 +21,9 @@ event_test_CFLAGS = $(WARN_CFLAGS) | ||
26 | event_test_SOURCES = event-test.c | ||
27 | event_test_LDADD = $(top_builddir)/src/libvirt.la \ | ||
28 | $(top_builddir)/gnulib/lib/libgnu.la | ||
29 | + | ||
30 | +if WITH_GNUTLS | ||
31 | +event_test_LDADD += ../../../src/libvirt-net-rpc.la \ | ||
32 | + ../../../gnulib/lib/libgnu.la | ||
33 | +endif | ||
34 | + | ||
35 | diff --git a/examples/dominfo/Makefile.am b/examples/dominfo/Makefile.am | 20 | diff --git a/examples/dominfo/Makefile.am b/examples/dominfo/Makefile.am |
36 | index 4a30c77..99b3e17 100644 | 21 | index 4a30c7768df9..99b3e17eb741 100644 |
37 | --- a/examples/dominfo/Makefile.am | 22 | --- a/examples/dominfo/Makefile.am |
38 | +++ b/examples/dominfo/Makefile.am | 23 | +++ b/examples/dominfo/Makefile.am |
39 | @@ -23,3 +23,10 @@ noinst_PROGRAMS=info1 | 24 | @@ -23,3 +23,10 @@ noinst_PROGRAMS=info1 |
@@ -48,10 +33,10 @@ index 4a30c77..99b3e17 100644 | |||
48 | +endif | 33 | +endif |
49 | + | 34 | + |
50 | diff --git a/examples/domsuspend/Makefile.am b/examples/domsuspend/Makefile.am | 35 | diff --git a/examples/domsuspend/Makefile.am b/examples/domsuspend/Makefile.am |
51 | index d0d9368..e368ffa 100644 | 36 | index b8e65f24a28d..9553e0f1d948 100644 |
52 | --- a/examples/domsuspend/Makefile.am | 37 | --- a/examples/domsuspend/Makefile.am |
53 | +++ b/examples/domsuspend/Makefile.am | 38 | +++ b/examples/domsuspend/Makefile.am |
54 | @@ -23,3 +23,10 @@ noinst_PROGRAMS=suspend | 39 | @@ -25,3 +25,10 @@ noinst_PROGRAMS=suspend |
55 | suspend_SOURCES=suspend.c | 40 | suspend_SOURCES=suspend.c |
56 | suspend_LDFLAGS= | 41 | suspend_LDFLAGS= |
57 | suspend_LDADD= $(LDADDS) | 42 | suspend_LDADD= $(LDADDS) |
@@ -63,7 +48,7 @@ index d0d9368..e368ffa 100644 | |||
63 | +endif | 48 | +endif |
64 | + | 49 | + |
65 | diff --git a/examples/hellolibvirt/Makefile.am b/examples/hellolibvirt/Makefile.am | 50 | diff --git a/examples/hellolibvirt/Makefile.am b/examples/hellolibvirt/Makefile.am |
66 | index 060cc71..d6ff30a 100644 | 51 | index 55ea972c42f8..a5272e2bb565 100644 |
67 | --- a/examples/hellolibvirt/Makefile.am | 52 | --- a/examples/hellolibvirt/Makefile.am |
68 | +++ b/examples/hellolibvirt/Makefile.am | 53 | +++ b/examples/hellolibvirt/Makefile.am |
69 | @@ -19,3 +19,10 @@ noinst_PROGRAMS = hellolibvirt | 54 | @@ -19,3 +19,10 @@ noinst_PROGRAMS = hellolibvirt |
@@ -78,7 +63,7 @@ index 060cc71..d6ff30a 100644 | |||
78 | +endif | 63 | +endif |
79 | + | 64 | + |
80 | diff --git a/examples/openauth/Makefile.am b/examples/openauth/Makefile.am | 65 | diff --git a/examples/openauth/Makefile.am b/examples/openauth/Makefile.am |
81 | index 1eb23fc..4d076f1 100644 | 66 | index 7bb860491e73..34e9b47f65cb 100644 |
82 | --- a/examples/openauth/Makefile.am | 67 | --- a/examples/openauth/Makefile.am |
83 | +++ b/examples/openauth/Makefile.am | 68 | +++ b/examples/openauth/Makefile.am |
84 | @@ -19,3 +19,9 @@ noinst_PROGRAMS = openauth | 69 | @@ -19,3 +19,9 @@ noinst_PROGRAMS = openauth |
@@ -92,10 +77,10 @@ index 1eb23fc..4d076f1 100644 | |||
92 | +endif | 77 | +endif |
93 | + | 78 | + |
94 | diff --git a/tools/Makefile.am b/tools/Makefile.am | 79 | diff --git a/tools/Makefile.am b/tools/Makefile.am |
95 | index 1dac7c1..c4c6f72 100644 | 80 | index 256a8f37a2a9..837a83fb612a 100644 |
96 | --- a/tools/Makefile.am | 81 | --- a/tools/Makefile.am |
97 | +++ b/tools/Makefile.am | 82 | +++ b/tools/Makefile.am |
98 | @@ -121,6 +121,13 @@ virt_host_validate_LDADD = \ | 83 | @@ -147,6 +147,13 @@ virt_host_validate_LDADD = \ |
99 | ../gnulib/lib/libgnu.la \ | 84 | ../gnulib/lib/libgnu.la \ |
100 | $(NULL) | 85 | $(NULL) |
101 | 86 | ||
@@ -109,7 +94,7 @@ index 1dac7c1..c4c6f72 100644 | |||
109 | virt_host_validate_CFLAGS = \ | 94 | virt_host_validate_CFLAGS = \ |
110 | $(WARN_CFLAGS) \ | 95 | $(WARN_CFLAGS) \ |
111 | $(PIE_CFLAGS) \ | 96 | $(PIE_CFLAGS) \ |
112 | @@ -162,6 +169,12 @@ virsh_CFLAGS = \ | 97 | @@ -214,6 +221,12 @@ virsh_CFLAGS = \ |
113 | $(READLINE_CFLAGS) | 98 | $(READLINE_CFLAGS) |
114 | BUILT_SOURCES = | 99 | BUILT_SOURCES = |
115 | 100 | ||
@@ -123,5 +108,5 @@ index 1dac7c1..c4c6f72 100644 | |||
123 | virsh_LDADD += virsh_win_icon.$(OBJEXT) | 108 | virsh_LDADD += virsh_win_icon.$(OBJEXT) |
124 | 109 | ||
125 | -- | 110 | -- |
126 | 1.7.10.4 | 111 | 1.8.1.2 |
127 | 112 | ||