summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-06-05 10:01:48 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-06-05 12:01:01 -0400
commit343b40ba0d44caeb22013a1586ae2159e415bd4c (patch)
tree3c5fdb72c38b060aeefccff3cd85091b5a5421c3 /recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch
parent1fd1ff3720140baa3680d795f6d97597e5113e90 (diff)
downloadmeta-virtualization-343b40ba0d44caeb22013a1586ae2159e415bd4c.tar.gz
libvirt: uprev to the latest release, v4.3.0
We have been using the 1.3.x release series for a long time now which has been great for stability but is slowly becoming harder and harder to track and port bug and CVE fixes. This is a big jump to the latest upstream release which gives us access to a myriad of fixes as well as puts us in a better position to contribute to the upstream project when issues are found. Several patches have been dropped as they are either no longer valid against this release or have equivalent updates already applied to the upstream project. Some patches were consolidated which should ease future uprevs of this recipe. The majority of the updates were related to ptest patches, which is not a huge surprise given this code has no upstream equivalent. The overall runtime behavior remains much the same from v1.3.5 with the only notable configuration change being for 'seccomp_sandbox' which has been disabled here but should possibly be revisited in the near future. As usual the normal runtime usecases for qemu/kvm and lxc have been run successfully along with ptest results which are by and large OK: ==================================== Testsuite summary for libvirt 4.3.0 ==================================== # TOTAL: 119 # PASS: 115 # SKIP: 0 # XFAIL: 0 # FAIL: 4 # XPASS: 0 # ERROR: 0 Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch')
-rw-r--r--recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch34
1 files changed, 18 insertions, 16 deletions
diff --git a/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch b/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch
index a7fc727b..5f6f9502 100644
--- a/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch
+++ b/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch
@@ -1,4 +1,4 @@
1From a790bfe8fa7b24b68cb6f9a1b7205fda2c6d558e Mon Sep 17 00:00:00 2001 1From f73c5c61c921bf773dcba5e4234e23afce5dbe7f Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com> 2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Fri, 2 Aug 2013 11:38:43 -0400 3Date: Fri, 2 Aug 2013 11:38:43 -0400
4Subject: [PATCH] tools: add libvirt-net-rpc to virt-host-validate when TLS is 4Subject: [PATCH] tools: add libvirt-net-rpc to virt-host-validate when TLS is
@@ -11,18 +11,20 @@ link against libvirt-net-rpc which provides the implementation.
11Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> 11Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
12[ywei: rebased to libvirt-1.3.2] 12[ywei: rebased to libvirt-1.3.2]
13Signed-off-by: Yunguo Wei <yunguo.wei@windriver.com> 13Signed-off-by: Yunguo Wei <yunguo.wei@windriver.com>
14[MA: rebase to v4.3.0]
15Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
14--- 16---
15 examples/Makefile.am | 19 +++++++++++++++++++ 17 examples/Makefile.am | 19 +++++++++++++++++++
16 tools/Makefile.am | 13 +++++++++++++ 18 tools/Makefile.am | 13 +++++++++++++
17 2 files changed, 32 insertions(+) 19 2 files changed, 32 insertions(+)
18 20
19diff --git a/examples/Makefile.am b/examples/Makefile.am 21diff --git a/examples/Makefile.am b/examples/Makefile.am
20index 2adcefb..fff49d4 100644 22index 7069d74..c8893e3 100644
21--- a/examples/Makefile.am 23--- a/examples/Makefile.am
22+++ b/examples/Makefile.am 24+++ b/examples/Makefile.am
23@@ -39,6 +39,10 @@ INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir) \ 25@@ -39,6 +39,10 @@ LDADD = $(STATIC_BINARIES) $(WARN_CFLAGS) $(COVERAGE_LDFLAGS) \
24 LDADD = $(STATIC_BINARIES) $(WARN_CFLAGS) $(COVERAGE_LDFLAGS) \ 26 $(top_builddir)/src/libvirt.la $(top_builddir)/gnulib/lib/libgnu.la \
25 $(top_builddir)/src/libvirt.la $(top_builddir)/gnulib/lib/libgnu.la 27 $(top_builddir)/src/libvirt-admin.la
26 28
27+if WITH_GNUTLS 29+if WITH_GNUTLS
28+LDADD += $(top_builddir)/src/libvirt-net-rpc.la 30+LDADD += $(top_builddir)/src/libvirt-net-rpc.la
@@ -30,10 +32,10 @@ index 2adcefb..fff49d4 100644
30+ 32+
31 noinst_PROGRAMS=dominfo/info1 dommigrate/dommigrate domsuspend/suspend \ 33 noinst_PROGRAMS=dominfo/info1 dommigrate/dommigrate domsuspend/suspend \
32 domtop/domtop hellolibvirt/hellolibvirt object-events/event-test \ 34 domtop/domtop hellolibvirt/hellolibvirt object-events/event-test \
33 openauth/openauth rename/rename 35 openauth/openauth rename/rename admin/list_servers admin/list_clients \
34@@ -52,6 +56,21 @@ object_events_event_test_SOURCES = object-events/event-test.c 36@@ -70,6 +74,21 @@ admin_logging_SOURCES = admin/logging.c
35 openauth_openauth_SOURCES = openauth/openauth.c 37 INSTALL_DATA_LOCAL =
36 rename_rename_SOURCES = rename/rename.c 38 UNINSTALL_LOCAL =
37 39
38+if WITH_GNUTLS 40+if WITH_GNUTLS
39+dominfo_info1_LDADD = $(top_builddir)/src/libvirt-net-rpc.la \ 41+dominfo_info1_LDADD = $(top_builddir)/src/libvirt-net-rpc.la \
@@ -54,11 +56,11 @@ index 2adcefb..fff49d4 100644
54 apparmordir = $(sysconfdir)/apparmor.d/ 56 apparmordir = $(sysconfdir)/apparmor.d/
55 apparmor_DATA = \ 57 apparmor_DATA = \
56diff --git a/tools/Makefile.am b/tools/Makefile.am 58diff --git a/tools/Makefile.am b/tools/Makefile.am
57index 0be3567..b3227a7 100644 59index 1452d98..204e772 100644
58--- a/tools/Makefile.am 60--- a/tools/Makefile.am
59+++ b/tools/Makefile.am 61+++ b/tools/Makefile.am
60@@ -169,6 +169,13 @@ virt_host_validate_LDADD = \ 62@@ -188,6 +188,13 @@ virt_host_validate_LDADD = \
61 ../gnulib/lib/libgnu.la \ 63 ../gnulib/lib/libgnu.la \
62 $(NULL) 64 $(NULL)
63 65
64+if WITH_GNUTLS 66+if WITH_GNUTLS
@@ -69,9 +71,9 @@ index 0be3567..b3227a7 100644
69+ 71+
70+ 72+
71 virt_host_validate_CFLAGS = \ 73 virt_host_validate_CFLAGS = \
72 $(LIBXML_CFLAGS) \ 74 $(AM_CFLAGS) \
73 $(WARN_CFLAGS) \ 75 $(NULL)
74@@ -256,6 +263,12 @@ virt_admin_CFLAGS = \ 76@@ -268,6 +275,12 @@ virt_admin_CFLAGS = \
75 $(READLINE_CFLAGS) 77 $(READLINE_CFLAGS)
76 BUILT_SOURCES = 78 BUILT_SOURCES =
77 79
@@ -85,5 +87,5 @@ index 0be3567..b3227a7 100644
85 virsh_LDADD += virsh_win_icon.$(OBJEXT) 87 virsh_LDADD += virsh_win_icon.$(OBJEXT)
86 88
87-- 89--
881.9.1 902.7.4
89 91