summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ipxe/ipxe_git.bb
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2019-02-20 16:52:03 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-02-21 03:15:23 +0000
commit4cbd6c2b467c1f4caa32b2f782072739ab373065 (patch)
treee5a1030c245f5af901ffb321523289e2ae8574b4 /recipes-extended/ipxe/ipxe_git.bb
parentaea2a3531a11beca9b7cb769b2f6ea6c699b06a6 (diff)
downloadmeta-virtualization-4cbd6c2b467c1f4caa32b2f782072739ab373065.tar.gz
ipxe: Uprev and fix host compiler and linker flags.
Adds patch to fix detection of the "no-pie" vs "nopie" flag, which needs to be performed for both the host and target compilers; cannot assume that one works for the other. Use EXTRA_HOST_CFLAGS and EXTRA_HOST_LDFLAGS variables for passing the host tool build parameters: BUILD_CFLAGS and BUILD_LDFLAGS. Drop unneeded 'NO_WERROR=1' from the recipe and rewrap line. Uprev commit to latest git revision. Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/ipxe/ipxe_git.bb')
-rw-r--r--recipes-extended/ipxe/ipxe_git.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/recipes-extended/ipxe/ipxe_git.bb b/recipes-extended/ipxe/ipxe_git.bb
index 18c92d2b..1de0f21e 100644
--- a/recipes-extended/ipxe/ipxe_git.bb
+++ b/recipes-extended/ipxe/ipxe_git.bb
@@ -4,15 +4,24 @@ LICENSE = "GPLv2"
4DEPENDS = "binutils-native perl-native syslinux mtools-native cdrtools-native xz" 4DEPENDS = "binutils-native perl-native syslinux mtools-native cdrtools-native xz"
5LIC_FILES_CHKSUM = "file://../COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263" 5LIC_FILES_CHKSUM = "file://../COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6 6
7SRCREV = "133f4c47baef6002b2ccb4904a035cda2303c6e5" 7SRCREV = "64b4452bca04af433f1c98ab782c0e93cd5c88c0"
8PV = "gitr${SRCPV}" 8PV = "gitr${SRCPV}"
9PR = "r0" 9PR = "r0"
10 10
11SRC_URI = "git://git.ipxe.org/ipxe.git;protocol=https" 11FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
12
13SRC_URI = " \
14 git://git.ipxe.org/ipxe.git;protocol=https \
15 file://ipxe-fix-hostcc-nopie-cflags.patch \
16 "
12 17
13FILES_${PN} = "/usr/share/firmware/*.rom" 18FILES_${PN} = "/usr/share/firmware/*.rom"
14 19
15EXTRA_OEMAKE = "NO_WERROR=1 ISOLINUX_BIN="${STAGING_DIR_TARGET}/usr/share/syslinux/isolinux.bin" CROSS_COMPILE="${TARGET_PREFIX}"" 20EXTRA_OEMAKE = " \
21 ISOLINUX_BIN="${STAGING_DIR_TARGET}/usr/share/syslinux/isolinux.bin" \
22 CROSS_COMPILE="${TARGET_PREFIX}" \
23 EXTRA_HOST_CFLAGS="${BUILD_CFLAGS}" \
24 EXTRA_HOST_LDFLAGS="${BUILD_LDFLAGS}""
16 25
17S = "${WORKDIR}/git/src" 26S = "${WORKDIR}/git/src"
18 27