summaryrefslogtreecommitdiffstats
path: root/recipes-extended/images/xen-image-minimal.bb
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2022-04-27 17:06:08 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-05-09 08:08:25 -0400
commit1c746a976830ebaf85c7c8c25612bea349b0a7c5 (patch)
tree1741629264022f4827da8db1a076a9c0dd927e4d /recipes-extended/images/xen-image-minimal.bb
parentda1e54ca79f49c9c311fe5f74e192e743c4ece20 (diff)
downloadmeta-virtualization-1c746a976830ebaf85c7c8c25612bea349b0a7c5.tar.gz
qemuboot, xen-image-minimal: enable runqemu for qemuarm Xen images
The Xen hypervisor built for Arm 32-bit targets can be launched with runqemu by providing a u-boot script and configuration for Qemu, which enables interactive testing of Xen images. Add qemuboot-xen-u-boot.bbclass to add a new bitbake task for generating the u-boot script. Since this increases the number of qemuboot-specific classes that are inherited by the xen-image-minimal recipe, change the inherit of all of these to only apply to qemu machines with the qemuall override. Update qemuboot-xen-defaults.bbclass to supply working default parameters for the qemuarm machine needed to boot successfully in testing. Also change all the arch-specific variable overrides into narrower qemu platform overrides instead to avoid unnecessary interactions with other Arm platform machines. Signed-off-by: Christopher Clark <christopher.clark@starlab.io> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/images/xen-image-minimal.bb')
-rw-r--r--recipes-extended/images/xen-image-minimal.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb
index 3cf42300..9b7f4150 100644
--- a/recipes-extended/images/xen-image-minimal.bb
+++ b/recipes-extended/images/xen-image-minimal.bb
@@ -34,7 +34,11 @@ XEN_ACPI_PROCESSOR_MODULE:x86-64 = "kernel-module-xen-acpi-processor"
34 34
35LICENSE = "MIT" 35LICENSE = "MIT"
36 36
37inherit core-image qemuboot-xen-defaults qemuboot-xen-dtb qemuboot-testimage-network 37inherit core-image
38# Only inherit the qemuboot classes when building for a qemu machine
39QB_QEMU_CLASSES = ""
40QB_QEMU_CLASSES:qemuall = "qemuboot-xen-defaults qemuboot-xen-dtb qemuboot-xen-u-boot qemuboot-testimage-network"
41inherit ${QB_QEMU_CLASSES}
38 42
39do_check_xen_state() { 43do_check_xen_state() {
40 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' yes', 'no', d)}" = "no" ]; then 44 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' yes', 'no', d)}" = "no" ]; then