summaryrefslogtreecommitdiffstats
path: root/recipes-extended/images/xen-guest-image-minimal.bb
diff options
context:
space:
mode:
authorChris Patterson <cjp256@gmail.com>2013-10-09 22:22:51 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-10 23:32:26 -0400
commit505c4a1c1c78403e31792007b5aa0e777074331f (patch)
tree59c7a236946fd9894ca06cc13d75bec0876a4f80 /recipes-extended/images/xen-guest-image-minimal.bb
parentac0499102746fbe8a25517b000ef791d2011e5ce (diff)
downloadmeta-virtualization-505c4a1c1c78403e31792007b5aa0e777074331f.tar.gz
xen-guest-image-minimal: add minimal xen guest image.
Signed-off-by: Chris Patterson <cjp256@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/images/xen-guest-image-minimal.bb')
-rw-r--r--recipes-extended/images/xen-guest-image-minimal.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-extended/images/xen-guest-image-minimal.bb b/recipes-extended/images/xen-guest-image-minimal.bb
new file mode 100644
index 00000000..bcac4d79
--- /dev/null
+++ b/recipes-extended/images/xen-guest-image-minimal.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "A Xen guest image."
2
3inherit core-image
4
5IMAGE_INSTALL += " \
6 packagegroup-core-boot \
7 kernel-module-xen-acpi-processor \
8 "
9
10IMAGE_INSTALL += "${@base_contains('DISTRO_FEATURES', 'x11', ' xf86-video-fbdev', '', d)}"
11IMAGE_INSTALL += "${@base_contains('DISTRO_FEATURES', 'x11', ' xf86-video-vesa', '', d)}"
12
13LICENSE = "MIT"
14
15# Send console messages to xen console
16APPEND += "console=hvc0"