summaryrefslogtreecommitdiffstats
path: root/recipes-extended/images/xen-guest-image-minimal.bb
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2017-09-17 18:21:38 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-09-19 09:22:55 -0400
commit33e8e20d3c52afbbaf3675383fedc20225f2c19b (patch)
tree12e928185ed2e581331261c4b318f6b84013140c /recipes-extended/images/xen-guest-image-minimal.bb
parent55b1cbe55dcd356e4d6b257ee1f58df9bb728665 (diff)
downloadmeta-virtualization-33e8e20d3c52afbbaf3675383fedc20225f2c19b.tar.gz
xen-guest-image-minimal: Fix non-x86. Select x11 via IMAGE_FEATURES.
Fix the image for non-x86, both with and without x11 included. * Only install xf86-video-vesa on x86 platforms as it is not available elsewhere. * In the absence of xf86-video-vesa (ie. on non-x86 platforms) enable opengl and remove wayland from IMAGE_INSTALL to satisfy build requirements for x11. * Use IMAGE_FEATURES instead of DISTRO_FEATURES to enable x11 inclusion in the image. * Verify the required DISTRO_FEATURE of 'xen' and if enabled, 'x11'. * When building the Xserver with Xen in DISTRO_FEATURES, on non-x86, turn off glamor by default, to remove dependency on egl. Introduces: xserver-xorg_%.bbappend Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/images/xen-guest-image-minimal.bb')
-rw-r--r--recipes-extended/images/xen-guest-image-minimal.bb16
1 files changed, 13 insertions, 3 deletions
diff --git a/recipes-extended/images/xen-guest-image-minimal.bb b/recipes-extended/images/xen-guest-image-minimal.bb
index ab7e92c3..bca60178 100644
--- a/recipes-extended/images/xen-guest-image-minimal.bb
+++ b/recipes-extended/images/xen-guest-image-minimal.bb
@@ -1,14 +1,24 @@
1DESCRIPTION = "A Xen guest image." 1DESCRIPTION = "A Xen guest image."
2 2
3inherit core-image 3inherit core-image distro_features_check
4 4
5IMAGE_INSTALL += " \ 5IMAGE_INSTALL += " \
6 packagegroup-core-boot \ 6 packagegroup-core-boot \
7 ${@bb.utils.contains('MACHINE_FEATURES', 'acpi', 'kernel-module-xen-acpi-processor', '', d)} \ 7 ${@bb.utils.contains('MACHINE_FEATURES', 'acpi', 'kernel-module-xen-acpi-processor', '', d)} \
8 " 8 "
9 9
10IMAGE_INSTALL += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' xf86-video-fbdev', '', d)}" 10IMAGE_INSTALL += "${@bb.utils.contains('IMAGE_FEATURES', 'x11', ' xf86-video-fbdev', '', d)}"
11IMAGE_INSTALL += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' xf86-video-vesa', '', d)}" 11
12# Install xf86-video-vesa on x86 platforms.
13IMAGE_INSTALL_append_x86-64 = "${@bb.utils.contains('IMAGE_FEATURES', 'x11', ' xf86-video-vesa', '', d)}"
14IMAGE_INSTALL_append_x86 = "${@bb.utils.contains('IMAGE_FEATURES', 'x11', ' xf86-video-vesa', '', d)}"
15
16# When xf86-video-vesa is not present, add opengl and don't require wayland:
17DISTRO_FEATURES_append = "${@bb.utils.contains('IMAGE_FEATURES', 'x11', \
18 bb.utils.contains('IMAGE_INSTALL', 'xf86-video-vesa', '', ' opengl', d), '', d)}"
19DISTRO_FEATURES_remove = "${@bb.utils.contains('IMAGE_INSTALL', 'xf86-video-vesa', '', 'wayland', d)}"
20
21REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('IMAGE_FEATURES', 'x11', ' x11', '', d)} xen"
12 22
13LICENSE = "MIT" 23LICENSE = "MIT"
14 24