summaryrefslogtreecommitdiffstats
path: root/recipes-extended/hyperstart/hyperstart_git.bb
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2018-06-15 08:19:23 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-06-19 12:29:33 -0400
commit646259f4d50bdfc0bd3d6ebd9c20bd8bd7251310 (patch)
tree04b0f2270000b954d77068e56b4086db96a30f17 /recipes-extended/hyperstart/hyperstart_git.bb
parent8af86bc72dc7313d8a81e0e8897efbd044575b15 (diff)
downloadmeta-virtualization-646259f4d50bdfc0bd3d6ebd9c20bd8bd7251310.tar.gz
hyperstart: Fix compiler errors from gcc 8.1.0 uprev
The patch to hypterstart was also submitted to the upstream project. It fixes these errors/warnings: container.c: In function 'hyper_setup_container_rootfs': container.c:630:24: error: '/' directive writing 1 byte into a region of size between 0 and 511 [-Werror=format-overflow=] sprintf(rootfs, "%s/%s/", root, container->rootfs); ^ container.c:630:2: note: 'sprintf' output 3 or more bytes (assuming 514) into a destination of size 512 sprintf(rootfs, "%s/%s/", root, container->rootfs); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ container.c:262:18: error: '%s' directive writing up to 511 bytes into a region of size 510 [-Werror=format-overflow=] sprintf(dst, "./%s", src); ^~ ~~~ container.c:262:2: note: 'sprintf' output between 3 and 514 bytes into a destination of size 512 sprintf(dst, "./%s", src); ^~~~~~~~~~~~~~~~~~~~~~~~~ container.c:218:24: error: '/_data' directive writing 6 bytes into a region of size between 1 and 512 [-Werror=format-overflow=] sprintf(volume, "%s/_data", path); ^~~~~~ container.c:218:5: note: 'sprintf' output between 7 and 518 bytes into a destination of size 512 sprintf(volume, "%s/_data", path); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ container.c:149:24: error: '/_data' directive writing 6 bytes into a region of size between 0 and 511 [-Werror=format-overflow=] sprintf(volume, "/%s/_data", path); ^~~~~~ container.c:149:4: note: 'sprintf' output between 8 and 519 bytes into a destination of size 512 sprintf(volume, "/%s/_data", path); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ container.c:131:24: error: '/' directive writing 1 byte into a region of size between 0 and 511 [-Werror=format-overflow=] sprintf(volume, "/%s/", path); ^ container.c:131:4: note: 'sprintf' output between 3 and 514 bytes into a destination of size 512 sprintf(volume, "/%s/", path); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~ container.c:176:24: error: '/_data/' directive writing 7 bytes into a region of size between 0 and 511 [-Werror=format-overflow=] sprintf(volume, "/%s/_data/%s", path, filevolume); ^~~~~~~ container.c:176:4: note: 'sprintf' output 9 or more bytes (assuming 520) into a destination of size 512 sprintf(volume, "/%s/_data/%s", path, filevolume); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/hyperstart/hyperstart_git.bb')
-rw-r--r--recipes-extended/hyperstart/hyperstart_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-extended/hyperstart/hyperstart_git.bb b/recipes-extended/hyperstart/hyperstart_git.bb
index 02974772..99c21952 100644
--- a/recipes-extended/hyperstart/hyperstart_git.bb
+++ b/recipes-extended/hyperstart/hyperstart_git.bb
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7inherit autotools-brokensep 7inherit autotools-brokensep
8 8
9SRC_URI = "git://github.com/hyperhq/hyperstart.git" 9SRC_URI = "git://github.com/hyperhq/hyperstart.git"
10SRC_URI += "file://0001-container.c-Fix-compiler-errors-that-gcc-8.1.0-repor.patch"
10 11
11SRCREV = "ad48a3230836f59ada163659cde151a37522068b" 12SRCREV = "ad48a3230836f59ada163659cde151a37522068b"
12PV = "v0.2+git${SRCREV}" 13PV = "v0.2+git${SRCREV}"