summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-05-22 21:46:55 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-05-25 11:39:13 -0400
commitd9189db0aa971fbd4a11608965f4bac534f0cd92 (patch)
treea9c97bfead2c0fdf80ec667f51eb37942310b4da /recipes-extended/ceph
parentfb0a7b97db4f419b82309f98a4944ae3330d1e2e (diff)
downloadmeta-virtualization-d9189db0aa971fbd4a11608965f4bac534f0cd92.tar.gz
ceph: fix gcc-12 compile failure
Add two patches to fix gcc-12 compile failure. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/ceph')
-rw-r--r--recipes-extended/ceph/ceph/0001-buffer.h-add-missing-header-file-due-to-gcc-upgrade.patch30
-rw-r--r--recipes-extended/ceph/ceph/0002-common-fix-FTBFS-due-to-dout-need_dynamic-on-GCC-12.patch42
-rw-r--r--recipes-extended/ceph/ceph_15.2.15.bb2
3 files changed, 74 insertions, 0 deletions
diff --git a/recipes-extended/ceph/ceph/0001-buffer.h-add-missing-header-file-due-to-gcc-upgrade.patch b/recipes-extended/ceph/ceph/0001-buffer.h-add-missing-header-file-due-to-gcc-upgrade.patch
new file mode 100644
index 00000000..70d3eb94
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0001-buffer.h-add-missing-header-file-due-to-gcc-upgrade.patch
@@ -0,0 +1,30 @@
1From 496465d9238109a93612e28682273e5bf576823b Mon Sep 17 00:00:00 2001
2From: Chen Qi <Qi.Chen@windriver.com>
3Date: Sun, 22 May 2022 19:40:59 -0700
4Subject: [PATCH 1/2] buffer.h: add missing header file due to gcc upgrade
5
6The header file <memory> have been changed to be no longer included by other
7heades, thus requiring explicit include. See https://gcc.gnu.org/gcc-12/porting_to.html
8
9Upstream-Status: Pending
10
11Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
12---
13 src/include/buffer.h | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/src/include/buffer.h b/src/include/buffer.h
17index 5c8b427d..88845ee6 100644
18--- a/src/include/buffer.h
19+++ b/src/include/buffer.h
20@@ -43,6 +43,7 @@
21 #include <list>
22 #include <vector>
23 #include <string>
24+#include <memory>
25 #if __cplusplus >= 201703L
26 #include <string_view>
27 #endif // __cplusplus >= 201703L
28--
292.36.0
30
diff --git a/recipes-extended/ceph/ceph/0002-common-fix-FTBFS-due-to-dout-need_dynamic-on-GCC-12.patch b/recipes-extended/ceph/ceph/0002-common-fix-FTBFS-due-to-dout-need_dynamic-on-GCC-12.patch
new file mode 100644
index 00000000..d119bf1b
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0002-common-fix-FTBFS-due-to-dout-need_dynamic-on-GCC-12.patch
@@ -0,0 +1,42 @@
1From 841806de212226921eeaeb3eea054bda8ccce616 Mon Sep 17 00:00:00 2001
2From: Radoslaw Zarzynski <rzarzyns@redhat.com>
3Date: Wed, 19 Jan 2022 15:24:11 +0000
4Subject: [PATCH 2/2] common: fix FTBFS due to dout & need_dynamic on GCC-12
5
6For details see:
7https://gist.github.com/rzarzynski/d6d2df6888923bef6a3e764f4856853f.
8
9Special thanks to Kaleb Keithley who reported the issue
10and tested the fix!
11
12Fixes: https://tracker.ceph.com/issues/53896
13Signed-off-by: Radoslaw Zarzynski <rzarzyns@redhat.com>
14
15Upstream-Status: Backport [963d756ded40f5adf2efef53893c917bec1845c1]
16Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
17---
18 src/common/dout.h | 5 +++--
19 1 file changed, 3 insertions(+), 2 deletions(-)
20
21diff --git a/src/common/dout.h b/src/common/dout.h
22index c7c08182..42f49915 100644
23--- a/src/common/dout.h
24+++ b/src/common/dout.h
25@@ -99,11 +99,12 @@ namespace ceph::dout {
26 template<typename T>
27 struct dynamic_marker_t {
28 T value;
29- operator T() const { return value; }
30+ // constexpr ctor isn't needed as it's an aggregate type
31+ constexpr operator T() const { return value; }
32 };
33
34 template<typename T>
35-dynamic_marker_t<T> need_dynamic(T&& t) {
36+constexpr dynamic_marker_t<T> need_dynamic(T&& t) {
37 return dynamic_marker_t<T>{ std::forward<T>(t) };
38 }
39
40--
412.36.0
42
diff --git a/recipes-extended/ceph/ceph_15.2.15.bb b/recipes-extended/ceph/ceph_15.2.15.bb
index 17dbcf35..0fb32b26 100644
--- a/recipes-extended/ceph/ceph_15.2.15.bb
+++ b/recipes-extended/ceph/ceph_15.2.15.bb
@@ -14,6 +14,8 @@ SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \
14 file://ceph.conf \ 14 file://ceph.conf \
15 file://0001-cmake-add-support-for-python3.10.patch \ 15 file://0001-cmake-add-support-for-python3.10.patch \
16 file://0001-SnappyCompressor.h-fix-snappy-compiler-error.patch \ 16 file://0001-SnappyCompressor.h-fix-snappy-compiler-error.patch \
17 file://0001-buffer.h-add-missing-header-file-due-to-gcc-upgrade.patch \
18 file://0002-common-fix-FTBFS-due-to-dout-need_dynamic-on-GCC-12.patch \
17" 19"
18 20
19SRC_URI[sha256sum] = "5dccdaff2ebe18d435b32bfc06f8b5f474bf6ac0432a6a07d144b7c56700d0bf" 21SRC_URI[sha256sum] = "5dccdaff2ebe18d435b32bfc06f8b5f474bf6ac0432a6a07d144b7c56700d0bf"