summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph
diff options
context:
space:
mode:
authorsakib.sajal@windriver.com <sakib.sajal@windriver.com>2020-04-07 14:04:48 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-04-08 23:06:09 -0400
commit40f79e8d17518285502425c537cd4e3e19c95ca7 (patch)
treec950c5a2288c7c251804f6b40941c8f222b78ed4 /recipes-extended/ceph
parent420479e0fc43bbc9545aeadfe6c612bf84d48f23 (diff)
downloadmeta-virtualization-40f79e8d17518285502425c537cd4e3e19c95ca7.tar.gz
ceph: uprev ceph from 14.2.7 to 15.2.0
ceph uprev to v15.2.0 Refreshed oe-specific patch: ceph/0001-ceph-fix-build-errors-for-cross-compile.patch Removed merged patches: ceph/0001-common-rgw-workaround-for-boost-1.72.patch ceph/0001-rgw-add-executor-type-for-basic_waitable_timers.patch ceph/0001-rgw-beast-handle_connection-takes-io_context.patch Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/ceph')
-rw-r--r--recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch41
-rw-r--r--recipes-extended/ceph/ceph/0001-common-rgw-workaround-for-boost-1.72.patch62
-rw-r--r--recipes-extended/ceph/ceph/0001-rgw-add-executor-type-for-basic_waitable_timers.patch58
-rw-r--r--recipes-extended/ceph/ceph/0001-rgw-beast-handle_connection-takes-io_context.patch67
-rw-r--r--recipes-extended/ceph/ceph_15.2.0.bb (renamed from recipes-extended/ceph/ceph_14.2.7.bb)15
5 files changed, 29 insertions, 214 deletions
diff --git a/recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch b/recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch
index 4f009f0f..4d54549f 100644
--- a/recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch
+++ b/recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch
@@ -1,4 +1,4 @@
1From 9b97824ad0da2c0d3dcc0cf41f4506aa7e458e9f Mon Sep 17 00:00:00 2001 1From 4712fe18405ffea31405308357a8e7fca358bcce Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com> 2From: Dengke Du <dengke.du@windriver.com>
3Date: Mon, 11 Mar 2019 09:14:09 +0800 3Date: Mon, 11 Mar 2019 09:14:09 +0800
4Subject: [PATCH] ceph: fix build errors for cross compile 4Subject: [PATCH] ceph: fix build errors for cross compile
@@ -13,6 +13,7 @@ Signed-off-by: Dengke Du <dengke.du@windriver.com>
13Adjust context for v14.2.3 13Adjust context for v14.2.3
14 14
15Signed-off-by: He Zhe <zhe.he@windriver.com> 15Signed-off-by: He Zhe <zhe.he@windriver.com>
16Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com>
16--- 17---
17 cmake/modules/Distutils.cmake | 25 +++++-------------------- 18 cmake/modules/Distutils.cmake | 25 +++++--------------------
18 cmake/modules/FindRocksDB.cmake | 4 ++-- 19 cmake/modules/FindRocksDB.cmake | 4 ++--
@@ -24,11 +25,11 @@ Signed-off-by: He Zhe <zhe.he@windriver.com>
24 7 files changed, 8 insertions(+), 55 deletions(-) 25 7 files changed, 8 insertions(+), 55 deletions(-)
25 26
26diff --git a/cmake/modules/Distutils.cmake b/cmake/modules/Distutils.cmake 27diff --git a/cmake/modules/Distutils.cmake b/cmake/modules/Distutils.cmake
27index f70265f..b2f4223 100644 28index 5fe929499d..802eb37e32 100644
28--- a/cmake/modules/Distutils.cmake 29--- a/cmake/modules/Distutils.cmake
29+++ b/cmake/modules/Distutils.cmake 30+++ b/cmake/modules/Distutils.cmake
30@@ -16,17 +16,8 @@ function(distutils_install_module name) 31@@ -18,17 +18,8 @@ function(distutils_install_module name)
31 cmake_parse_arguments(DU "" INSTALL_SCRIPT "" ${ARGN}) 32 cmake_parse_arguments(DU "" "INSTALL_SCRIPT" "" ${ARGN})
32 install(CODE " 33 install(CODE "
33 set(options --prefix=${CMAKE_INSTALL_PREFIX}) 34 set(options --prefix=${CMAKE_INSTALL_PREFIX})
34- if(DEFINED ENV{DESTDIR}) 35- if(DEFINED ENV{DESTDIR})
@@ -45,9 +46,9 @@ index f70265f..b2f4223 100644
45+ list(APPEND options --root=${CMAKE_DESTDIR}) 46+ list(APPEND options --root=${CMAKE_DESTDIR})
46+ list(APPEND options --install-lib=${PYTHON_SITEPACKAGES_DIR}) 47+ list(APPEND options --install-lib=${PYTHON_SITEPACKAGES_DIR})
47 execute_process( 48 execute_process(
48 COMMAND ${PYTHON${PYTHON_VERSION}_EXECUTABLE} 49 COMMAND ${Python3_EXECUTABLE}
49 setup.py install \${options} 50 setup.py install \${options}
50@@ -48,7 +39,7 @@ function(distutils_add_cython_module name src) 51@@ -50,7 +41,7 @@ function(distutils_add_cython_module target name src)
51 # Note: no quotes, otherwise distutils will execute "/usr/bin/ccache gcc" 52 # Note: no quotes, otherwise distutils will execute "/usr/bin/ccache gcc"
52 # CMake's implicit conversion between strings and lists is wonderful, isn't it? 53 # CMake's implicit conversion between strings and lists is wonderful, isn't it?
53 string(REPLACE " " ";" cflags ${CMAKE_C_FLAGS}) 54 string(REPLACE " " ";" cflags ${CMAKE_C_FLAGS})
@@ -56,7 +57,7 @@ index f70265f..b2f4223 100644
56 # This little bit of magic wipes out __Pyx_check_single_interpreter() 57 # This little bit of magic wipes out __Pyx_check_single_interpreter()
57 # Note: this is reproduced in distutils_install_cython_module 58 # Note: this is reproduced in distutils_install_cython_module
58 list(APPEND cflags -D'void0=dead_function\(void\)') 59 list(APPEND cflags -D'void0=dead_function\(void\)')
59@@ -89,14 +80,8 @@ function(distutils_install_cython_module name) 60@@ -108,14 +99,8 @@ function(distutils_install_cython_module name)
60 set(ENV{CEPH_LIBDIR} \"${CMAKE_LIBRARY_OUTPUT_DIRECTORY}\") 61 set(ENV{CEPH_LIBDIR} \"${CMAKE_LIBRARY_OUTPUT_DIRECTORY}\")
61 62
62 set(options --prefix=${CMAKE_INSTALL_PREFIX}) 63 set(options --prefix=${CMAKE_INSTALL_PREFIX})
@@ -72,9 +73,9 @@ index f70265f..b2f4223 100644
72+ list(APPEND options --install-lib=${PYTHON_SITEPACKAGES_DIR}) 73+ list(APPEND options --install-lib=${PYTHON_SITEPACKAGES_DIR})
73 execute_process( 74 execute_process(
74 COMMAND 75 COMMAND
75 ${PYTHON${PYTHON_VERSION}_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/setup.py 76 ${Python3_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/setup.py
76diff --git a/cmake/modules/FindRocksDB.cmake b/cmake/modules/FindRocksDB.cmake 77diff --git a/cmake/modules/FindRocksDB.cmake b/cmake/modules/FindRocksDB.cmake
77index c5dd3df..be38597 100644 78index c5dd3dfaf6..be38597af2 100644
78--- a/cmake/modules/FindRocksDB.cmake 79--- a/cmake/modules/FindRocksDB.cmake
79+++ b/cmake/modules/FindRocksDB.cmake 80+++ b/cmake/modules/FindRocksDB.cmake
80@@ -9,9 +9,9 @@ 81@@ -9,9 +9,9 @@
@@ -90,7 +91,7 @@ index c5dd3df..be38597 100644
90 if(ROCKSDB_INCLUDE_DIR AND EXISTS "${ROCKSDB_INCLUDE_DIR}/rocksdb/version.h") 91 if(ROCKSDB_INCLUDE_DIR AND EXISTS "${ROCKSDB_INCLUDE_DIR}/rocksdb/version.h")
91 foreach(ver "MAJOR" "MINOR" "PATCH") 92 foreach(ver "MAJOR" "MINOR" "PATCH")
92diff --git a/src/compressor/zstd/CMakeLists.txt b/src/compressor/zstd/CMakeLists.txt 93diff --git a/src/compressor/zstd/CMakeLists.txt b/src/compressor/zstd/CMakeLists.txt
93index 76709bb..95bba4a 100644 94index a5ebdaf538..a234068150 100644
94--- a/src/compressor/zstd/CMakeLists.txt 95--- a/src/compressor/zstd/CMakeLists.txt
95+++ b/src/compressor/zstd/CMakeLists.txt 96+++ b/src/compressor/zstd/CMakeLists.txt
96@@ -9,7 +9,7 @@ ExternalProject_Add(zstd_ext 97@@ -9,7 +9,7 @@ ExternalProject_Add(zstd_ext
@@ -100,13 +101,13 @@ index 76709bb..95bba4a 100644
100- -DCMAKE_AR=${CMAKE_AR} 101- -DCMAKE_AR=${CMAKE_AR}
101+ -DCMAKE_SYSROOT=${CMAKE_SYSROOT} 102+ -DCMAKE_SYSROOT=${CMAKE_SYSROOT}
102 -DCMAKE_POSITION_INDEPENDENT_CODE=${ENABLE_SHARED} 103 -DCMAKE_POSITION_INDEPENDENT_CODE=${ENABLE_SHARED}
104 -G${CMAKE_GENERATOR}
103 BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/libzstd 105 BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/libzstd
104 BUILD_COMMAND $(MAKE) libzstd_static
105diff --git a/src/pybind/cephfs/setup.py b/src/pybind/cephfs/setup.py 106diff --git a/src/pybind/cephfs/setup.py b/src/pybind/cephfs/setup.py
106index 1f95005..8a6d136 100755 107index 19ae6c329a..c9a25ccfff 100755
107--- a/src/pybind/cephfs/setup.py 108--- a/src/pybind/cephfs/setup.py
108+++ b/src/pybind/cephfs/setup.py 109+++ b/src/pybind/cephfs/setup.py
109@@ -142,14 +142,6 @@ def check_sanity(): 110@@ -135,14 +135,6 @@ def check_sanity():
110 finally: 111 finally:
111 shutil.rmtree(tmp_dir) 112 shutil.rmtree(tmp_dir)
112 113
@@ -122,10 +123,10 @@ index 1f95005..8a6d136 100755
122 try: 123 try:
123 from Cython.Build import cythonize 124 from Cython.Build import cythonize
124diff --git a/src/pybind/rados/setup.py b/src/pybind/rados/setup.py 125diff --git a/src/pybind/rados/setup.py b/src/pybind/rados/setup.py
125index 75081df..4d1591c 100755 126index e2c5696404..4e99d26721 100755
126--- a/src/pybind/rados/setup.py 127--- a/src/pybind/rados/setup.py
127+++ b/src/pybind/rados/setup.py 128+++ b/src/pybind/rados/setup.py
128@@ -138,14 +138,6 @@ def check_sanity(): 129@@ -134,14 +134,6 @@ def check_sanity():
129 finally: 130 finally:
130 shutil.rmtree(tmp_dir) 131 shutil.rmtree(tmp_dir)
131 132
@@ -141,10 +142,10 @@ index 75081df..4d1591c 100755
141 try: 142 try:
142 from Cython.Build import cythonize 143 from Cython.Build import cythonize
143diff --git a/src/pybind/rbd/setup.py b/src/pybind/rbd/setup.py 144diff --git a/src/pybind/rbd/setup.py b/src/pybind/rbd/setup.py
144index 8dd5c12..b8f4d91 100755 145index 634484f140..f5bbbdab4f 100755
145--- a/src/pybind/rbd/setup.py 146--- a/src/pybind/rbd/setup.py
146+++ b/src/pybind/rbd/setup.py 147+++ b/src/pybind/rbd/setup.py
147@@ -141,14 +141,6 @@ def check_sanity(): 148@@ -133,14 +133,6 @@ def check_sanity():
148 finally: 149 finally:
149 shutil.rmtree(tmp_dir) 150 shutil.rmtree(tmp_dir)
150 151
@@ -160,10 +161,10 @@ index 8dd5c12..b8f4d91 100755
160 try: 161 try:
161 from Cython.Build import cythonize 162 from Cython.Build import cythonize
162diff --git a/src/pybind/rgw/setup.py b/src/pybind/rgw/setup.py 163diff --git a/src/pybind/rgw/setup.py b/src/pybind/rgw/setup.py
163index 4ee4f49..91dc7d4 100755 164index eb1591a460..b9f2428cf9 100755
164--- a/src/pybind/rgw/setup.py 165--- a/src/pybind/rgw/setup.py
165+++ b/src/pybind/rgw/setup.py 166+++ b/src/pybind/rgw/setup.py
166@@ -143,14 +143,6 @@ def check_sanity(): 167@@ -134,14 +134,6 @@ def check_sanity():
167 finally: 168 finally:
168 shutil.rmtree(tmp_dir) 169 shutil.rmtree(tmp_dir)
169 170
@@ -179,5 +180,5 @@ index 4ee4f49..91dc7d4 100755
179 try: 180 try:
180 from Cython.Build import cythonize 181 from Cython.Build import cythonize
181-- 182--
1822.7.4 1832.20.1
183 184
diff --git a/recipes-extended/ceph/ceph/0001-common-rgw-workaround-for-boost-1.72.patch b/recipes-extended/ceph/ceph/0001-common-rgw-workaround-for-boost-1.72.patch
deleted file mode 100644
index 44bda1a2..00000000
--- a/recipes-extended/ceph/ceph/0001-common-rgw-workaround-for-boost-1.72.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From ea64c4909ffeae10e5d8e0a23604030e8849f803 Mon Sep 17 00:00:00 2001
2From: Kefu Chai <kchai@redhat.com>
3Date: Mon, 23 Dec 2019 16:26:13 +0800
4Subject: [PATCH] common,rgw: workaround for boost 1.72
5
6see also https://github.com/boostorg/coroutine/issues/46
7
8will need to remove this change once we require boost >= 1.73
9
10Signed-off-by: Kefu Chai <kchai@redhat.com>
11
12Upstream-Status: Backport [https://github.com/ceph/ceph/commit/ea64c4909ffeae10e5d8e0a23604030e8849f803]
13
14Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
15---
16 src/common/async/yield_context.h | 2 ++
17 src/rgw/rgw_asio_frontend.cc | 2 ++
18 src/test/librados/asio.cc | 2 ++
19 3 files changed, 6 insertions(+)
20
21diff --git a/src/common/async/yield_context.h b/src/common/async/yield_context.h
22index fda9541eb4..436192c02f 100644
23--- a/src/common/async/yield_context.h
24+++ b/src/common/async/yield_context.h
25@@ -14,6 +14,8 @@
26
27 #pragma once
28
29+#include <boost/range/begin.hpp>
30+#include <boost/range/end.hpp>
31 #include <boost/asio/io_context.hpp>
32
33 #include "acconfig.h"
34diff --git a/src/rgw/rgw_asio_frontend.cc b/src/rgw/rgw_asio_frontend.cc
35index 7df74225f6..deab1b0c66 100644
36--- a/src/rgw/rgw_asio_frontend.cc
37+++ b/src/rgw/rgw_asio_frontend.cc
38@@ -7,6 +7,8 @@
39
40 #include <boost/asio.hpp>
41 #define BOOST_COROUTINES_NO_DEPRECATION_WARNING
42+#include <boost/range/begin.hpp>
43+#include <boost/range/end.hpp>
44 #include <boost/asio/spawn.hpp>
45 #include <boost/intrusive/list.hpp>
46
47diff --git a/src/test/librados/asio.cc b/src/test/librados/asio.cc
48index 9c86ad420c..8fa4bab197 100644
49--- a/src/test/librados/asio.cc
50+++ b/src/test/librados/asio.cc
51@@ -21,6 +21,8 @@
52
53 #ifdef HAVE_BOOST_CONTEXT
54 #define BOOST_COROUTINES_NO_DEPRECATION_WARNING
55+#include <boost/range/begin.hpp>
56+#include <boost/range/end.hpp>
57 #include <boost/asio/spawn.hpp>
58 #endif
59 #include <boost/asio/use_future.hpp>
60--
612.17.1
62
diff --git a/recipes-extended/ceph/ceph/0001-rgw-add-executor-type-for-basic_waitable_timers.patch b/recipes-extended/ceph/ceph/0001-rgw-add-executor-type-for-basic_waitable_timers.patch
deleted file mode 100644
index b7a9dd96..00000000
--- a/recipes-extended/ceph/ceph/0001-rgw-add-executor-type-for-basic_waitable_timers.patch
+++ /dev/null
@@ -1,58 +0,0 @@
1From f1651b8c509d60787d10c4115e29fecfd2da237c Mon Sep 17 00:00:00 2001
2From: Casey Bodley <cbodley@redhat.com>
3Date: Tue, 23 Apr 2019 15:41:45 -0400
4Subject: [PATCH] rgw: add executor type for basic_waitable_timers
5
6as of boost 1.70, the timer no longer depends on io_context directly,
7so we have to specify its executor as a template parameter
8
9Signed-off-by: Casey Bodley <cbodley@redhat.com>
10
11Upstream-Status: Backport [f1651b8c509d60787d10c4115e29fecfd2da237c]
12
13Signed-off-by: He Zhe <zhe.he@windriver.com>
14---
15 src/rgw/rgw_dmclock_async_scheduler.h | 5 +++++
16 src/rgw/rgw_reshard.h | 9 ++++++++-
17 2 files changed, 13 insertions(+), 1 deletion(-)
18
19diff --git a/src/rgw/rgw_dmclock_async_scheduler.h b/src/rgw/rgw_dmclock_async_scheduler.h
20index 70487a5253..1d454acd2e 100644
21--- a/src/rgw/rgw_dmclock_async_scheduler.h
22+++ b/src/rgw/rgw_dmclock_async_scheduler.h
23@@ -82,7 +82,12 @@ class AsyncScheduler : public md_config_obs_t, public Scheduler {
24 using Completion = async::Completion<Signature, async::AsBase<Request>>;
25
26 using Clock = ceph::coarse_real_clock;
27+#if BOOST_VERSION < 107000
28 using Timer = boost::asio::basic_waitable_timer<Clock>;
29+#else
30+ using Timer = boost::asio::basic_waitable_timer<Clock,
31+ boost::asio::wait_traits<Clock>, executor_type>;
32+#endif
33 Timer timer; //< timer for the next scheduled request
34
35 CephContext *const cct;
36diff --git a/src/rgw/rgw_reshard.h b/src/rgw/rgw_reshard.h
37index d99a6ff68d..213fc238d2 100644
38--- a/src/rgw/rgw_reshard.h
39+++ b/src/rgw/rgw_reshard.h
40@@ -183,7 +183,14 @@ class RGWReshardWait {
41 ceph::condition_variable cond;
42
43 struct Waiter : boost::intrusive::list_base_hook<> {
44- boost::asio::basic_waitable_timer<Clock> timer;
45+#if BOOST_VERSION < 107000
46+ using Timer = boost::asio::basic_waitable_timer<Clock>;
47+#else
48+ using Executor = boost::asio::io_context::executor_type;
49+ using Timer = boost::asio::basic_waitable_timer<Clock,
50+ boost::asio::wait_traits<Clock>, Executor>;
51+#endif
52+ Timer timer;
53 explicit Waiter(boost::asio::io_context& ioc) : timer(ioc) {}
54 };
55 boost::intrusive::list<Waiter> waiters;
56--
572.21.0
58
diff --git a/recipes-extended/ceph/ceph/0001-rgw-beast-handle_connection-takes-io_context.patch b/recipes-extended/ceph/ceph/0001-rgw-beast-handle_connection-takes-io_context.patch
deleted file mode 100644
index d18e00a1..00000000
--- a/recipes-extended/ceph/ceph/0001-rgw-beast-handle_connection-takes-io_context.patch
+++ /dev/null
@@ -1,67 +0,0 @@
1Backport patch from upstream and update context to fix compile error:
2
3| /path/to/tmp-glibc/work/core2-64-wrs-linux/ceph/14.2.6-r0/ceph-14.2.6/src/rgw/rgw_asio_frontend.cc:165:38: error: 'class boost::asio::basic_socket<boost::asio::ip::tcp, boost::asio::executor>' has no member named 'get_io_context'
4| 165 | auto y = optional_yield{socket.get_io_context(), yield};
5| | ~~~~~~~^~~~~~~~~~~~~~
6
7Upstream-Status: Backport [https://github.com/ceph/ceph/commit/064f142]
8
9Signed-off-by: Kai Kang <kai.kang@windriver.com>
10
11From 064f142746ae97f54865069cdacf5aae2b1b14f6 Mon Sep 17 00:00:00 2001
12From: Casey Bodley <cbodley@redhat.com>
13Date: Tue, 23 Apr 2019 15:40:01 -0400
14Subject: [PATCH] rgw: beast handle_connection() takes io_context
15
16as of boost 1.70, the socket no longer has a get_io_context(), so we
17have to pass it in as an argument
18
19Signed-off-by: Casey Bodley <cbodley@redhat.com>
20---
21 src/rgw/rgw_asio_frontend.cc | 9 +++++----
22 1 file changed, 5 insertions(+), 4 deletions(-)
23
24diff --git a/src/rgw/rgw_asio_frontend.cc b/src/rgw/rgw_asio_frontend.cc
25index 0e1e09a..f7c13e1 100644
26--- a/src/rgw/rgw_asio_frontend.cc
27+++ b/src/rgw/rgw_asio_frontend.cc
28@@ -84,7 +84,8 @@ class StreamIO : public rgw::asio::ClientIO {
29 using SharedMutex = ceph::async::SharedMutex<boost::asio::io_context::executor_type>;
30
31 template <typename Stream>
32-void handle_connection(RGWProcessEnv& env, Stream& stream,
33+void handle_connection(boost::asio::io_context& context,
34+ RGWProcessEnv& env, Stream& stream,
35 parse_buffer& buffer, bool is_ssl,
36 SharedMutex& pause_mutex,
37 rgw::dmclock::Scheduler *scheduler,
38@@ -161,7 +162,7 @@ void handle_connection(RGWProcessEnv& env, Stream& stream,
39 rgw::io::add_conlen_controlling(
40 &real_client))));
41 RGWRestfulIO client(cct, &real_client_io);
42- auto y = optional_yield{socket.get_io_context(), yield};
43+ auto y = optional_yield{context, yield};
44 process_request(env.store, env.rest, &req, env.uri_prefix,
45 *env.auth_registry, &client, env.olog, y, scheduler);
46 }
47@@ -605,7 +606,7 @@ void AsioFrontend::accept(Listener& l, boost::system::error_code ec)
48 return;
49 }
50 buffer->consume(bytes);
51- handle_connection(env, stream, *buffer, true, pause_mutex,
52+ handle_connection(context, env, stream, *buffer, true, pause_mutex,
53 scheduler.get(), ec, yield);
54 if (!ec) {
55 // ssl shutdown (ignoring errors)
56@@ -623,7 +624,7 @@ void AsioFrontend::accept(Listener& l, boost::system::error_code ec)
57 auto c = connections.add(conn);
58 auto buffer = std::make_unique<parse_buffer>();
59 boost::system::error_code ec;
60- handle_connection(env, s, *buffer, false, pause_mutex,
61+ handle_connection(context, env, s, *buffer, false, pause_mutex,
62 scheduler.get(), ec, yield);
63 s.shutdown(tcp::socket::shutdown_both, ec);
64 });
65--
662.20.1
67
diff --git a/recipes-extended/ceph/ceph_14.2.7.bb b/recipes-extended/ceph/ceph_15.2.0.bb
index 18df8b4b..2b7b2c10 100644
--- a/recipes-extended/ceph/ceph_14.2.7.bb
+++ b/recipes-extended/ceph/ceph_15.2.0.bb
@@ -2,7 +2,7 @@ SUMMARY = "User space components of the Ceph file system"
2LICENSE = "LGPLv2.1 & GPLv2 & Apache-2.0 & MIT" 2LICENSE = "LGPLv2.1 & GPLv2 & Apache-2.0 & MIT"
3LIC_FILES_CHKSUM = "file://COPYING-LGPL2.1;md5=fbc093901857fcd118f065f900982c24 \ 3LIC_FILES_CHKSUM = "file://COPYING-LGPL2.1;md5=fbc093901857fcd118f065f900982c24 \
4 file://COPYING-GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 4 file://COPYING-GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://COPYING;md5=601c21a554d728c3038ca292b83b8af0 \ 5 file://COPYING;md5=4eb012c221c5fd4b760029a2981a6754 \
6" 6"
7inherit cmake python3native python3-dir systemd 7inherit cmake python3native python3-dir systemd
8# Disable python pybind support for ceph temporary, when corss compiling pybind, 8# Disable python pybind support for ceph temporary, when corss compiling pybind,
@@ -11,13 +11,13 @@ inherit cmake python3native python3-dir systemd
11SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \ 11SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \
12 file://0001-ceph-fix-build-errors-for-cross-compile.patch \ 12 file://0001-ceph-fix-build-errors-for-cross-compile.patch \
13 file://ceph.conf \ 13 file://ceph.conf \
14 file://0001-rgw-add-executor-type-for-basic_waitable_timers.patch \
15 file://0001-common-rgw-workaround-for-boost-1.72.patch \
16 file://0001-rgw-beast-handle_connection-takes-io_context.patch \
17" 14"
18 15
19SRC_URI[md5sum] = "8100ce9820714554e6d4717f6f0aa4da" 16SRC_URI[md5sum] = "1f9af648b4c6d19975aab2583ab99710"
20SRC_URI[sha256sum] = "9606dc80553bd97e138cd80b6bbbc117b6b26c66248e490a4e49fc0d4d853862" 17SRC_URI[sha256sum] = "4292c473d1714a6602c525d7582e4e03ec608f0a1cbc0dd338207e5c7068e0d3"
18SRC_URI[sha1sum] = "7158806ece1483fcccdf1172c20cc34d9401c543"
19SRC_URI[sha384sum] = "20e996dbf30d1e33a6d6aae36960190125ce263d306415bcec5d2b3032b8b8f730deeba3ca318576573127d08909404a"
20SRC_URI[sha512sum] = "07a3ff2ccf1a3abac652ff8c5f1611e7c628fcedcb280adc6cd49792b46fa50c7c29437dc57c2c4a6af708a6833abf8c1a386ef2142d30bd5e1f214ba7aec4f2"
21 21
22DEPENDS = "boost bzip2 curl expat gperf-native \ 22DEPENDS = "boost bzip2 curl expat gperf-native \
23 keyutils libaio libibverbs lz4 \ 23 keyutils libaio libibverbs lz4 \
@@ -60,7 +60,8 @@ EXTRA_OECMAKE = "-DWITH_MANPAGE=OFF \
60 -DWITH_RDMA=OFF \ 60 -DWITH_RDMA=OFF \
61 -DWITH_RADOSGW_AMQP_ENDPOINT=OFF \ 61 -DWITH_RADOSGW_AMQP_ENDPOINT=OFF \
62 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 \ 62 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 \
63 -DPYTHON_EXECUTABLE=${PYTHON} \ 63 -DPython3_EXECUTABLE=${PYTHON} \
64 -DWITH_RADOSGW_KAFKA_ENDPOINT=OFF \
64" 65"
65 66
66do_configure_prepend () { 67do_configure_prepend () {