summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph/ceph_15.2.12.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-07-28 14:22:43 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-08-02 17:17:53 -0400
commitd876cfc5bfafa516dee55d04b50b319a22165640 (patch)
treeea03c34f999bd85e440c85fc8e722df8666e2e68 /recipes-extended/ceph/ceph_15.2.12.bb
parent5fdf66c1e2ec0c6b08573bf0a6aa9f84d2fc4ae6 (diff)
downloadmeta-virtualization-d876cfc5bfafa516dee55d04b50b319a22165640.tar.gz
global: overrides syntax conversion
OEcore/bitbake are moving to use the clearer ":" as an overrides separator. This is pass one of updating the meta-virt recipes to use that syntax. This has only been minimally build/runtime tested, more changes will be required for missed overrides, or incorrect conversions Note: A recent bitbake is required: commit 75fad23fc06c008a03414a1fc288a8614c6af9ca Author: Richard Purdie <richard.purdie@linuxfoundation.org> Date: Sun Jul 18 12:59:15 2021 +0100 bitbake: data_smart/parse: Allow ':' characters in variable/function names It is becomming increasingly clear we need to find a way to show what is/is not an override in our syntax. We need to do this in a way which is clear to users, readable and in a way we can transition to. The most effective way I've found to this is to use the ":" charater to directly replace "_" where an override is being specified. This includes "append", "prepend" and "remove" which are effectively special override directives. This patch simply adds the character to the parser so bitbake accepts the value but maps it back to "_" internally so there is no behaviour change. This change is simple enough it could potentially be backported to older version of bitbake meaning layers using the new syntax/markup could work with older releases. Even if other no other changes are accepted at this time and we don't backport, it does set us on a path where at some point in future we could require a more explict syntax. I've tested this patch by converting oe-core/meta-yocto to the new syntax for overrides (9000+ changes) and then seeing that builds continue to work with this patch. (Bitbake rev: 0dbbb4547cb2570d2ce607e9a53459df3c0ac284) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/ceph/ceph_15.2.12.bb')
-rw-r--r--recipes-extended/ceph/ceph_15.2.12.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/recipes-extended/ceph/ceph_15.2.12.bb b/recipes-extended/ceph/ceph_15.2.12.bb
index 3c2e1c62..6636d7a4 100644
--- a/recipes-extended/ceph/ceph_15.2.12.bb
+++ b/recipes-extended/ceph/ceph_15.2.12.bb
@@ -29,7 +29,7 @@ DEPENDS = "boost bzip2 curl expat gperf-native \
29 python3 python3-cython-native rabbitmq-c rocksdb snappy udev \ 29 python3 python3-cython-native rabbitmq-c rocksdb snappy udev \
30 valgrind xfsprogs zlib \ 30 valgrind xfsprogs zlib \
31" 31"
32SYSTEMD_SERVICE_${PN} = " \ 32SYSTEMD_SERVICE:${PN} = " \
33 ceph-radosgw@.service \ 33 ceph-radosgw@.service \
34 ceph-radosgw.target \ 34 ceph-radosgw.target \
35 ceph-mon@.service \ 35 ceph-mon@.service \
@@ -72,13 +72,13 @@ EXTRA_OECMAKE = "-DWITH_MANPAGE=OFF \
72 72
73export STAGING_DIR_HOST 73export STAGING_DIR_HOST
74 74
75do_configure_prepend () { 75do_configure:prepend () {
76 echo "set( CMAKE_SYSROOT \"${RECIPE_SYSROOT}\" )" >> ${WORKDIR}/toolchain.cmake 76 echo "set( CMAKE_SYSROOT \"${RECIPE_SYSROOT}\" )" >> ${WORKDIR}/toolchain.cmake
77 echo "set( CMAKE_DESTDIR \"${D}\" )" >> ${WORKDIR}/toolchain.cmake 77 echo "set( CMAKE_DESTDIR \"${D}\" )" >> ${WORKDIR}/toolchain.cmake
78 echo "set( PYTHON_SITEPACKAGES_DIR \"${PYTHON_SITEPACKAGES_DIR}\" )" >> ${WORKDIR}/toolchain.cmake 78 echo "set( PYTHON_SITEPACKAGES_DIR \"${PYTHON_SITEPACKAGES_DIR}\" )" >> ${WORKDIR}/toolchain.cmake
79} 79}
80 80
81do_install_append () { 81do_install:append () {
82 sed -i -e 's:^#!/usr/bin/python$:&3:' \ 82 sed -i -e 's:^#!/usr/bin/python$:&3:' \
83 -e 's:${WORKDIR}.*python3:${bindir}/python3:' \ 83 -e 's:${WORKDIR}.*python3:${bindir}/python3:' \
84 ${D}${bindir}/ceph ${D}${bindir}/ceph-crash \ 84 ${D}${bindir}/ceph ${D}${bindir}/ceph-crash \
@@ -94,7 +94,7 @@ do_install_append () {
94 rm ${D}${systemd_unitdir}/system/ceph-fuse.target ${D}${systemd_unitdir}/system/ceph-fuse@.service 94 rm ${D}${systemd_unitdir}/system/ceph-fuse.target ${D}${systemd_unitdir}/system/ceph-fuse@.service
95} 95}
96 96
97do_install_append_class-target () { 97do_install:append:class-target () {
98 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 98 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
99 install -d ${D}${sysconfdir}/tmpfiles.d 99 install -d ${D}${sysconfdir}/tmpfiles.d
100 echo "d /var/lib/ceph/crash/posted 0755 root root - -" > ${D}${sysconfdir}/tmpfiles.d/ceph-placeholder.conf 100 echo "d /var/lib/ceph/crash/posted 0755 root root - -" > ${D}${sysconfdir}/tmpfiles.d/ceph-placeholder.conf
@@ -106,28 +106,28 @@ do_install_append_class-target () {
106 fi 106 fi
107} 107}
108 108
109pkg_postinst_${PN}() { 109pkg_postinst:${PN}() {
110 if [ -z "$D" ] && [ -e ${sysconfdir}/init.d/populate-volatile.sh ] ; then 110 if [ -z "$D" ] && [ -e ${sysconfdir}/init.d/populate-volatile.sh ] ; then
111 ${sysconfdir}/init.d/populate-volatile.sh update 111 ${sysconfdir}/init.d/populate-volatile.sh update
112 fi 112 fi
113} 113}
114 114
115FILES_${PN} += "\ 115FILES:${PN} += "\
116 ${libdir}/rados-classes/*.so.* \ 116 ${libdir}/rados-classes/*.so.* \
117 ${libdir}/ceph/compressor/*.so \ 117 ${libdir}/ceph/compressor/*.so \
118 ${libdir}/rados-classes/*.so \ 118 ${libdir}/rados-classes/*.so \
119 ${libdir}/ceph/*.so \ 119 ${libdir}/ceph/*.so \
120" 120"
121 121
122FILES_${PN} += " \ 122FILES:${PN} += " \
123 /etc/tmpfiles.d/ceph-placeholder.conf \ 123 /etc/tmpfiles.d/ceph-placeholder.conf \
124 /etc/default/volatiles/99_ceph-placeholder \ 124 /etc/default/volatiles/99_ceph-placeholder \
125" 125"
126 126
127FILES_${PN}-python = "\ 127FILES:${PN}-python = "\
128 ${PYTHON_SITEPACKAGES_DIR}/* \ 128 ${PYTHON_SITEPACKAGES_DIR}/* \
129" 129"
130RDEPENDS_${PN} += "\ 130RDEPENDS:${PN} += "\
131 python3-core \ 131 python3-core \
132 python3-misc \ 132 python3-misc \
133 python3-modules \ 133 python3-modules \
@@ -138,8 +138,8 @@ COMPATIBLE_HOST = "(x86_64).*"
138PACKAGES += " \ 138PACKAGES += " \
139 ${PN}-python \ 139 ${PN}-python \
140" 140"
141INSANE_SKIP_${PN}-python += "ldflags" 141INSANE_SKIP:${PN}-python += "ldflags"
142INSANE_SKIP_${PN} += "dev-so" 142INSANE_SKIP:${PN} += "dev-so"
143CCACHE_DISABLE = "1" 143CCACHE_DISABLE = "1"
144 144
145CVE_PRODUCT = "ceph ceph_storage ceph_storage_mon ceph_storage_osd" 145CVE_PRODUCT = "ceph ceph_storage ceph_storage_mon ceph_storage_osd"