summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 16:01:49 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 16:01:49 +0000
commitd10d310cbebe393a7aa8ee5c6816a256dd1a54b8 (patch)
tree6884e969c0c74d1274021fc84d434b55e4834dae /recipes-devtools
parent1d47e25958506b7c3b9e01ae6eff4c3e7ebda8cb (diff)
downloadmeta-virtualization-d10d310cbebe393a7aa8ee5c6816a256dd1a54b8.tar.gz
python: make DISTRO_FEATURE safe
The python bbappend should have only been active when virtualization is in DISTRO_FEATURES, so we change it to work like the rest of the bbappends. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python3_3.%.bbappend9
-rw-r--r--recipes-devtools/python/python3_virtualization.inc8
2 files changed, 9 insertions, 8 deletions
diff --git a/recipes-devtools/python/python3_3.%.bbappend b/recipes-devtools/python/python3_3.%.bbappend
index 55301c7e..617caccb 100644
--- a/recipes-devtools/python/python3_3.%.bbappend
+++ b/recipes-devtools/python/python3_3.%.bbappend
@@ -1,8 +1 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" require ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', '${BPN}_virtualization.inc', '', d)}
2
3DEPENDS += " ncurses"
4
5do_compile_prepend() {
6 export LIBRARY_PATH=${STAGING_DIR_TARGET}/lib
7}
8
diff --git a/recipes-devtools/python/python3_virtualization.inc b/recipes-devtools/python/python3_virtualization.inc
new file mode 100644
index 00000000..55301c7e
--- /dev/null
+++ b/recipes-devtools/python/python3_virtualization.inc
@@ -0,0 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3DEPENDS += " ncurses"
4
5do_compile_prepend() {
6 export LIBRARY_PATH=${STAGING_DIR_TARGET}/lib
7}
8