summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2016-09-06 11:33:20 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-09-07 16:06:51 -0400
commita3766e464d3ce0e7a57b61b2cca369d4429baa34 (patch)
treef48b6531e9d207326dae1d0eacf4ceca65081911 /recipes-devtools
parent548c88a90a003f96ed32dafb015db4c245f823aa (diff)
downloadmeta-virtualization-a3766e464d3ce0e7a57b61b2cca369d4429baa34.tar.gz
go-distribution-digest: Fix do_package failure
The rule in the recipe which deletes all but LICENSE and the digest directory is broken depending on what ascii table bash uses by default for matching, specifically: rm -rf ${S}/[A-KM-Za-ce-z]* ${S}/doc* The "A-K" piece will actually match both upper and lower case when the acsii because the ascii value is checked as being between two numbers: 0x41=a, 0x42=A,0x43=b...0x48=D This is contray to what you would typically think should work with the lower and uppers separated into two contiguous spaces. To fix this, instead of using the "rm" logic, we can copy the components we need instead. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/go/go-distribution-digest_git.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes-devtools/go/go-distribution-digest_git.bb b/recipes-devtools/go/go-distribution-digest_git.bb
index 31d724ce..2a803da5 100644
--- a/recipes-devtools/go/go-distribution-digest_git.bb
+++ b/recipes-devtools/go/go-distribution-digest_git.bb
@@ -13,15 +13,13 @@ SRCREV = "d957768537c5af40e4f4cd96871f7b2bde9e2923"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16do_unpackpost() { 16# NO-OP the do compile rule because this recipe is source only.
17 rm -rf ${S}/[A-KM-Za-ce-z]* ${S}/doc* 17do_compile() {
18} 18}
19 19
20addtask unpackpost after do_unpack before do_patch
21
22do_install() { 20do_install() {
23 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 21 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
24 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 22 cp -r ${S}/LICENSE ${S}/digest ${D}${prefix}/local/go/src/${PKG_NAME}/
25} 23}
26 24
27SYSROOT_PREPROCESS_FUNCS += "go_distribution_digeset_sysroot_preprocess" 25SYSROOT_PREPROCESS_FUNCS += "go_distribution_digeset_sysroot_preprocess"