summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 15:32:03 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 15:53:49 +0000
commit52e67d4e6307a161491825bdfca01dd36b2228e1 (patch)
treef4c2bea6dab8d9df21d41323f120aeb34bfaf96a /recipes-devtools
parentcceef93ba83497dcce2c1cdac91555d82371450a (diff)
downloadmeta-virtualization-52e67d4e6307a161491825bdfca01dd36b2228e1.tar.gz
python: update support packages to python3
Updating the python support packages to python3. Some packages are dropped in favour of variants that are in meta-python, some are updated and update to the new python3 name for others. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-boto_2.34.0.bb25
-rw-r--r--recipes-devtools/python/python-flask_0.10.1.bb20
-rw-r--r--recipes-devtools/python/python-gevent/gevent-allow-ssl-v2-or-v3-certificates.patch29
-rw-r--r--recipes-devtools/python/python-gevent/libev-conf.patch19
-rw-r--r--recipes-devtools/python/python-gevent_1.0.1.bb30
-rw-r--r--recipes-devtools/python/python-m2crypto/m2crypto-Fix-build-with-SWIG-3.0.5.patch158
-rw-r--r--recipes-devtools/python/python-m2crypto_0.22.3.bb63
-rw-r--r--recipes-devtools/python/python-redis_2.10.3.bb22
-rw-r--r--recipes-devtools/python/python-websocket-client_0.44.0.bb2
-rw-r--r--recipes-devtools/python/python-werkzeug_0.10.4.bb33
-rw-r--r--recipes-devtools/python/python3-boto3_1.11.7.bb22
-rw-r--r--recipes-devtools/python/python3-bugsnag_3.6.0.bb (renamed from recipes-devtools/python/python-bugsnag_2.0.2.bb)11
-rw-r--r--recipes-devtools/python/python3-flask-cors_3.0.8.bb (renamed from recipes-devtools/python/python-flask-cors_1.10.3.bb)13
-rw-r--r--recipes-devtools/python/python3-newrelic_5.4.1.134.bb (renamed from recipes-devtools/python/python-newrelic_2.22.0.19.bb)9
-rw-r--r--recipes-devtools/python/python3-webob_1.8.5.bb (renamed from recipes-devtools/python/python-webob_1.8.5.bb)4
15 files changed, 39 insertions, 421 deletions
diff --git a/recipes-devtools/python/python-boto_2.34.0.bb b/recipes-devtools/python/python-boto_2.34.0.bb
deleted file mode 100644
index f94f3244..00000000
--- a/recipes-devtools/python/python-boto_2.34.0.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1HOMEPAGE = "https://github.com/boto/boto"
2SUMMARY = "Amazon Web Services API"
3DESCRIPTION = "\
4 Boto is a Python package that provides interfaces to Amazon Web Services. \
5 Currently, all features work with Python 2.6 and 2.7. Work is under way to \
6 support Python 3.3+ in the same codebase. Modules are being ported one at \
7 a time with the help of the open source community, so please check below \
8 for compatibility with Python 3.3+. \
9 "
10SECTION = "devel/python"
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://setup.py;md5=182ef81236d3fac2c6ed8e8d3c988ec8"
13
14PR = "r0"
15SRCNAME = "boto"
16
17SRC_URI = "https://pypi.python.org/packages/source/b/boto/${SRCNAME}-${PV}.tar.gz"
18
19SRC_URI[md5sum] = "5556223d2d0cc4d06dd4829e671dcecd"
20SRC_URI[sha256sum] = "33baab022ecb803414ad0d6cf4041d010cfc2755ff8acc3bea7b32e77ba98be0"
21
22S = "${WORKDIR}/${SRCNAME}-${PV}"
23
24inherit setuptools
25
diff --git a/recipes-devtools/python/python-flask_0.10.1.bb b/recipes-devtools/python/python-flask_0.10.1.bb
deleted file mode 100644
index 263e53d0..00000000
--- a/recipes-devtools/python/python-flask_0.10.1.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1DESCRIPTION = "A microframework based on Werkzeug, Jinja2 and good intentions"
2HOMEPAGE = "https://pypi.python.org/pypi/Flask/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=79aa8b7bc4f781210d6b5c06d6424cb0"
6
7PR = "r0"
8SRCNAME = "Flask"
9
10SRC_URI = "https://pypi.python.org/packages/source/F/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "378670fe456957eb3c27ddaef60b2b24"
13SRC_URI[sha256sum] = "4c83829ff83d408b5e1d4995472265411d2c414112298f2eb4b359d9e4563373"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19CLEANBROKEN = "1"
20
diff --git a/recipes-devtools/python/python-gevent/gevent-allow-ssl-v2-or-v3-certificates.patch b/recipes-devtools/python/python-gevent/gevent-allow-ssl-v2-or-v3-certificates.patch
deleted file mode 100644
index 623d04f0..00000000
--- a/recipes-devtools/python/python-gevent/gevent-allow-ssl-v2-or-v3-certificates.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From c2dc97478fcc3757e09d5d2997391960a8351d53 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Sun, 29 Mar 2015 22:34:28 -0400
4Subject: [PATCH] gevent: allow ssl v2 or v3 certificates
5
6Work around an issue with python 2.7 not always having SSLv3 available
7by allowing v2 or v3 certificates.
8
9Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
10---
11 gevent/ssl.py | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/gevent/ssl.py b/gevent/ssl.py
15index ce6434718d1b..93c0d642da5f 100644
16--- a/gevent/ssl.py
17+++ b/gevent/ssl.py
18@@ -383,7 +383,7 @@ def wrap_socket(sock, keyfile=None, certfile=None,
19 ciphers=ciphers)
20
21
22-def get_server_certificate(addr, ssl_version=PROTOCOL_SSLv3, ca_certs=None):
23+def get_server_certificate(addr, ssl_version=PROTOCOL_SSLv23, ca_certs=None):
24 """Retrieve the certificate from the server at the specified address,
25 and return it as a PEM-encoded string.
26 If 'ca_certs' is specified, validate the server cert against it.
27--
281.9.1
29
diff --git a/recipes-devtools/python/python-gevent/libev-conf.patch b/recipes-devtools/python/python-gevent/libev-conf.patch
deleted file mode 100644
index 283705f8..00000000
--- a/recipes-devtools/python/python-gevent/libev-conf.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1Due to differences in library locations, the cross compile test can fail because it can't run
2the conftest binary (dynamically linked). Building it statically instead.
3
4Signed-off-by: Amy Fong <amy.fong@windriver.com>
5---
6 libev/configure | 2 +-
7 1 file changed, 1 insertion(+), 1 deletion(-)
8
9--- a/libev/configure
10+++ b/libev/configure
11@@ -2730,7 +2730,7 @@
12 ac_ext=c
13 ac_cpp='$CPP $CPPFLAGS'
14 ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
15-ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
16+ac_link='$CC -static -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
17 ac_compiler_gnu=$ac_cv_c_compiler_gnu
18 if test -n "$ac_tool_prefix"; then
19 # Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
diff --git a/recipes-devtools/python/python-gevent_1.0.1.bb b/recipes-devtools/python/python-gevent_1.0.1.bb
deleted file mode 100644
index 8cd1388a..00000000
--- a/recipes-devtools/python/python-gevent_1.0.1.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1HOMEPAGE = "http://www.gevent.org"
2SUMMARY = "A coroutine-based Python networking library"
3DESCRIPTION = "\
4 gevent is a coroutine-based Python networking library that uses greenlet \
5 to provide a high-level synchronous API on top of the libevent event \
6 loop. \
7 "
8SECTION = "devel/python"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=2dbb33d00e1fd31c7041460a81ac0bd2"
11DEPENDS += "python-greenlet libevent"
12RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re"
13
14SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6"
15SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43"
16
17inherit setuptools pypi
18
19FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
20SRC_URI += "file://libev-conf.patch"
21SRC_URI += "file://gevent-allow-ssl-v2-or-v3-certificates.patch"
22
23# The python-gevent has no autoreconf ability
24# and the logic for detecting a cross compile is flawed
25# so always force a cross compile
26do_configure_append() {
27 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/libev/configure
28}
29
30DEFAULT_PREFERENCE = "-1"
diff --git a/recipes-devtools/python/python-m2crypto/m2crypto-Fix-build-with-SWIG-3.0.5.patch b/recipes-devtools/python/python-m2crypto/m2crypto-Fix-build-with-SWIG-3.0.5.patch
deleted file mode 100644
index c4085952..00000000
--- a/recipes-devtools/python/python-m2crypto/m2crypto-Fix-build-with-SWIG-3.0.5.patch
+++ /dev/null
@@ -1,158 +0,0 @@
1From 8430e7202407fb1a0a104b0decdcc9da9e41a52b Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Mon, 4 Apr 2016 23:28:15 -0400
4Subject: [PATCH] Fix build with SWIG 3.0.5
5
6See analysis and previous patches in
7https://github.com/martinpaljak/M2Crypto/issues/60 and
8https://github.com/swig/swig/issues/344, in particular this adds the
9build machinery to patch
10https://github.com/martinpaljak/M2Crypto/issues/60#issuecomment-75735489
11
12Fixes #47
13
14Author: Miloslav Trmac <mitr@redhat.com>
15
16Upstream-Status: Backport
17
18Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
19---
20 M2Crypto/__init__.py | 4 ++--
21 M2Crypto/m2.py | 2 +-
22 SWIG/_lib.i | 4 ++++
23 SWIG/_pkcs7.i | 1 +
24 setup.py | 24 ++++++++++++++++++++++++
25 5 files changed, 32 insertions(+), 3 deletions(-)
26
27diff --git a/M2Crypto/__init__.py b/M2Crypto/__init__.py
28index 647e057..280af94 100644
29--- a/M2Crypto/__init__.py
30+++ b/M2Crypto/__init__.py
31@@ -19,7 +19,7 @@ Copyright 2008-2011 Heikki Toivonen. All rights reserved.
32 version_info = (0, 22)
33 version = '.'.join([str(_v) for _v in version_info])
34
35-import __m2crypto
36+import _m2crypto
37 import m2
38 import ASN1
39 import AuthCookie
40@@ -47,4 +47,4 @@ import m2xmlrpclib
41 import threading
42 import util
43
44-__m2crypto.lib_init()
45+_m2crypto.lib_init()
46diff --git a/M2Crypto/m2.py b/M2Crypto/m2.py
47index e4bb695..822143f 100644
48--- a/M2Crypto/m2.py
49+++ b/M2Crypto/m2.py
50@@ -25,7 +25,7 @@ Portions created by Open Source Applications Foundation (OSAF) are
51 Copyright (C) 2004 OSAF. All Rights Reserved.
52 """
53
54-from __m2crypto import *
55+from _m2crypto import *
56 lib_init()
57
58
59diff --git a/SWIG/_lib.i b/SWIG/_lib.i
60index 0d40698..6cc1a44 100644
61--- a/SWIG/_lib.i
62+++ b/SWIG/_lib.i
63@@ -66,6 +66,7 @@ int ssl_verify_callback(int ok, X509_STORE_CTX *ctx) {
64 int cret;
65 int new_style_callback = 0, warning_raised_exception=0;
66 PyGILState_STATE gilstate;
67+ PyObject *self = NULL; /* bug in SWIG_NewPointerObj as of 3.0.5 */
68
69 ssl = (SSL *)X509_STORE_CTX_get_app_data(ctx);
70
71@@ -151,6 +152,7 @@ int ssl_verify_callback(int ok, X509_STORE_CTX *ctx) {
72 void ssl_info_callback(const SSL *s, int where, int ret) {
73 PyObject *argv, *retval, *_SSL;
74 PyGILState_STATE gilstate;
75+ PyObject *self = NULL; /* bug in SWIG_NewPointerObj as of 3.0.5 */
76
77 gilstate = PyGILState_Ensure();
78
79@@ -170,6 +172,7 @@ DH *ssl_set_tmp_dh_callback(SSL *ssl, int is_export, int keylength) {
80 PyObject *argv, *ret, *_ssl;
81 DH *dh;
82 PyGILState_STATE gilstate;
83+ PyObject *self = NULL; /* bug in SWIG_NewPointerObj as of 3.0.5 */
84
85 gilstate = PyGILState_Ensure();
86
87@@ -193,6 +196,7 @@ RSA *ssl_set_tmp_rsa_callback(SSL *ssl, int is_export, int keylength) {
88 PyObject *argv, *ret, *_ssl;
89 RSA *rsa;
90 PyGILState_STATE gilstate;
91+ PyObject *self = NULL; /* bug in SWIG_NewPointerObj as of 3.0.5 */
92
93 gilstate = PyGILState_Ensure();
94
95diff --git a/SWIG/_pkcs7.i b/SWIG/_pkcs7.i
96index 22d791a..20dfbaf 100644
97--- a/SWIG/_pkcs7.i
98+++ b/SWIG/_pkcs7.i
99@@ -157,6 +157,7 @@ PyObject *smime_read_pkcs7(BIO *bio) {
100 BIO *bcont = NULL;
101 PKCS7 *p7;
102 PyObject *tuple, *_p7, *_BIO;
103+ PyObject *self = NULL; /* bug in SWIG_NewPointerObj as of 3.0.5 */
104
105 if (BIO_method_type(bio) == BIO_TYPE_MEM) {
106 /* OpenSSL FAQ explains that this is needed for mem BIO to return EOF,
107diff --git a/setup.py b/setup.py
108index bac6f9f..f59dc18 100644
109--- a/setup.py
110+++ b/setup.py
111@@ -19,6 +19,7 @@ from setuptools.command import build_ext
112
113 from distutils.core import Extension
114 from distutils.spawn import find_executable
115+from distutils.file_util import copy_file
116
117
118 class _M2CryptoBuildExt(build_ext.build_ext):
119@@ -77,6 +78,15 @@ class _M2CryptoBuildExt(build_ext.build_ext):
120 [opensslIncludeDir, os.path.join(opensslIncludeDir, "openssl")]]
121 self.swig_opts.append('-includeall')
122 self.swig_opts.append('-modern')
123+ self.swig_opts.append('-builtin')
124+
125+ # These two lines are a workaround for
126+ # http://bugs.python.org/issue2624 , hard-coding that we are only
127+ # building a single extension with a known path; a proper patch to
128+ # distutils would be in the run phase, when extension name and path are
129+ # known.
130+ self.swig_opts.append('-outdir')
131+ self.swig_opts.append(os.path.join(self.build_lib, 'M2Crypto'))
132
133 # Fedora does hat tricks.
134 if platform.linux_distribution()[0] in ['Fedora', 'CentOS']:
135@@ -98,6 +108,20 @@ class _M2CryptoBuildExt(build_ext.build_ext):
136
137 self.library_dirs += [os.path.join(self.openssl, opensslLibraryDir)]
138
139+ def run(self):
140+ '''Overloaded build_ext implementation to allow inplace=1 to work,
141+ which is needed for (python setup.py test).'''
142+ # This is another workaround for http://bugs.python.org/issue2624 + the
143+ # corresponding lack of support in setuptools' test command. Note that
144+ # just using self.inplace in finalize_options() above does not work
145+ # because swig is not rerun if the __m2crypto.so extension exists.
146+ # Again, hard-coding our extension name and location.
147+ build_ext.build_ext.run(self)
148+ if self.inplace:
149+ copy_file(os.path.join(self.build_lib, 'M2Crypto', '_m2crypto.py'),
150+ os.path.join('M2Crypto', '_m2crypto.py'),
151+ verbose=self.verbose, dry_run=self.dry_run)
152+
153 if sys.platform == 'darwin':
154 my_extra_compile_args = ["-Wno-deprecated-declarations"]
155 else:
156--
1571.9.1
158
diff --git a/recipes-devtools/python/python-m2crypto_0.22.3.bb b/recipes-devtools/python/python-m2crypto_0.22.3.bb
deleted file mode 100644
index e151dcc4..00000000
--- a/recipes-devtools/python/python-m2crypto_0.22.3.bb
+++ /dev/null
@@ -1,63 +0,0 @@
1HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
2SUMMARY = "A Python crypto and SSL toolkit"
3DESCRIPTION = "\
4 M2Crypto is the most complete Python wrapper for OpenSSL featuring RSA, \
5 DSA, DH, EC, HMACs, message digests, symmetric ciphers (including \
6 AES); SSL functionality to implement clients and servers; HTTPS \
7 extensions to Python's httplib, urllib, and xmlrpclib; unforgeable \
8 HMAC'ing AuthCookies for web session management; FTP/TLS client and \
9 server; S/MIME; ZServerSSL: A HTTPS server for Zope and ZSmime: An \
10 S/MIME messenger for Zope. M2Crypto can also be used to provide SSL \
11 for Twisted. \
12 "
13LICENSE = "BSD"
14LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0ccca7097c1d29fa42e75e9c15c6ff2e"
15
16PYPI_PACKAGE = "M2Crypto"
17
18SRC_URI += " \
19 file://m2crypto-Fix-build-with-SWIG-3.0.5.patch \
20"
21
22SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd"
23SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72"
24
25DEFAULT_PREFERENCE = "-1"
26
27inherit setuptools pypi
28
29DEPENDS += "openssl swig-native"
30
31DISTUTILS_BUILD_ARGS += "build_ext -I${STAGING_INCDIR}"
32
33inherit setuptools pypi
34
35SWIG_FEATURES_x86-64 = "-D__x86_64__"
36SWIG_FEATURES ?= ""
37export SWIG_FEATURES
38
39# Get around a problem with swig, but only if the
40# multilib header file exists.
41#
42do_compile_prepend() {
43 sed -i -e 's/self.add_multiarch_paths.*$/# &/;' ${S}/setup.py
44 sed -i -e 's/opensslIncludeDir = .*$/opensslIncludeDir = os.getenv("STAGING_INCDIR")/;' ${S}/setup.py
45 sed -i -e 's/opensslLibraryDir = .*$/opensslLibraryDir = os.getenv("STAGING_LIBDIR")/;' ${S}/setup.py
46
47 if [ "${SITEINFO_BITS}" = "64" ];then
48 bit="64"
49 else
50 bit="32"
51 fi
52
53 if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ]; then
54 for i in SWIG/_ec.i SWIG/_evp.i; do
55 sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
56 done
57 elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
58 for i in SWIG/_ec.i SWIG/_evp.i; do
59 sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
60 done
61 fi
62}
63
diff --git a/recipes-devtools/python/python-redis_2.10.3.bb b/recipes-devtools/python/python-redis_2.10.3.bb
deleted file mode 100644
index 2ef2b6b7..00000000
--- a/recipes-devtools/python/python-redis_2.10.3.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1HOMEPAGE = "https://pypi.python.org/pypi/redis/"
2SUMMARY = "Python client for Redis key-value store"
3DESCRIPTION = "The Python interface to the Redis key-value store."
4SECTION = "devel/python"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=51d9ad56299ab60ba7be65a621004f27"
7
8PR = "r0"
9SRCNAME = "redis"
10
11SRC_URI = "https://pypi.python.org/packages/source/r/redis/${SRCNAME}-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "7619221ad0cbd124a5687458ea3f5289"
14SRC_URI[sha256sum] = "a4fb37b02860f6b1617f6469487471fd086dd2d38bbce640c2055862b9c4019c"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18DEFAULT_PREFERENCE = "-1"
19
20inherit setuptools
21
22RDEPENDS_${PN} = "redis"
diff --git a/recipes-devtools/python/python-websocket-client_0.44.0.bb b/recipes-devtools/python/python-websocket-client_0.44.0.bb
deleted file mode 100644
index 11eeb04a..00000000
--- a/recipes-devtools/python/python-websocket-client_0.44.0.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require python-websocket-client.inc
2inherit setuptools \ No newline at end of file
diff --git a/recipes-devtools/python/python-werkzeug_0.10.4.bb b/recipes-devtools/python/python-werkzeug_0.10.4.bb
deleted file mode 100644
index 5f3e01fd..00000000
--- a/recipes-devtools/python/python-werkzeug_0.10.4.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1DESCRIPTION = "The Swiss Army knife of Python web development"
2HOMEPAGE = "https://pypi.python.org/pypi/Werkzeug/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a68f5361a2b2ca9fdf26b38aaecb6faa"
6
7PR = "r0"
8SRCNAME = "Werkzeug"
9
10SRC_URI = "https://pypi.python.org/packages/source/W/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "66a488e0ac50a9ec326fe020b3083450"
13SRC_URI[sha256sum] = "9d2771e4c89be127bc4bac056ab7ceaf0e0064c723d6b6e195739c3af4fd5c1d"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17DEFAULT_PREFERENCE = "-1"
18
19inherit setuptools
20
21RDEPENDS_${PN} += "python-io \
22 python-datetime \
23 python-email \
24 python-zlib \
25 python-pkgutil \
26 python-html \
27 python-shell \
28 python-pprint \
29 python-subprocess \
30 python-netserver"
31
32CLEANBROKEN = "1"
33
diff --git a/recipes-devtools/python/python3-boto3_1.11.7.bb b/recipes-devtools/python/python3-boto3_1.11.7.bb
new file mode 100644
index 00000000..ae623cf1
--- /dev/null
+++ b/recipes-devtools/python/python3-boto3_1.11.7.bb
@@ -0,0 +1,22 @@
1HOMEPAGE = "https://github.com/boto/boto"
2SUMMARY = "Amazon Web Services API"
3DESCRIPTION = "\
4 Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK) for Python, \
5 which allows Python developers to write software that makes use of services like \
6 Amazon S3 and Amazon EC2. \
7 "
8SECTION = "devel/python"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://setup.py;md5=0149f3d994965905689bbefa0212efe2"
11
12SRCNAME = "boto3"
13
14SRC_URI = "https://pypi.python.org/packages/source/b/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "79936a15612b8ef762eb1274a936cea5"
17SRC_URI[sha256sum] = "5222edc5b20d5c6ab7440fc4f89f987ead05be37ff5cc5359a3b9148d9b5a51e"
18
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21inherit setuptools3
22
diff --git a/recipes-devtools/python/python-bugsnag_2.0.2.bb b/recipes-devtools/python/python3-bugsnag_3.6.0.bb
index edf880fb..ef704e70 100644
--- a/recipes-devtools/python/python-bugsnag_2.0.2.bb
+++ b/recipes-devtools/python/python3-bugsnag_3.6.0.bb
@@ -8,19 +8,18 @@ DESCRIPTION = "\
8 " 8 "
9SECTION = "devel/python" 9SECTION = "devel/python"
10LICENSE = "MIT" 10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://PKG-INFO;md5=f6df6ab9f1b615a140ebb2a48f61bddc" 11LIC_FILES_CHKSUM = "file://PKG-INFO;md5=9577253c24027f0c6027a4fded2134fc"
12 12
13PR = "r0"
14SRCNAME = "bugsnag" 13SRCNAME = "bugsnag"
15 14
16SRC_URI = "https://pypi.python.org/packages/source/b/bugsnag/${SRCNAME}-${PV}.tar.gz" 15SRC_URI = "https://pypi.python.org/packages/source/b/bugsnag/${SRCNAME}-${PV}.tar.gz"
17 16
18SRC_URI[md5sum] = "e16360d86979890892cd388635f213e7" 17SRC_URI[md5sum] = "b97e16b068b5e7fdc3e3fa9f684e56cd"
19SRC_URI[sha256sum] = "093934b3cd1d36ba2b89cfe1673b14ba59043417fe500a02dbf6de0df43ea962" 18SRC_URI[sha256sum] = "67b8c01719e92f193f8424595a94e3a527bc0f9fcb7f2bc47a20af87de81929d"
20 19
21S = "${WORKDIR}/${SRCNAME}-${PV}" 20S = "${WORKDIR}/${SRCNAME}-${PV}"
22 21
23inherit setuptools 22inherit setuptools3
24 23
25DEPENDS += "python-webob python-flask python-blinker" 24DEPENDS += "python3-webob python3-flask python3-blinker"
26 25
diff --git a/recipes-devtools/python/python-flask-cors_1.10.3.bb b/recipes-devtools/python/python3-flask-cors_3.0.8.bb
index c39e9b26..5d3c41f7 100644
--- a/recipes-devtools/python/python-flask-cors_1.10.3.bb
+++ b/recipes-devtools/python/python3-flask-cors_3.0.8.bb
@@ -1,22 +1,21 @@
1HOMEPAGE = "https://pypi.python.org/pypi/Flask-Cors/1.10.3" 1HOMEPAGE = "https://pypi.python.org/pypi/Flask-Cors/"
2SUMMARY = "A Flask extension adding a decorator for CORS support" 2SUMMARY = "A Flask extension adding a decorator for CORS support"
3DESCRIPTION = "\ 3DESCRIPTION = "\
4 A Flask extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible \ 4 A Flask extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible \
5 " 5 "
6SECTION = "devel/python" 6SECTION = "devel/python"
7LICENSE = "MIT" 7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=4784781a5ee9fed9c50272e733e07685" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=118fecaa576ab51c1520f95e98db61ce"
9 9
10DEPENDS += "python-six python-flask" 10DEPENDS += "python3-six python3-flask"
11 11
12PR = "r0"
13SRCNAME = "Flask-Cors" 12SRCNAME = "Flask-Cors"
14 13
15SRC_URI = "https://pypi.python.org/packages/source/F/Flask-Cors/${SRCNAME}-${PV}.tar.gz" 14SRC_URI = "https://pypi.python.org/packages/source/F/Flask-Cors/${SRCNAME}-${PV}.tar.gz"
16 15
17SRC_URI[md5sum] = "4f3c75ace0f724d1de167bd73745c965" 16SRC_URI[md5sum] = "551cc4c0305a171d28caa2b3bc838867"
18SRC_URI[sha256sum] = "9e6927aa0a46f314bca0ec63eb871cee898a162adfdd5b65224db7a008287423" 17SRC_URI[sha256sum] = "72170423eb4612f0847318afff8c247b38bd516b7737adfc10d1c2cdbb382d16"
19 18
20S = "${WORKDIR}/${SRCNAME}-${PV}" 19S = "${WORKDIR}/${SRCNAME}-${PV}"
21 20
22inherit setuptools 21inherit setuptools3
diff --git a/recipes-devtools/python/python-newrelic_2.22.0.19.bb b/recipes-devtools/python/python3-newrelic_5.4.1.134.bb
index 38918249..36eec67a 100644
--- a/recipes-devtools/python/python-newrelic_2.22.0.19.bb
+++ b/recipes-devtools/python/python3-newrelic_5.4.1.134.bb
@@ -6,19 +6,18 @@ DESCRIPTION = "\
6 " 6 "
7SECTION = "devel/python" 7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause & MIT & Python-2.0 & BSD-2-Clause & NewRelic" 8LICENSE = "BSD-3-Clause & MIT & Python-2.0 & BSD-2-Clause & NewRelic"
9LIC_FILES_CHKSUM = "file://newrelic/LICENSE;md5=0f6cc160a8ed6759faa408a30b6ac978" 9LIC_FILES_CHKSUM = "file://newrelic/LICENSE;md5=2c3b4d48a631fe909df7a767726d4f6c"
10 10
11PR = "r0"
12SRCNAME = "newrelic" 11SRCNAME = "newrelic"
13 12
14SRC_URI = "https://pypi.python.org/packages/source/n/newrelic/${SRCNAME}-${PV}.tar.gz" 13SRC_URI = "https://pypi.python.org/packages/source/n/newrelic/${SRCNAME}-${PV}.tar.gz"
15 14
16SRC_URI[md5sum] = "f8c9bf996d040a11847d14682b290eff" 15SRC_URI[md5sum] = "45099c6d88dcf474267226469caa845e"
17SRC_URI[sha256sum] = "aa8869413c21aff441a77582df1e0fdc0f67342760eb7560d33ed3bbed7edf7b" 16SRC_URI[sha256sum] = "0e651f2ff48dd1fc538fc1297892cf726d1ad4fc0b2578aae6a47f10f16afb2c"
18 17
19S = "${WORKDIR}/${SRCNAME}-${PV}" 18S = "${WORKDIR}/${SRCNAME}-${PV}"
20 19
21inherit setuptools 20inherit setuptools3
22 21
23FILES_${PN}-dbg += "\ 22FILES_${PN}-dbg += "\
24 ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/*/.debug \ 23 ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/*/.debug \
diff --git a/recipes-devtools/python/python-webob_1.8.5.bb b/recipes-devtools/python/python3-webob_1.8.5.bb
index b9f8a9fd..74a36e39 100644
--- a/recipes-devtools/python/python-webob_1.8.5.bb
+++ b/recipes-devtools/python/python3-webob_1.8.5.bb
@@ -9,9 +9,9 @@ PYPI_PACKAGE = "WebOb"
9SRC_URI[md5sum] = "1761f416e8cf53f6fb674149cc223bd1" 9SRC_URI[md5sum] = "1761f416e8cf53f6fb674149cc223bd1"
10SRC_URI[sha256sum] = "05aaab7975e0ee8af2026325d656e5ce14a71f1883c52276181821d6d5bf7086" 10SRC_URI[sha256sum] = "05aaab7975e0ee8af2026325d656e5ce14a71f1883c52276181821d6d5bf7086"
11 11
12inherit setuptools pypi 12inherit setuptools3 pypi
13 13
14RDEPENDS_${PN} += " \ 14RDEPENDS_${PN} += " \
15 python-sphinx \ 15 python3-sphinx \
16 " 16 "
17 17