summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-09-16 11:00:11 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-09-16 11:00:11 -0400
commit3373301f78b1765e65c0c955fc7e8107cb0885aa (patch)
treeb9b7fe067169792d21373e390afc26874c72db27 /recipes-devtools
parentd9af46db9aa9060c1ec10118b2cccabfc8264904 (diff)
downloadmeta-virtualization-3373301f78b1765e65c0c955fc7e8107cb0885aa.tar.gz
devtools: introduce udica
udica provides an (easier) way to generate selnux policies for containers. since we already have selinux has a dependency of meta-virt, we might as well make policy creation easier. See https://github.com/containers/udica, for details on how to use the tool. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python3-udica_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-udica_git.bb b/recipes-devtools/python/python3-udica_git.bb
new file mode 100644
index 00000000..7f86374e
--- /dev/null
+++ b/recipes-devtools/python/python3-udica_git.bb
@@ -0,0 +1,20 @@
1SUMMARY = "A tool for generating SELinux security policies for containers"
2HOMEPAGE = "https://github.com/containers/udica"
3LICENSE = "GPL-3.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
5
6SRC_URI = "git://github.com/containers/udica;protocol=https;branch=main"
7
8SRCREV = "4a64ff7c1b8116a1894e72eee2a19706e970001f"
9PV = "0.2.7+git${SRCPV}"
10
11S = "${WORKDIR}/git"
12
13SRC_URI[md5sum] = "9cc5156a2ff6458a8f52114b9bbc0d7e"
14SRC_URI[sha256sum] = "3e8bc47534e0ca9331d72c32f2881bb13b93ded0bcdeab3c833fb7cf61c0a9a5"
15
16RDEPENDS:${PN} += " \
17 selinux-python \
18 "
19
20inherit setuptools3