summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-11-02 09:24:33 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-11-02 09:57:03 -0400
commit0a7ae8bc50208a7409198a8e92c4ce4afb2b5ed3 (patch)
tree6be7cbdc43382e52b80e2508d16d663cb39981ad /recipes-devtools
parentac399ad09105dce73bccde9574216377613a98de (diff)
downloadmeta-virtualization-0a7ae8bc50208a7409198a8e92c4ce4afb2b5ed3.tar.gz
global: convert github SRC_URIs to use https protocol
github is removing git:// access, and fetches will start experiencing interruptions in service, and eventually will fail completely. bitbake will also begin to warn on github src_uri's that don't use https. So we convert the meta-virt instances to use protocol=https (done using the oe-core contrib conversion script) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/go/go-build_git.bb2
-rw-r--r--recipes-devtools/go/grpc-go_git.bb2
-rw-r--r--recipes-devtools/yq/yq_git.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/recipes-devtools/go/go-build_git.bb b/recipes-devtools/go/go-build_git.bb
index ff675c4f..831b3c0d 100644
--- a/recipes-devtools/go/go-build_git.bb
+++ b/recipes-devtools/go/go-build_git.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "Xen Runtime for OCI"
5SRCREV_runx = "f24efd33fb18469e9cfe4d1bfe8e2c90ec8c4e93" 5SRCREV_runx = "f24efd33fb18469e9cfe4d1bfe8e2c90ec8c4e93"
6 6
7SRC_URI = "\ 7SRC_URI = "\
8 git://github.com/lf-edge/runx;nobranch=1;name=runx \ 8 git://github.com/lf-edge/runx;nobranch=1;name=runx;protocol=https \
9 file://0001-build-use-instead-of-go.patch \ 9 file://0001-build-use-instead-of-go.patch \
10 " 10 "
11SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b" 11SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b"
diff --git a/recipes-devtools/go/grpc-go_git.bb b/recipes-devtools/go/grpc-go_git.bb
index 188ad71c..b516e216 100644
--- a/recipes-devtools/go/grpc-go_git.bb
+++ b/recipes-devtools/go/grpc-go_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=3b83ef96387f14655fc854ddc
7SRCNAME = "grpc-go" 7SRCNAME = "grpc-go"
8 8
9PKG_NAME = "google.golang.org/grpc" 9PKG_NAME = "google.golang.org/grpc"
10SRC_URI = "git://github.com/grpc/${SRCNAME}.git;destsuffix=git/src/${PKG_NAME};branch=master" 10SRC_URI = "git://github.com/grpc/${SRCNAME}.git;destsuffix=git/src/${PKG_NAME};branch=master;protocol=https"
11 11
12SRCREV = "5d8e5aad40bedb696205b96b786f1d0e1326b3f8" 12SRCREV = "5d8e5aad40bedb696205b96b786f1d0e1326b3f8"
13PV = "1.41.0+git${SRCPV}" 13PV = "1.41.0+git${SRCPV}"
diff --git a/recipes-devtools/yq/yq_git.bb b/recipes-devtools/yq/yq_git.bb
index 198699ba..3e48fee6 100644
--- a/recipes-devtools/yq/yq_git.bb
+++ b/recipes-devtools/yq/yq_git.bb
@@ -16,14 +16,14 @@ SRCREV_yaml = "eeeca48fe7764f320e4870d231902bf9c1be2c08"
16 16
17SRCREV_FORMAT = "yq_color" 17SRCREV_FORMAT = "yq_color"
18SRC_URI = "git://${GO_IMPORT};name=yq;branch=master \ 18SRC_URI = "git://${GO_IMPORT};name=yq;branch=master \
19 git://github.com/fatih/color;name=color;destsuffix=build/vendor/src/github.com/fatih/color;branch=master \ 19 git://github.com/fatih/color;name=color;destsuffix=build/vendor/src/github.com/fatih/color;branch=master;protocol=https \
20 git://github.com/goccy/go-yaml;name=lexer;destsuffix=build/vendor/src/github.com/goccy/go-yaml/;branch=master \ 20 git://github.com/goccy/go-yaml;name=lexer;destsuffix=build/vendor/src/github.com/goccy/go-yaml/;branch=master;protocol=https \
21 git://github.com/kylelemons/godebug;name=debug;destsuffix=build/vendor/src/github.com/kylelemons/godebug/;branch=master \ 21 git://github.com/kylelemons/godebug;name=debug;destsuffix=build/vendor/src/github.com/kylelemons/godebug/;branch=master;protocol=https \
22 git://github.com/pkg/errors;name=errors;destsuffix=build/vendor/src/github.com/pkg/errors/;branch=master \ 22 git://github.com/pkg/errors;name=errors;destsuffix=build/vendor/src/github.com/pkg/errors/;branch=master;protocol=https \
23 git://github.com/spf13/cobra;name=cobra;destsuffix=build/vendor/src/github.com/spf13/cobra;branch=master \ 23 git://github.com/spf13/cobra;name=cobra;destsuffix=build/vendor/src/github.com/spf13/cobra;branch=master;protocol=https \
24 git://github.com/spf13/pflag;name=pflag;destsuffix=build/vendor/src/github.com/spf13/pflag;branch=master \ 24 git://github.com/spf13/pflag;name=pflag;destsuffix=build/vendor/src/github.com/spf13/pflag;branch=master;protocol=https \
25 git://github.com/op/go-logging.git;name=logging;destsuffix=build/vendor/src/gopkg.in/op/go-logging.v1;branch=master \ 25 git://github.com/op/go-logging.git;name=logging;destsuffix=build/vendor/src/gopkg.in/op/go-logging.v1;branch=master;protocol=https \
26 git://github.com/go-yaml/yaml.git;name=yaml;branch=v3;destsuffix=build/vendor/src/gopkg.in/yaml.v3 \ 26 git://github.com/go-yaml/yaml.git;name=yaml;branch=v3;destsuffix=build/vendor/src/gopkg.in/yaml.v3;protocol=https \
27 " 27 "
28 28
29PV = "1.13.1+git${SRCREV_yq}" 29PV = "1.13.1+git${SRCREV_yq}"