summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2017-09-15 13:13:00 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-09-15 15:21:18 -0400
commitd16d4acc6059d05d94a4e319b801ce0272f17dd9 (patch)
treee0ea9532b2f9996eeb9d219a42f288939ad671e2 /recipes-devtools/python
parente83556a3f4633e91be4bb107fb7663c5282a924a (diff)
downloadmeta-virtualization-d16d4acc6059d05d94a4e319b801ce0272f17dd9.tar.gz
python3-docker-compose: add version 1.16.1 + dependencies
This requires some packages as well as the pypi.bbclass from meta-python. It uses Python 3 as I don't think it makes sense to use Python 2 anymore. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-docopt.inc9
-rw-r--r--recipes-devtools/python/python3-cached-property_1.3.0.bb9
-rw-r--r--recipes-devtools/python/python3-colorama_0.3.9.bb9
-rw-r--r--recipes-devtools/python/python3-docker-pycreds_0.2.1.bb9
-rw-r--r--recipes-devtools/python/python3-docker_2.5.1.bb11
-rw-r--r--recipes-devtools/python/python3-dockerpty_0.4.1.bb9
-rw-r--r--recipes-devtools/python/python3-docopt_0.6.2.bb2
-rw-r--r--recipes-devtools/python/python3-texttable_0.9.1.bb9
-rw-r--r--recipes-devtools/python/python3-websocket-client_0.44.0.bb11
9 files changed, 78 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-docopt.inc b/recipes-devtools/python/python-docopt.inc
new file mode 100644
index 00000000..4f464c13
--- /dev/null
+++ b/recipes-devtools/python/python-docopt.inc
@@ -0,0 +1,9 @@
1SUMMARY = "Pythonic argument parser, that will make you smile"
2HOMEPAGE = "http://docopt.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=09b77fb74986791a3d4a0e746a37d88f"
5
6inherit pypi
7
8SRC_URI[md5sum] = "4bc74561b37fad5d3e7d037f82a4c3b1"
9SRC_URI[sha256sum] = "49b3a825280bd66b3aa83585ef59c4a8c82f2c8a522dbe754a8bc8d08c85c491"
diff --git a/recipes-devtools/python/python3-cached-property_1.3.0.bb b/recipes-devtools/python/python3-cached-property_1.3.0.bb
new file mode 100644
index 00000000..f01aabd0
--- /dev/null
+++ b/recipes-devtools/python/python3-cached-property_1.3.0.bb
@@ -0,0 +1,9 @@
1SUMMARY = "A decorator for caching properties in classes."
2HOMEPAGE = "https://github.com/pydanny/cached-property"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=db7ff60c4e14f58534201242803d8abc"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "4a6039f7418007275505e355359396a8"
9SRC_URI[sha256sum] = "458e78b1c7286ece887d92c9bee829da85717994c5e3ddd253a40467f488bc81"
diff --git a/recipes-devtools/python/python3-colorama_0.3.9.bb b/recipes-devtools/python/python3-colorama_0.3.9.bb
new file mode 100644
index 00000000..458b0dbd
--- /dev/null
+++ b/recipes-devtools/python/python3-colorama_0.3.9.bb
@@ -0,0 +1,9 @@
1SUMMARY = "Cross-platform colored terminal text."
2HOMEPAGE = "https://github.com/tartley/colorama"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14d0b64047ed8f510b51ce0495995358"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "3a0e415259690f4dd7455c2683ee5850"
9SRC_URI[sha256sum] = "48eb22f4f8461b1df5734a074b57042430fb06e1d61bd1e11b078c0fe6d7a1f1"
diff --git a/recipes-devtools/python/python3-docker-pycreds_0.2.1.bb b/recipes-devtools/python/python3-docker-pycreds_0.2.1.bb
new file mode 100644
index 00000000..40384100
--- /dev/null
+++ b/recipes-devtools/python/python3-docker-pycreds_0.2.1.bb
@@ -0,0 +1,9 @@
1SUMMARY = "Python bindings for the docker credentials store API"
2HOMEPAGE = "https://github.com/shin-/dockerpy-creds"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "0d80d5aebab771faf7e422b759c3055b"
9SRC_URI[sha256sum] = "93833a2cf280b7d8abbe1b8121530413250c6cd4ffed2c1cf085f335262f7348"
diff --git a/recipes-devtools/python/python3-docker_2.5.1.bb b/recipes-devtools/python/python3-docker_2.5.1.bb
new file mode 100644
index 00000000..ff8f89ee
--- /dev/null
+++ b/recipes-devtools/python/python3-docker_2.5.1.bb
@@ -0,0 +1,11 @@
1SUMMARY = "A Python library for the Docker Engine API."
2HOMEPAGE = "https://github.com/docker/docker-py"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "7d917152976df075e6e90ee853df641f"
9SRC_URI[sha256sum] = "b876e6909d8d2360e0540364c3a952a62847137f4674f2439320ede16d6db880"
10
11DEPENDS += "${PYTHON_PN}-pip-native"
diff --git a/recipes-devtools/python/python3-dockerpty_0.4.1.bb b/recipes-devtools/python/python3-dockerpty_0.4.1.bb
new file mode 100644
index 00000000..a40f2a30
--- /dev/null
+++ b/recipes-devtools/python/python3-dockerpty_0.4.1.bb
@@ -0,0 +1,9 @@
1SUMMARY = "Python library to use the pseudo-tty of a docker container"
2HOMEPAGE = "https://github.com/d11wtq/dockerpty"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=afaf767baa20ac524dc12f1071ca493a"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "028bacb34536f3ee6a2ccd668c27e8e4"
9SRC_URI[sha256sum] = "69a9d69d573a0daa31bcd1c0774eeed5c15c295fe719c61aca550ed1393156ce"
diff --git a/recipes-devtools/python/python3-docopt_0.6.2.bb b/recipes-devtools/python/python3-docopt_0.6.2.bb
new file mode 100644
index 00000000..4637448a
--- /dev/null
+++ b/recipes-devtools/python/python3-docopt_0.6.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-docopt.inc
diff --git a/recipes-devtools/python/python3-texttable_0.9.1.bb b/recipes-devtools/python/python3-texttable_0.9.1.bb
new file mode 100644
index 00000000..25e402f1
--- /dev/null
+++ b/recipes-devtools/python/python3-texttable_0.9.1.bb
@@ -0,0 +1,9 @@
1SUMMARY = "module for creating simple ASCII tables"
2HOMEPAGE = "https://github.com/foutaise/texttable/"
3LICENSE = "LGPL-3.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e6a600fd5e1d9cbde2d983680233ad02"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "a712b5a5464d51c5fc43c64d9d2cd0de"
9SRC_URI[sha256sum] = "119041773ff03596b56392532f9315cb3a3116e404fd6f36e76a7dc088d95c79"
diff --git a/recipes-devtools/python/python3-websocket-client_0.44.0.bb b/recipes-devtools/python/python3-websocket-client_0.44.0.bb
new file mode 100644
index 00000000..8dfc95f5
--- /dev/null
+++ b/recipes-devtools/python/python3-websocket-client_0.44.0.bb
@@ -0,0 +1,11 @@
1SUMMARY = "WebSocket client for python. hybi13 is supported."
2HOMEPAGE = "https://github.com/websocket-client/websocket-client.git"
3LICENSE = "LGPL-3.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=18b09a20dd186af4fd60f1a08311628c"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "websocket_client"
9
10SRC_URI[md5sum] = "73d87aa16a2212da448b30aca9c5bf3b"
11SRC_URI[sha256sum] = "15f585566e2ea7459136a632b9785aa081093064391878a448c382415e948d72"