summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2015-06-17 09:37:07 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-06-17 16:10:05 -0400
commita623810bd044b895d292a334266cb2cc6a695054 (patch)
tree7e972856b32f4026153f079755439f326d09e63f /recipes-devtools/python
parentfe357d8c80137595ee6d0a84b9178f2f846ba441 (diff)
downloadmeta-virtualization-a623810bd044b895d292a334266cb2cc6a695054.tar.gz
python-gevent: Fix cross compile for ARM
The lack of a proper ability to regenerate configure causes the cross compile detect logic to fail (shown below). It is easiest to just force the cross compile option at configure time. | configure: error: in `/opt/buildtmp/work/cortexa7t2hf-vfp-neon-wrs-linux-gnueabi/python-gevent/1.0.1-r0/gevent-1.0.1/build/temp.linux-x86_64-2.7/libev': | configure: error: cannot run C compiled programs. | If you meant to cross compile, use `--host'. | See `config.log' for more details | Running '/bin/sh /opt/buildtmp/work/cortexa7t2hf-vfp-neon-wrs-linux-gnueabi/python-gevent/1.0.1-r0/gevent-1.0.1/libev/configure > configure-output.txt' in /opt/buildtmp/work/cortexa7t2hf-vfp-neon-wrs-linux-gnueabi/python-gevent/1.0.1-r0/gevent-1.0.1/build/temp.linux-x86_64-2.7/libev | building 'gevent.core' extension | creating build/temp.linux-x86_64-2.7/gevent | ccache arm-wrs-linux-gnueabi-gcc -march=armv7-a -mfloat-abi=hard -mfpu=neon -marm -mthumb-interwork -mtune=cortex-a7 --sysroot=/opt/buildtmp/sysroots/fsl-ls10xx -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -O2 -pipe -g -fPIC -DLIBEV_EMBED=1 -DEV_COMMON= -DEV_CLEANUP_ENABLE=0 -DEV_EMBED_ENABLE=0 -DEV_PERIODIC_ENABLE=0 -Ibuild/temp.linux-x86_64-2.7/libev -Ilibev -I/opt/buildtmp/sysroots/fsl-ls10xx/usr/include/python2.7 -c gevent/gevent.core.c -o build/temp.linux-x86_64-2.7/gevent/gevent.core.o | In file included from gevent/libev.h:2:0, | from gevent/gevent.core.c:313: | libev/ev.c:45:22: fatal error: config.h: No such file or directory | # include "config.h" | ^ | compilation terminated. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-gevent_1.0.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-gevent_1.0.1.bb b/recipes-devtools/python/python-gevent_1.0.1.bb
index 44f9518b..47f1267a 100644
--- a/recipes-devtools/python/python-gevent_1.0.1.bb
+++ b/recipes-devtools/python/python-gevent_1.0.1.bb
@@ -24,3 +24,10 @@ inherit setuptools
24FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 24FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
25SRC_URI += "file://libev-conf.patch" 25SRC_URI += "file://libev-conf.patch"
26SRC_URI += "file://gevent-allow-ssl-v2-or-v3-certificates.patch" 26SRC_URI += "file://gevent-allow-ssl-v2-or-v3-certificates.patch"
27
28# The python-gevent has no autoreconf ability
29# and the logic for detecting a cross compile is flawed
30# so always force a cross compile
31do_configure_append() {
32 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/libev/configure
33} \ No newline at end of file