summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2015-03-12 21:42:44 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-03-17 09:46:32 -0400
commit938c1cb12706691387c75d69dce47fdcaef09bdf (patch)
tree56342617e8c78ae156c6917da6d060ab30f93368 /recipes-devtools/python
parent33ea7df40bc5aa9a34f4362e976775be1076e876 (diff)
downloadmeta-virtualization-938c1cb12706691387c75d69dce47fdcaef09bdf.tar.gz
docker: Add dependencies for docker and docker-registry
These are a set of dependencies required to build and run docker and docker-registry which had previously existed in meta-cloud-services. By moving these from meta-cloud-services to meta-virtualization we can build and use docker without needing to include meta-cloud-services. Since meta-cloud-services depends on meta-virtualization these recipes will still be available for use with packages/images in meta-cloud-services. There is a concern that meta-cloud-services contains many python packages as there exists tight dependency for specific package versions, this move does not prevent this tight binding from continuing using various mechanisms made available to layers. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-flask_0.10.1.bb20
-rw-r--r--recipes-devtools/python/python-itsdangerous_0.24.bb22
-rw-r--r--recipes-devtools/python/python-six_1.7.3.bb18
-rw-r--r--recipes-devtools/python/python-sphinx_1.2b1.bb17
-rw-r--r--recipes-devtools/python/python-sqlalchemy_0.9.7.bb16
-rw-r--r--recipes-devtools/python/python-webob_1.2.3.bb23
-rw-r--r--recipes-devtools/python/python-werkzeug_0.9.4.bb31
7 files changed, 147 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-flask_0.10.1.bb b/recipes-devtools/python/python-flask_0.10.1.bb
new file mode 100644
index 00000000..263e53d0
--- /dev/null
+++ b/recipes-devtools/python/python-flask_0.10.1.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "A microframework based on Werkzeug, Jinja2 and good intentions"
2HOMEPAGE = "https://pypi.python.org/pypi/Flask/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=79aa8b7bc4f781210d6b5c06d6424cb0"
6
7PR = "r0"
8SRCNAME = "Flask"
9
10SRC_URI = "https://pypi.python.org/packages/source/F/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "378670fe456957eb3c27ddaef60b2b24"
13SRC_URI[sha256sum] = "4c83829ff83d408b5e1d4995472265411d2c414112298f2eb4b359d9e4563373"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19CLEANBROKEN = "1"
20
diff --git a/recipes-devtools/python/python-itsdangerous_0.24.bb b/recipes-devtools/python/python-itsdangerous_0.24.bb
new file mode 100644
index 00000000..3e229f8f
--- /dev/null
+++ b/recipes-devtools/python/python-itsdangerous_0.24.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Various helpers to pass trusted data to untrusted environments and back"
2HOMEPAGE = "https://pypi.python.org/pypi/itsdangerous/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b61841e2bf5f07884148e2a6f1bcab0c"
6
7PR = "r0"
8SRCNAME = "itsdangerous"
9
10SRC_URI = "https://pypi.python.org/packages/source/i/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "a3d55aa79369aef5345c036a8a26307f"
13SRC_URI[sha256sum] = "cbb3fcf8d3e33df861709ecaf89d9e6629cff0a217bc2848f1b41cd30d360519"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} += "python-json python-netclient python-zlib python-datetime python-lang python-crypt"
20
21CLEANBROKEN = "1"
22
diff --git a/recipes-devtools/python/python-six_1.7.3.bb b/recipes-devtools/python/python-six_1.7.3.bb
new file mode 100644
index 00000000..07dcafdf
--- /dev/null
+++ b/recipes-devtools/python/python-six_1.7.3.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "Python 2 and 3 compatibility utilities"
2HOMEPAGE = "http://pypi.python.org/pypi/six/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=530f34047c21ad45b3199946dd90bea5"
6
7PR = "r1"
8SRCNAME = "six"
9
10SRC_URI = "https://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
11"
12
13SRC_URI[md5sum] = "784c6e5541c3c4952de9c0a966a0a80b"
14SRC_URI[sha256sum] = "7a842c9f882c0b2ab1064d567bb9fff6a21c9efbc3d9992083ad6193787ed393"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit setuptools
diff --git a/recipes-devtools/python/python-sphinx_1.2b1.bb b/recipes-devtools/python/python-sphinx_1.2b1.bb
new file mode 100644
index 00000000..acdba560
--- /dev/null
+++ b/recipes-devtools/python/python-sphinx_1.2b1.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=da9cf9fa4e0d0076dd4d116777ad401e"
6
7PR = "r0"
8SRCNAME = "Sphinx"
9
10SRC_URI = "http://pypi.python.org/packages/source/S/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "67bea6df63be8e2a76ebedc76d8f71a3"
13SRC_URI[sha256sum] = "16102b69e939d9ee60b05d694a804a83e3ce047c283f6b981a83573a75ea718d"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
diff --git a/recipes-devtools/python/python-sqlalchemy_0.9.7.bb b/recipes-devtools/python/python-sqlalchemy_0.9.7.bb
new file mode 100644
index 00000000..6207233e
--- /dev/null
+++ b/recipes-devtools/python/python-sqlalchemy_0.9.7.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6c90a3830628085e8ba945f94d622cb2"
6RDEPENDS_${PN} += "python-numbers"
7
8SRCNAME = "SQLAlchemy"
9SRC_URI = "https://pypi.python.org/packages/source/S/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "e3c8f836ea9b48886718f59b9d8646ff"
12SRC_URI[sha256sum] = "5fff261d0cff21c39913f9d30682659a52bfa2875699b2b7d908d0225df42a15"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
diff --git a/recipes-devtools/python/python-webob_1.2.3.bb b/recipes-devtools/python/python-webob_1.2.3.bb
new file mode 100644
index 00000000..a30ee9c1
--- /dev/null
+++ b/recipes-devtools/python/python-webob_1.2.3.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "WSGI request and response object"
2HOMEPAGE = "http://webob.org/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://docs/license.txt;md5=8ed3584bcc78c16da363747ccabc5af5"
6
7PR = "r0"
8SRCNAME = "WebOb"
9
10SRC_URI = "http://pypi.python.org/packages/source/W/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "11825b7074ba7043e157805e4e6e0f55"
13SRC_URI[sha256sum] = "325c249f3ac35e72b75ba13b2c60317def0c986a24a413ebf700509ea4c73a13"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} += " \
20 python-sphinx \
21 python-nose \
22 "
23
diff --git a/recipes-devtools/python/python-werkzeug_0.9.4.bb b/recipes-devtools/python/python-werkzeug_0.9.4.bb
new file mode 100644
index 00000000..38e9f0f9
--- /dev/null
+++ b/recipes-devtools/python/python-werkzeug_0.9.4.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "The Swiss Army knife of Python web development"
2HOMEPAGE = "https://pypi.python.org/pypi/Werkzeug/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=ad2e600a437b1b03d25b02df8c23ad1c"
6
7PR = "r0"
8SRCNAME = "Werkzeug"
9
10SRC_URI = "https://pypi.python.org/packages/source/W/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "670fad41f57c13b71a6816765765a3dd"
13SRC_URI[sha256sum] = "c1baf7a3e8be70f34d931ee173283f406877bd3d17f372bbe82318a5b3c510cc"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} += "python-io \
20 python-datetime \
21 python-email \
22 python-zlib \
23 python-pkgutil \
24 python-html \
25 python-shell \
26 python-pprint \
27 python-subprocess \
28 python-netserver"
29
30CLEANBROKEN = "1"
31