summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-03-30 23:42:44 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-03-30 23:42:44 -0400
commit780a57e15a58cc1d74090509138744550609d876 (patch)
treebd3e8bf1663b689ba89b05b8f63facea4039ce3b /recipes-devtools/python
parentdf21652a7fb9499f0c1f8d23d0989672a9dae218 (diff)
downloadmeta-virtualization-780a57e15a58cc1d74090509138744550609d876.tar.gz
gevent: allow ssl v2 or v3 certificates
Work around an issue with python 2.7 not always having SSLv3 available by allowing v2 or v3 certificates. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-gevent/gevent-allow-ssl-v2-or-v3-certificates.patch29
-rw-r--r--recipes-devtools/python/python-gevent_1.0.1.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-gevent/gevent-allow-ssl-v2-or-v3-certificates.patch b/recipes-devtools/python/python-gevent/gevent-allow-ssl-v2-or-v3-certificates.patch
new file mode 100644
index 00000000..623d04f0
--- /dev/null
+++ b/recipes-devtools/python/python-gevent/gevent-allow-ssl-v2-or-v3-certificates.patch
@@ -0,0 +1,29 @@
1From c2dc97478fcc3757e09d5d2997391960a8351d53 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Sun, 29 Mar 2015 22:34:28 -0400
4Subject: [PATCH] gevent: allow ssl v2 or v3 certificates
5
6Work around an issue with python 2.7 not always having SSLv3 available
7by allowing v2 or v3 certificates.
8
9Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
10---
11 gevent/ssl.py | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/gevent/ssl.py b/gevent/ssl.py
15index ce6434718d1b..93c0d642da5f 100644
16--- a/gevent/ssl.py
17+++ b/gevent/ssl.py
18@@ -383,7 +383,7 @@ def wrap_socket(sock, keyfile=None, certfile=None,
19 ciphers=ciphers)
20
21
22-def get_server_certificate(addr, ssl_version=PROTOCOL_SSLv3, ca_certs=None):
23+def get_server_certificate(addr, ssl_version=PROTOCOL_SSLv23, ca_certs=None):
24 """Retrieve the certificate from the server at the specified address,
25 and return it as a PEM-encoded string.
26 If 'ca_certs' is specified, validate the server cert against it.
27--
281.9.1
29
diff --git a/recipes-devtools/python/python-gevent_1.0.1.bb b/recipes-devtools/python/python-gevent_1.0.1.bb
index f42979be..44f9518b 100644
--- a/recipes-devtools/python/python-gevent_1.0.1.bb
+++ b/recipes-devtools/python/python-gevent_1.0.1.bb
@@ -23,3 +23,4 @@ inherit setuptools
23 23
24FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 24FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
25SRC_URI += "file://libev-conf.patch" 25SRC_URI += "file://libev-conf.patch"
26SRC_URI += "file://gevent-allow-ssl-v2-or-v3-certificates.patch"