summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-sphinx-420.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-03-24 08:10:59 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-03-24 08:10:59 -0400
commit82f8a454a37bff32b98eab004e20b9c25a818165 (patch)
treeccf69081fb60156eb7bff0eab956af383868f9c7 /recipes-devtools/python/python3-sphinx-420.bb
parente7516708fe6fb60e52b24354fa5635689aa06d5d (diff)
downloadmeta-virtualization-82f8a454a37bff32b98eab004e20b9c25a818165.tar.gz
python3-sphinx: make a 4.2.0 specific recipe
OEcore has pulled in python3-sphinx, and bumped the version. Our recipe is causing failures. We still have a version dependency on 4.2.x, so we create a specific recipe to keep things working. Hopefully this can be deleted shortly, and this is only being created as a transition project. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python3-sphinx-420.bb')
-rw-r--r--recipes-devtools/python/python3-sphinx-420.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-sphinx-420.bb b/recipes-devtools/python/python3-sphinx-420.bb
new file mode 100644
index 00000000..67ecf416
--- /dev/null
+++ b/recipes-devtools/python/python3-sphinx-420.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & BSD-3-Clause & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=82cc7d23060a75a07b820eaaf75abecf"
6
7PYPI_PACKAGE = "Sphinx"
8
9PV = "4.2.0"
10
11RCONFLICTS:${PN} = "python3-sphinx"
12
13SRC_URI[sha256sum] = "94078db9184491e15bce0a56d9186e0aec95f16ac20b12d00e06d4e36f1058a6"
14
15inherit setuptools3 pypi