summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/go
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2015-06-19 12:01:32 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-06-19 15:31:40 -0400
commit2113be0a1d833480914396be15334e16c12ba097 (patch)
tree125e8447de5f4255a275e560821e54f3d3673625 /recipes-devtools/go
parent0682e9edcb7ca9c92eb40b61a01a12e20f1791b1 (diff)
downloadmeta-virtualization-2113be0a1d833480914396be15334e16c12ba097.tar.gz
golang-cross: add ccache support
golang doesn't work with ccache. In the current state, a lot of parsing happens where it'll grab the first string in CC or LD and uses that for its builds. When ccache is enabled, it results in trying to do builds with just ccache. The brokeness is seen when building with apps that uses cgo, like docker. To enable ccache to work, some string comparisons and changes to parsing had to be made. Signed-off-by: Amy Fong <amy.fong@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools/go')
-rw-r--r--recipes-devtools/go/files/ccache.patch147
-rw-r--r--recipes-devtools/go/golang-cross.inc1
-rw-r--r--recipes-devtools/go/golang-cross_1.3.bb3
3 files changed, 148 insertions, 3 deletions
diff --git a/recipes-devtools/go/files/ccache.patch b/recipes-devtools/go/files/ccache.patch
new file mode 100644
index 00000000..b7a64bf7
--- /dev/null
+++ b/recipes-devtools/go/files/ccache.patch
@@ -0,0 +1,147 @@
1golang doesn't work with ccache. In the current state, a lot of parsing
2happens where it'll grab the first string in CC or LD and uses that for
3its builds. When ccache is enabled, it results in trying to do builds
4with just ccache.
5
6The brokeness is seen when building with apps that uses cgo, like docker.
7To enable ccache to work, some string comparisons and changes to parsing
8had to be made.
9
10Signed-off-by: Amy Fong <amy.fong@windriver.com>
11
12Index: go/src/cmd/cgo/gcc.go
13===================================================================
14--- go.orig/src/cmd/cgo/gcc.go 2014-06-18 17:26:26.000000000 -0700
15+++ go/src/cmd/cgo/gcc.go 2015-06-18 13:19:08.908877160 -0700
16@@ -712,6 +712,12 @@
17 func (p *Package) gccBaseCmd() []string {
18 // Use $CC if set, since that's what the build uses.
19 if ret := strings.Fields(os.Getenv("CC")); len(ret) > 0 {
20+ if strings.Contains(ret[0], "ccache") {
21+ base_cc := ret[0] + " " + ret[1]
22+ os.Setenv("CCACHE_CC", ret[1])
23+ ret[1] = base_cc
24+ return ret[1:]
25+ }
26 return ret
27 }
28 // Try $GCC if set, since that's what we used to use.
29Index: go/src/pkg/os/exec/lp_unix.go
30===================================================================
31--- go.orig/src/pkg/os/exec/lp_unix.go 2014-06-18 17:26:25.000000000 -0700
32+++ go/src/pkg/os/exec/lp_unix.go 2015-06-18 13:19:29.464876331 -0700
33@@ -35,8 +35,14 @@
34 // (only bypass the path if file begins with / or ./ or ../)
35 // but that would not match all the Unix shells.
36
37- if strings.Contains(file, "/") {
38- err := findExecutable(file)
39+ tmp := file
40+ if strings.Contains(file, " ") {
41+ exec_part := strings.Split(file, " ")[0]
42+ tmp = exec_part
43+ }
44+
45+ if strings.Contains(tmp, "/") {
46+ err := findExecutable(tmp)
47 if err == nil {
48 return file, nil
49 }
50@@ -51,7 +57,7 @@
51 // Unix shell semantics: path element "" means "."
52 dir = "."
53 }
54- path := dir + "/" + file
55+ path := dir + "/" + tmp
56 if err := findExecutable(path); err == nil {
57 return path, nil
58 }
59Index: go/src/cmd/go/build.go
60===================================================================
61--- go.orig/src/cmd/go/build.go 2014-06-18 17:26:26.000000000 -0700
62+++ go/src/cmd/go/build.go 2015-06-18 13:20:08.724874749 -0700
63@@ -2005,8 +2005,15 @@
64 // strings returned are "gcc", "-I", objdir (and cuts them off).
65
66 compiler := envList(envvar, defcmd)
67- a := []string{compiler[0], "-I", objdir}
68- a = append(a, compiler[1:]...)
69+
70+ a := []string{compiler[0]}
71+ if strings.Contains(compiler[0], "ccache") {
72+ a = append(a, compiler[1], "-I", objdir)
73+ a = append(a, compiler[2:]...)
74+ } else {
75+ a = append(a, "-I", objdir)
76+ a = append(a, compiler[1:]...)
77+ }
78
79 // Definitely want -fPIC but on Windows gcc complains
80 // "-fPIC ignored for target (all code is position independent)"
81Index: go/src/cmd/ld/lib.c
82===================================================================
83--- go.orig/src/cmd/ld/lib.c 2014-06-18 17:26:27.000000000 -0700
84+++ go/src/cmd/ld/lib.c 2015-06-18 13:18:39.564878343 -0700
85@@ -552,7 +552,7 @@
86 void
87 hostlink(void)
88 {
89- char *p, **argv;
90+ char *p, *q, **argv;
91 int c, i, w, n, argc, len;
92 Hostobj *h;
93 Biobuf *f;
94@@ -577,6 +577,19 @@
95 if(extld == nil)
96 extld = "gcc";
97 argv[argc++] = extld;
98+
99+ p = extldflags;
100+ if (strstr(argv[0], "ccache") != NULL) {
101+ while(p != nil) {
102+ while(*p == ' ')
103+ *p++ = '\0';
104+ if(*p == '\0')
105+ break;
106+ argv[argc++] = p;
107+ p = strchr(p + 1, ' ');
108+ break;
109+ }
110+ }
111 switch(thechar){
112 case '8':
113 argv[argc++] = "-m32";
114@@ -629,12 +642,12 @@
115 errorexit();
116 }
117 Bseek(f, h->off, 0);
118- p = smprint("%s/%06d.o", tmpdir, i);
119- argv[argc++] = p;
120- w = create(p, 1, 0775);
121+ q = smprint("%s/%06d.o", tmpdir, i);
122+ argv[argc++] = q;
123+ w = create(q, 1, 0775);
124 if(w < 0) {
125 ctxt->cursym = S;
126- diag("cannot create %s: %r", p);
127+ diag("cannot create %s: %r", q);
128 errorexit();
129 }
130 len = h->len;
131@@ -646,7 +659,7 @@
132 }
133 if(close(w) < 0) {
134 ctxt->cursym = S;
135- diag("cannot write %s: %r", p);
136+ diag("cannot write %s: %r", q);
137 errorexit();
138 }
139 Bterm(f);
140@@ -656,7 +669,6 @@
141 for(i=0; i<nldflag; i++)
142 argv[argc++] = ldflag[i];
143
144- p = extldflags;
145 while(p != nil) {
146 while(*p == ' ')
147 *p++ = '\0';
diff --git a/recipes-devtools/go/golang-cross.inc b/recipes-devtools/go/golang-cross.inc
index ce4ee0e9..be2c1ebc 100644
--- a/recipes-devtools/go/golang-cross.inc
+++ b/recipes-devtools/go/golang-cross.inc
@@ -6,6 +6,7 @@ PROVIDES = "virtual/${TARGET_PREFIX}golang"
6SRC_URI = "\ 6SRC_URI = "\
7 http://golang.org/dl/go${PV}.src.tar.gz \ 7 http://golang.org/dl/go${PV}.src.tar.gz \
8 file://bsd_svid_source.patch \ 8 file://bsd_svid_source.patch \
9 file://ccache.patch \
9 " 10 "
10 11
11S="${WORKDIR}/go" 12S="${WORKDIR}/go"
diff --git a/recipes-devtools/go/golang-cross_1.3.bb b/recipes-devtools/go/golang-cross_1.3.bb
index 6d538f9e..fcb0e7a2 100644
--- a/recipes-devtools/go/golang-cross_1.3.bb
+++ b/recipes-devtools/go/golang-cross_1.3.bb
@@ -1,7 +1,4 @@
1inherit cross 1inherit cross
2 2
3# CCACHE does not work properly with GO
4CCACHE = ""
5
6require golang-cross.inc 3require golang-cross.inc
7require golang-${PV}.inc 4require golang-${PV}.inc