diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2017-02-08 12:53:28 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-02-09 09:14:27 -0500 |
commit | b2c365c37108c1ede6adbba45c158b7c68eed98e (patch) | |
tree | b4684c59b8b05a7b895405e94c696d84e73aca80 /recipes-devtools/go/go-distribution_git.bb | |
parent | 2ef58c264b21d36255c2754abef43e0bee764ae8 (diff) | |
download | meta-virtualization-b2c365c37108c1ede6adbba45c158b7c68eed98e.tar.gz |
docker: fixup failing build
Docker is failing to build because it is attempting to download
missing go dependencies. Add new recipes for missing dependencies and
update existing recipes to ensure the version defined in docker's
vendor.conf is available.
Note that this fixes the build only. At this time many docker
functions are working, such as 'docker image', 'docker pull' and more,
but 'docker run' is currently failing.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools/go/go-distribution_git.bb')
-rw-r--r-- | recipes-devtools/go/go-distribution_git.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-distribution_git.bb b/recipes-devtools/go/go-distribution_git.bb new file mode 100644 index 00000000..9e3f2093 --- /dev/null +++ b/recipes-devtools/go/go-distribution_git.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | DESCRIPTION = "The Docker toolset to pack, ship, store, and deliver content" | ||
2 | HOMEPAGE = "https://github.com/docker/distribution" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=d2794c0df5b907fdace235a619d80314" | ||
6 | |||
7 | SRCNAME = "distribution" | ||
8 | |||
9 | PKG_NAME = "github.com/docker/${SRCNAME}" | ||
10 | SRC_URI = "git://${PKG_NAME}.git;branch=docker/1.13;destsuffix=git/src/${PKG_NAME}" | ||
11 | |||
12 | SRCREV = "28602af35aceda2f8d571bad7ca37a54cf0250bc" | ||
13 | PV = "2.6.0+git${SRCPV}" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | # NO-OP the do compile rule because this recipe is source only. | ||
18 | do_compile() { | ||
19 | } | ||
20 | |||
21 | do_install() { | ||
22 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
23 | for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do | ||
24 | if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then | ||
25 | mkdir -p ${D}${prefix}/local/go/$(dirname $j) | ||
26 | fi | ||
27 | cp $j ${D}${prefix}/local/go/$j | ||
28 | done | ||
29 | cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
30 | } | ||
31 | |||
32 | SYSROOT_PREPROCESS_FUNCS += "go_distribution_digeset_sysroot_preprocess" | ||
33 | |||
34 | go_distribution_digeset_sysroot_preprocess () { | ||
35 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
36 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
37 | } | ||
38 | |||
39 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||