summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/go/go-distribution_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-02-08 12:53:28 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-02-09 09:14:27 -0500
commitb2c365c37108c1ede6adbba45c158b7c68eed98e (patch)
treeb4684c59b8b05a7b895405e94c696d84e73aca80 /recipes-devtools/go/go-distribution_git.bb
parent2ef58c264b21d36255c2754abef43e0bee764ae8 (diff)
downloadmeta-virtualization-b2c365c37108c1ede6adbba45c158b7c68eed98e.tar.gz
docker: fixup failing build
Docker is failing to build because it is attempting to download missing go dependencies. Add new recipes for missing dependencies and update existing recipes to ensure the version defined in docker's vendor.conf is available. Note that this fixes the build only. At this time many docker functions are working, such as 'docker image', 'docker pull' and more, but 'docker run' is currently failing. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools/go/go-distribution_git.bb')
-rw-r--r--recipes-devtools/go/go-distribution_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-distribution_git.bb b/recipes-devtools/go/go-distribution_git.bb
new file mode 100644
index 00000000..9e3f2093
--- /dev/null
+++ b/recipes-devtools/go/go-distribution_git.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "The Docker toolset to pack, ship, store, and deliver content"
2HOMEPAGE = "https://github.com/docker/distribution"
3SECTION = "devel/go"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7SRCNAME = "distribution"
8
9PKG_NAME = "github.com/docker/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;branch=docker/1.13;destsuffix=git/src/${PKG_NAME}"
11
12SRCREV = "28602af35aceda2f8d571bad7ca37a54cf0250bc"
13PV = "2.6.0+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17# NO-OP the do compile rule because this recipe is source only.
18do_compile() {
19}
20
21do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do
24 if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then
25 mkdir -p ${D}${prefix}/local/go/$(dirname $j)
26 fi
27 cp $j ${D}${prefix}/local/go/$j
28 done
29 cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/
30}
31
32SYSROOT_PREPROCESS_FUNCS += "go_distribution_digeset_sysroot_preprocess"
33
34go_distribution_digeset_sysroot_preprocess () {
35 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
36 cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
37}
38
39FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"