diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-07-28 14:22:43 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-08-02 17:17:53 -0400 |
commit | d876cfc5bfafa516dee55d04b50b319a22165640 (patch) | |
tree | ea03c34f999bd85e440c85fc8e722df8666e2e68 /recipes-devtools/go/go-connections_git.bb | |
parent | 5fdf66c1e2ec0c6b08573bf0a6aa9f84d2fc4ae6 (diff) | |
download | meta-virtualization-d876cfc5bfafa516dee55d04b50b319a22165640.tar.gz |
global: overrides syntax conversion
OEcore/bitbake are moving to use the clearer ":" as an overrides
separator.
This is pass one of updating the meta-virt recipes to use that
syntax.
This has only been minimally build/runtime tested, more changes
will be required for missed overrides, or incorrect conversions
Note: A recent bitbake is required:
commit 75fad23fc06c008a03414a1fc288a8614c6af9ca
Author: Richard Purdie <richard.purdie@linuxfoundation.org>
Date: Sun Jul 18 12:59:15 2021 +0100
bitbake: data_smart/parse: Allow ':' characters in variable/function names
It is becomming increasingly clear we need to find a way to show what
is/is not an override in our syntax. We need to do this in a way which
is clear to users, readable and in a way we can transition to.
The most effective way I've found to this is to use the ":" charater
to directly replace "_" where an override is being specified. This
includes "append", "prepend" and "remove" which are effectively special
override directives.
This patch simply adds the character to the parser so bitbake accepts
the value but maps it back to "_" internally so there is no behaviour
change.
This change is simple enough it could potentially be backported to older
version of bitbake meaning layers using the new syntax/markup could
work with older releases. Even if other no other changes are accepted
at this time and we don't backport, it does set us on a path where at
some point in future we could
require a more explict syntax.
I've tested this patch by converting oe-core/meta-yocto to the new
syntax for overrides (9000+ changes) and then seeing that builds
continue to work with this patch.
(Bitbake rev: 0dbbb4547cb2570d2ce607e9a53459df3c0ac284)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools/go/go-connections_git.bb')
-rw-r--r-- | recipes-devtools/go/go-connections_git.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/go/go-connections_git.bb b/recipes-devtools/go/go-connections_git.bb index 5d071b0a..529b99c4 100644 --- a/recipes-devtools/go/go-connections_git.bb +++ b/recipes-devtools/go/go-connections_git.bb | |||
@@ -36,4 +36,4 @@ go_connections_sysroot_preprocess () { | |||
36 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | 36 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) |
37 | } | 37 | } |
38 | 38 | ||
39 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | 39 | FILES:${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" |